summaryrefslogtreecommitdiff
path: root/packages/sqlite/sqlite3-3.2.5
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-09-16 17:17:24 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-09-16 17:17:24 +0000
commit34018942665dc27bda7a671c56549e96e728211c (patch)
treee76886c6b658aea5ec4ad4a7253f949b3328f89d /packages/sqlite/sqlite3-3.2.5
parenta7441008e144f91fecf79273a2118ea806552cf4 (diff)
sqlite: bump to 3.6.2 drop old recipes
Diffstat (limited to 'packages/sqlite/sqlite3-3.2.5')
-rw-r--r--packages/sqlite/sqlite3-3.2.5/.mtn2git_empty0
-rw-r--r--packages/sqlite/sqlite3-3.2.5/cross-compile.patch84
-rw-r--r--packages/sqlite/sqlite3-3.2.5/ldflags.patch77
3 files changed, 0 insertions, 161 deletions
diff --git a/packages/sqlite/sqlite3-3.2.5/.mtn2git_empty b/packages/sqlite/sqlite3-3.2.5/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/sqlite/sqlite3-3.2.5/.mtn2git_empty
+++ /dev/null
diff --git a/packages/sqlite/sqlite3-3.2.5/cross-compile.patch b/packages/sqlite/sqlite3-3.2.5/cross-compile.patch
deleted file mode 100644
index aaafaa590c..0000000000
--- a/packages/sqlite/sqlite3-3.2.5/cross-compile.patch
+++ /dev/null
@@ -1,84 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
-Index: sqlite-3.2.1/configure.ac
-===================================================================
---- sqlite-3.2.1.orig/configure.ac 2005-03-23 17:08:39.000000000 +0100
-+++ sqlite-3.2.1/configure.ac 2005-04-25 23:02:40.000000000 +0200
-@@ -186,10 +186,11 @@
- default_build_cflags="-g"
- if test "$config_BUILD_CC" = ""; then
- AC_PROG_CC
-- if test "$cross_compiling" = "yes"; then
-- AC_MSG_ERROR([unable to find a compiler for building build tools])
-- fi
-- BUILD_CC=$CC
-+# if test "$cross_compiling" = "yes"; then
-+# AC_MSG_ERROR([unable to find a compiler for building build tools])
-+# fi
-+# BUILD_CC=$CC
-+ BUILD_CC=gcc
- default_build_cflags=$CFLAGS
- else
- BUILD_CC=$config_BUILD_CC
-@@ -539,55 +540,14 @@
- # Figure out what C libraries are required to compile programs
- # that use "readline()" library.
- #
--if test "$config_TARGET_READLINE_LIBS" != ""; then
-- TARGET_READLINE_LIBS="$config_TARGET_READLINE_LIBS"
--else
-- CC=$TARGET_CC
-- LIBS=""
-- AC_SEARCH_LIBS(tgetent, [readline ncurses curses termcap])
-- AC_CHECK_LIB([readline], [readline])
-- TARGET_READLINE_LIBS="$LIBS"
--fi
-+TARGET_READLINE_LIBS="-lreadline"
- AC_SUBST(TARGET_READLINE_LIBS)
-
- ##########
- # Figure out where to get the READLINE header files.
- #
--AC_MSG_CHECKING([readline header files])
--found=no
--if test "$config_TARGET_READLINE_INC" != ""; then
-- TARGET_READLINE_INC=$config_TARGET_READLINE_INC
-- found=yes
--fi
--if test "$found" = "yes"; then
-- AC_MSG_RESULT($TARGET_READLINE_INC)
--else
-- AC_MSG_RESULT(not specified: still searching...)
-- AC_CHECK_HEADER(readline.h, [found=yes])
--fi
--if test "$found" = "no"; then
-- for dir in /usr /usr/local /usr/local/readline /usr/contrib /mingw; do
-- AC_CHECK_FILE($dir/include/readline.h, found=yes)
-- if test "$found" = "yes"; then
-- TARGET_READLINE_INC="-I$dir/include"
-- break
-- fi
-- AC_CHECK_FILE($dir/include/readline/readline.h, found=yes)
-- if test "$found" = "yes"; then
-- TARGET_READLINE_INC="-I$dir/include/readline"
-- break
-- fi
-- done
--fi
--if test "$found" = "yes"; then
-- if test "$TARGET_READLINE_LIBS" = ""; then
-- TARGET_HAVE_READLINE=0
-- else
-- TARGET_HAVE_READLINE=1
-- fi
--else
-- TARGET_HAVE_READLINE=0
--fi
-+TARGET_READLINE_INC=""
-+TARGET_HAVE_READLINE=1
- AC_SUBST(TARGET_READLINE_INC)
- AC_SUBST(TARGET_HAVE_READLINE)
-
diff --git a/packages/sqlite/sqlite3-3.2.5/ldflags.patch b/packages/sqlite/sqlite3-3.2.5/ldflags.patch
deleted file mode 100644
index 7f40385f25..0000000000
--- a/packages/sqlite/sqlite3-3.2.5/ldflags.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- sqlite-3.2.5/Makefile.in~ldflags
-+++ sqlite-3.2.5/Makefile.in
-@@ -31,6 +31,10 @@
- #
- TCC = @TARGET_CC@ @TARGET_CFLAGS@ -I. -I${TOP}/src
-
-+# OE overrides
-+#
-+TARGET_LFLAGS = @TARGET_LFLAGS@
-+
- # Define -DNDEBUG to compile without debugging (i.e., for production usage)
- # Omitting the define will cause extra debugging code to be inserted and
- # includes extra comments when "EXPLAIN stmt" is used.
-@@ -235,17 +239,17 @@
- | awk '{print $$5,$$6}' >last_change
-
- libsqlite3.la: $(LIBOBJ)
-- $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(LIBPTHREAD) \
-+ $(LTLINK) -o libsqlite3.la $(LIBOBJ) $(TARGET_LFLAGS) $(LIBPTHREAD) \
- ${ALLOWRELEASE} -rpath $(libdir) -version-info "8:6:8"
-
- libtclsqlite3.la: tclsqlite.lo libsqlite3.la
- $(LTLINK) -o libtclsqlite3.la tclsqlite.lo \
-- $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(LIBPTHREAD) \
-+ $(LIBOBJ) @TCL_STUB_LIB_SPEC@ $(TARGET_LFLAGS) $(LIBPTHREAD) \
- -rpath $(libdir)/sqlite \
- -version-info "8:6:8"
-
- sqlite3$(TEXE): $(TOP)/src/shell.c libsqlite3.la sqlite3.h
-- $(LTLINK) $(READLINE_FLAGS) $(LIBPTHREAD) \
-+ $(LTLINK) $(TARGET_LFLAGS) $(READLINE_FLAGS) $(LIBPTHREAD) \
- -o sqlite3 $(TOP)/src/shell.c libsqlite3.la $(LIBREADLINE)
-
- # This target creates a directory named "tsrc" and fills it with
-@@ -419,18 +423,18 @@
-
- tclsqlite3: tclsqlite-shell.lo libsqlite3.la
- $(LTLINK) -o tclsqlite3 tclsqlite-shell.lo \
-- libsqlite3.la $(LIBTCL)
-+ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
-
- testfixture$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC)
- $(LTLINK) -DTCLSH=1 -DSQLITE_TEST=1 $(TEMP_STORE) \
- -o testfixture $(TESTSRC) $(TOP)/src/tclsqlite.c \
-- libsqlite3.la $(LIBTCL)
-+ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
-
- crashtest$(TEXE): $(TOP)/src/tclsqlite.c libsqlite3.la $(TESTSRC) $(TOP)/src/os_test.c
- $(LTLINK) -DOS_TEST=1 -DTCLSH=1 -DSQLITE_TEST=1 \
- -o crashtest \
- $(TESTSRC) $(TOP)/src/os_test.c $(TOP)/src/tclsqlite.c \
-- libsqlite3.la $(LIBTCL)
-+ libsqlite3.la $(TARGET_LFLAGS) $(LIBTCL)
-
-
-
---- sqlite-3.2.5/configure.ac~ldflags
-+++ sqlite-3.2.5/configure.ac
-@@ -238,6 +238,13 @@
- TARGET_LINK=$config_TARGET_LINK
- fi
- AC_MSG_RESULT($TARGET_LINK)
-+AC_MSG_CHECKING([switches on the target linker])
-+if test "$config_TARGET_LFLAGS" != ""; then
-+ TARGET_LFLAGS=$config_TARGET_LFLAGS
-+else
-+ TARGET_LFLAGS=$BUILD_LFLAGS
-+fi
-+AC_MSG_RESULT($TARGET_LFLAGS)
- AC_MSG_CHECKING([switches on the target compiler])
- if test "$config_TARGET_TFLAGS" != ""; then
- TARGET_TFLAGS=$config_TARGET_TFLAGS