summaryrefslogtreecommitdiff
path: root/packages/sphinx
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-06-18 18:01:32 +0000
committerKoen Kooi <koen@openembedded.org>2008-06-18 18:01:32 +0000
commitd6e148309f18b80720dd394c39a6d48a925c48a2 (patch)
treef047de559d76c0cb08cc186f604bf4cd1a5d5d22 /packages/sphinx
parent284125854fb39564f2e9b625afcc6a59c4367763 (diff)
sphinx: update to latest release
Diffstat (limited to 'packages/sphinx')
-rw-r--r--packages/sphinx/pocketsphinx_0.4.1.bb13
-rw-r--r--packages/sphinx/sphinx-fpu.inc6
-rw-r--r--packages/sphinx/sphinxbase_0.1.bb5
-rw-r--r--packages/sphinx/sphinxbase_0.3.bb14
4 files changed, 36 insertions, 2 deletions
diff --git a/packages/sphinx/pocketsphinx_0.4.1.bb b/packages/sphinx/pocketsphinx_0.4.1.bb
new file mode 100644
index 0000000000..813146ed86
--- /dev/null
+++ b/packages/sphinx/pocketsphinx_0.4.1.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "CMU PocketSphinx - speech recognition engine for handhelds"
+HOMEPAGE = "http://www.speech.cs.cmu.edu/pocketsphinx/"
+LICENSE = "BSD"
+DEPENDS = "sphinxbase"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/${PN}-${PV}.tar.bz2 \
+ file://cross-compile.patch;patch=1"
+
+inherit autotools
+
+do_configure () {
+ CPPFLAGS="-I${STAGING_INCDIR}/sphinxbase" oe_runconf
+}
diff --git a/packages/sphinx/sphinx-fpu.inc b/packages/sphinx/sphinx-fpu.inc
new file mode 100644
index 0000000000..73ae2ec16e
--- /dev/null
+++ b/packages/sphinx/sphinx-fpu.inc
@@ -0,0 +1,6 @@
+
+def get_sphinx_fpu_setting(bb, d):
+ if bb.data.getVar('TARGET_FPU', d, 1) in [ 'soft' ]:
+ return "--enable-fixed"
+ return ""
+
diff --git a/packages/sphinx/sphinxbase_0.1.bb b/packages/sphinx/sphinxbase_0.1.bb
index 1ee41cc485..2830b9010a 100644
--- a/packages/sphinx/sphinxbase_0.1.bb
+++ b/packages/sphinx/sphinxbase_0.1.bb
@@ -2,11 +2,12 @@ DESCRIPTION = "Base library for CMU Sphinx speech recognition engines"
HOMEPAGE = "http://www.speech.cs.cmu.edu/pocketsphinx/"
LICENSE = "BSD"
-SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/sphinxbase-0.1.tar.bz2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/sphinxbase-${PV}.tar.bz2"
inherit autotools
-EXTRA_OECONF = "--enable-fixed"
+require sphinx-fpu.inc
+EXTRA_OECONF += "${@get_sphinx_fpu_setting(bb, d)}"
do_stage () {
autotools_stage_all
diff --git a/packages/sphinx/sphinxbase_0.3.bb b/packages/sphinx/sphinxbase_0.3.bb
new file mode 100644
index 0000000000..2830b9010a
--- /dev/null
+++ b/packages/sphinx/sphinxbase_0.3.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Base library for CMU Sphinx speech recognition engines"
+HOMEPAGE = "http://www.speech.cs.cmu.edu/pocketsphinx/"
+LICENSE = "BSD"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/cmusphinx/sphinxbase-${PV}.tar.bz2"
+
+inherit autotools
+
+require sphinx-fpu.inc
+EXTRA_OECONF += "${@get_sphinx_fpu_setting(bb, d)}"
+
+do_stage () {
+ autotools_stage_all
+}