summaryrefslogtreecommitdiff
path: root/packages/speechd/speechd_0.56.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2008-01-01 23:00:11 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2008-01-01 23:00:11 +0000
commite411fc33b72ba7667737f6cf89c2ba04231e0113 (patch)
treeb5fad96718c48095cb4817ae482ffc02a5654c9f /packages/speechd/speechd_0.56.bb
parente3c141ea4201fdd6109eddfff23a0f825cd18469 (diff)
parent8f9e46740b16defbebb955752a317137121e0b85 (diff)
merge of '560f1294e1ef2699d2b80c98d99386c3030b8c0b'
and '7dc115a2ce1cbe29ae1b44dad5546d16e4a5e4dd'
Diffstat (limited to 'packages/speechd/speechd_0.56.bb')
-rw-r--r--packages/speechd/speechd_0.56.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/speechd/speechd_0.56.bb b/packages/speechd/speechd_0.56.bb
new file mode 100644
index 0000000000..3b58609e8d
--- /dev/null
+++ b/packages/speechd/speechd_0.56.bb
@@ -0,0 +1,40 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2007
+# License: MIT (see http://www.opensource.org/licenses/mit-license.php
+# for a copy of the license)
+#
+# Filename: speechd_0.56.bb
+# Date: 20071231 (YMD)
+
+DESCRIPTION = "speechd implements /dev/speech"
+HOMEPAGE = "http://www.speechio.org/"
+SECTION = "base"
+LICENSE = "GPL"
+
+PR = "r0"
+
+######################################################################################
+
+
+SRC_URI = "http://www.speechio.org/dl/speechd-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}"
+
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/bin
+ install -d ${D}/etc
+ install -d ${D}/usr/share/man/man1
+
+ install -m 0755 ${S}/bin/catspeech ${D}/bin/catspeech
+ install -m 0755 ${S}/bin/speechd ${D}/bin/speechd
+
+ install -m 0644 ${S}/speechdrc ${D}/etc
+
+ install -m 0644 ${S}/man/man1/catspeech.1 ${D}/usr/share/man/man1
+ install -m 0644 ${S}/man/man1/speechd.1 ${D}/usr/share/man/man1
+}