summaryrefslogtreecommitdiff
path: root/packages/spca5xx/spca5xx_20060202.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2006-02-20 23:22:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-20 23:22:57 +0000
commitcbde8cbe425ff9c1d24c009a6a785327d8bbee5b (patch)
tree582bc10b82e1fcd9ca987c66dde11d3f27d7f209 /packages/spca5xx/spca5xx_20060202.bb
parent6eb8cc0af2e64afa5ee55236a10cc14c8e7bf604 (diff)
parent89d74ede96d6986ea831ef28d513f60f58b306f5 (diff)
merge of 623eed7c92806a0e18e3daa7e8dee2edd301a94e
and d7c8c3fb9c9b65e500f2c9ffb52d588c15efa14b
Diffstat (limited to 'packages/spca5xx/spca5xx_20060202.bb')
-rw-r--r--packages/spca5xx/spca5xx_20060202.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/spca5xx/spca5xx_20060202.bb b/packages/spca5xx/spca5xx_20060202.bb
new file mode 100644
index 0000000000..a5798f5b59
--- /dev/null
+++ b/packages/spca5xx/spca5xx_20060202.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera""
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+MAINTAINER = "dyoung <dyoung8888@yahoo.com>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/spca5xx-20060202.tar.gz \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/spca5xx-20060202"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}
+