summaryrefslogtreecommitdiff
path: root/packages/spca5xx/spca5xx_20060202.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@yahoo.com>2006-02-20 20:32:25 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-20 20:32:25 +0000
commita953f708d91b5ec953bcce9eaec0197729891b3e (patch)
treee7c87107ddd7f79f1c0ea1429a2bfd3d3e63b6fa /packages/spca5xx/spca5xx_20060202.bb
parentba81094a28b35db729737a391e266c92ecf588e4 (diff)
spca5xx: added release 20060202 (on request, builds fine, cannot test this as I do not have this cam)
Diffstat (limited to 'packages/spca5xx/spca5xx_20060202.bb')
-rw-r--r--packages/spca5xx/spca5xx_20060202.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/spca5xx/spca5xx_20060202.bb b/packages/spca5xx/spca5xx_20060202.bb
new file mode 100644
index 0000000000..a5798f5b59
--- /dev/null
+++ b/packages/spca5xx/spca5xx_20060202.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "USB Webcam driver for spca5xx chipset family supporting \
+over 100 models of camera""
+PRIORITY = "optional"
+SECTION = "kernel/modules"
+MAINTAINER = "dyoung <dyoung8888@yahoo.com>"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://mxhaard.free.fr/spca50x/Download/spca5xx-20060202.tar.gz \
+ file://Makefile.patch;patch=1"
+
+S = "${WORKDIR}/spca5xx-20060202"
+
+inherit module
+
+do_compile () {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ oe_runmake 'KERNELDIR=${STAGING_KERNEL_DIR}' \
+ 'CC=${KERNEL_CC}' \
+ 'LD=${KERNEL_LD}'
+}
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/media
+}
+