summaryrefslogtreecommitdiff
path: root/packages/sparse
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/sparse
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/sparse')
-rw-r--r--packages/sparse/files/compile.patch16
-rw-r--r--packages/sparse/files/vars.patch42
-rw-r--r--packages/sparse/sparse_snapshot.bb25
3 files changed, 0 insertions, 83 deletions
diff --git a/packages/sparse/files/compile.patch b/packages/sparse/files/compile.patch
deleted file mode 100644
index f19d521335..0000000000
--- a/packages/sparse/files/compile.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- sparse-bk/expression.c~compile 2004-09-13 17:42:22.642639000 -0400
-+++ sparse-bk/expression.c 2004-09-13 17:44:59.147847520 -0400
-@@ -8,7 +8,7 @@
- *
- * This is the expression parsing part of parsing C.
- */
--#define _ISOC99_SOURCE
-+//#define _ISOC99_SOURCE
- #include <stdarg.h>
- #include <stdlib.h>
- #include <stdio.h>
diff --git a/packages/sparse/files/vars.patch b/packages/sparse/files/vars.patch
deleted file mode 100644
index 353df2ad0b..0000000000
--- a/packages/sparse/files/vars.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- sparse-bk/Makefile~vars 2004-09-13 17:45:43.304134000 -0400
-+++ sparse-bk/Makefile 2004-09-13 17:46:04.980839384 -0400
-@@ -1,4 +1,5 @@
- CC=gcc
-+CCLD=gcc
- CFLAGS=-O -g -Wall
- LDFLAGS=-g
- AR=ar
-@@ -26,22 +27,22 @@
- if test $< -nt $(PREFIX)/bin/sparse ; then install -v $< $(PREFIX)/bin/sparse ; fi
-
- test-lexing: test-lexing.o $(LIB_FILE)
-- gcc $(LDFLAGS) -o $@ $< $(LIBS)
-+ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
-
- test-parsing: test-parsing.o $(LIB_FILE)
-- gcc $(LDFLAGS) -o $@ $< $(LIBS)
-+ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
-
- test-linearize: test-linearize.o $(LIB_FILE)
-- gcc $(LDFLAGS) -o $@ $< $(LIBS)
-+ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
-
- compile: compile.o compile-i386.o $(LIB_FILE)
-- gcc $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
-+ $(CCLD) $(LDFLAGS) -o $@ $< compile-i386.o $(LIBS)
-
- obfuscate: obfuscate.o $(LIB_FILE)
-- gcc $(LDFLAGS) -o $@ $< $(LIBS)
-+ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
-
- check: check.o $(LIB_FILE)
-- gcc $(LDFLAGS) -o $@ $< $(LIBS)
-+ $(CCLD) $(LDFLAGS) -o $@ $< $(LIBS)
-
- $(LIB_FILE): $(LIB_OBJS)
- $(AR) rcs $(LIB_FILE) $(LIB_OBJS)
diff --git a/packages/sparse/sparse_snapshot.bb b/packages/sparse/sparse_snapshot.bb
deleted file mode 100644
index 6a913d69ec..0000000000
--- a/packages/sparse/sparse_snapshot.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-SECTION = "devel"
-def get_snapshot_date(d):
- import bb
- srcdate = bb.data.getVar('SRCDATE', d, 1)
- if not srcdate:
- return ""
- y = srcdate[0:4]
- m = srcdate[4:6]
- d = srcdate[6:8]
- return "%s-%s-%s" % (y, m, d)
-
-DESCRIPTION = "Sparse is a semantic parser of source files: it's neither a \
-compiler (although it could be used as a front-end for one) nor is it a \
-preprocessor (although it contains as a part of it a preprocessing phase)."
-PV = "0.0+${SRCDATE}"
-LICENSE = "OSL"
-SRC_URI = "http://www.codemonkey.org.uk/projects/git-snapshots/sparse/sparse-${@get_snapshot_date(d)}.tar.gz \
- file://compile.patch;patch=1 \
- file://vars.patch;patch=1"
-S = "${WORKDIR}/sparse-bk"
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 check ${D}${bindir}/sparse
-}