summaryrefslogtreecommitdiff
path: root/packages/socat
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/socat
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/socat')
-rw-r--r--packages/socat/socat-1.3.2.1/ldflags.patch32
-rw-r--r--packages/socat/socat-1.3.2.1/xioinitialize.patch52
-rw-r--r--packages/socat/socat-1.3.2.1/xioopen.patch11
-rw-r--r--packages/socat/socat_1.3.2.1.bb20
4 files changed, 0 insertions, 115 deletions
diff --git a/packages/socat/socat-1.3.2.1/ldflags.patch b/packages/socat/socat-1.3.2.1/ldflags.patch
deleted file mode 100644
index 6ab4681383..0000000000
--- a/packages/socat/socat-1.3.2.1/ldflags.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-
-#
-# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
-#
-
---- socat-1.3/Makefile.in~ldflags
-+++ socat-1.3/Makefile.in
-@@ -33,6 +33,7 @@
-
-
- CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(INCLS)
-+LDFLAGS = @LDFLAGS@
- CLIBS = $(LIBS)
- #CLIBS = $(LIBS) -lm -lefence
- XIOSRCS = xioinitialize.c xiohelp.c xioparam.c xiodiag.c xioopen.c xioopts.c xiosigchld.c xioread.c xiowrite.c \
-@@ -78,13 +79,13 @@
- makedepend @SYSDEFS@ $(CFILES)
-
- socat: socat.o libxio.a
-- $(CC) $(CFLAGS) -o $@ socat.o libxio.a $(CLIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ socat.o libxio.a $(CLIBS)
-
- procan: procan_main.o procan.o error.o sycls.o sysutils.o utils.o
-- $(CC) $(CFLAGS) -o $@ procan_main.o procan.o error.o sycls.o sysutils.o utils.o $(CLIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ procan_main.o procan.o error.o sycls.o sysutils.o utils.o $(CLIBS)
-
- filan: filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o
-- $(CC) $(CFLAGS) -o $@ filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o $(CLIBS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ filan_main.o filan.o fdname.o error.o sycls.o sysutils.o utils.o $(CLIBS)
-
- libxio.a: $(XIOOBJS) $(UTLOBJS)
- $(AR) r $@ $(XIOOBJS) $(UTLOBJS)
diff --git a/packages/socat/socat-1.3.2.1/xioinitialize.patch b/packages/socat/socat-1.3.2.1/xioinitialize.patch
deleted file mode 100644
index 24e816cfd7..0000000000
--- a/packages/socat/socat-1.3.2.1/xioinitialize.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-diff -Naur socat-1.3/xioinitialize.c socat-1.3_patched/xioinitialize.c
---- socat-1.3/xioinitialize.c 2003-05-23 08:24:53.000000000 +0200
-+++ socat-1.3_patched/xioinitialize.c 2006-09-09 18:18:19.000000000 +0200
-@@ -19,48 +19,10 @@
- assert(O_WRONLY==1);
- assert(O_RDWR==2);
-
-- /* some assertions about termios */
--#if WITH_TERMIOS
--#ifdef CRDLY
-- assert(3 << opt_crdly.arg3 == CRDLY);
--#endif
--#ifdef TABDLY
-- assert(3 << opt_tabdly.arg3 == TABDLY);
--#endif
-- assert(3 << opt_csize.arg3 == CSIZE);
-- {
-- union {
-- struct termios termarg;
-- tcflag_t flags[4];
--#if HAVE_TERMIOS_ISPEED
-- speed_t speeds[sizeof(struct termios)/sizeof(speed_t)];
--#endif
-- } tdata;
-- tdata.termarg.c_iflag = 0x12345678;
-- tdata.termarg.c_oflag = 0x23456789;
-- tdata.termarg.c_cflag = 0x3456789a;
-- tdata.termarg.c_lflag = 0x456789ab;
-- assert(tdata.termarg.c_iflag == tdata.flags[0]);
-- assert(tdata.termarg.c_oflag == tdata.flags[1]);
-- assert(tdata.termarg.c_cflag == tdata.flags[2]);
-- assert(tdata.termarg.c_lflag == tdata.flags[3]);
--#if HAVE_TERMIOS_ISPEED
-- tdata.termarg.c_ispeed = 0x56789abc;
-- tdata.termarg.c_ospeed = 0x6789abcd;
-- assert(tdata.termarg.c_ispeed == tdata.speeds[ISPEED_OFFSET]);
-- assert(tdata.termarg.c_ospeed == tdata.speeds[OSPEED_OFFSET]);
--#endif
-- }
--#endif
--
- /* these dependencies required in applyopts() for OFUNC_FCNTL */
- assert(F_GETFD == F_SETFD-1);
- assert(F_GETFL == F_SETFL-1);
-
-- if (Atexit(xioexit) < 0) {
-- Error("atexit(xioexit) failed");
-- return -1;
-- }
- xioinitialized = 1;
- return 0;
- }
diff --git a/packages/socat/socat-1.3.2.1/xioopen.patch b/packages/socat/socat-1.3.2.1/xioopen.patch
deleted file mode 100644
index 456862653a..0000000000
--- a/packages/socat/socat-1.3.2.1/xioopen.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur socat-1.3/xioopen.h socat-1.3_patched/xioopen.h
---- socat-1.3/xioopen.h 2003-02-15 15:26:22.000000000 +0100
-+++ socat-1.3_patched/xioopen.h 2006-09-05 10:49:15.000000000 +0200
-@@ -42,7 +42,6 @@
- extern const char *ddirection[];
- extern const char *filetypenames[];
- extern const struct addrname addressnames[];
--extern const char *addressgroupnames[];
- extern const struct optname optionnames[];
-
- extern int xioopen_makedual(xiofile_t *file);
diff --git a/packages/socat/socat_1.3.2.1.bb b/packages/socat/socat_1.3.2.1.bb
deleted file mode 100644
index 612987858b..0000000000
--- a/packages/socat/socat_1.3.2.1.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-SECTION = "console/network"
-DEPENDS = "openssl"
-DESCRIPTION = "Socat is a relay for bidirectional data \
-transfer between two independent data channels."
-LICENSE = "GPL"
-PR = "r1"
-
-SRC_URI = "http://www.dest-unreach.org/socat/download/socat-${PV}.tar.bz2 \
- file://xioopen.patch;patch=1 \
- file://ldflags.patch;patch=1 \
- file://xioinitialize.patch;patch=1"
-
-S = "${WORKDIR}/socat-1.3"
-
-inherit autotools
-
-do_install_prepend () {
- mkdir -p ${D}${bindir}
- install -d ${D}${bindir} ${D}${mandir}/man1
-}