summaryrefslogtreecommitdiff
path: root/packages/slugos-init
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-02-06 09:02:33 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-06 09:02:33 +0000
commit23d84f45ff8f5a03695c1cd0e1dac0d1d3390b96 (patch)
tree27112b3fe3bf10e0601be53fdfcc99b84130fb12 /packages/slugos-init
parent0d9012187fcb9d4d5efb3fa7960f984d9de102bb (diff)
parentd2449f188c1d5b589a2e26dd044d3c717e36cb42 (diff)
merge of 0dcf135f8174d6cb8b709f2104158f5de5fa769d
and 6e0b7038969c91f76744d47455957a8284414e7d
Diffstat (limited to 'packages/slugos-init')
-rw-r--r--packages/slugos-init/files/boot/disk8
-rw-r--r--packages/slugos-init/files/functions14
-rw-r--r--packages/slugos-init/files/leds5
-rw-r--r--packages/slugos-init/slugos-init_0.10.bb2
4 files changed, 21 insertions, 8 deletions
diff --git a/packages/slugos-init/files/boot/disk b/packages/slugos-init/files/boot/disk
index 6077a92ffe..724dc3af5d 100644
--- a/packages/slugos-init/files/boot/disk
+++ b/packages/slugos-init/files/boot/disk
@@ -29,12 +29,10 @@ then
mount "$@" -U "$UUID" /mnt ||
mount "$@" "$device" /mnt
then
- # checkmount checks for sh, init and no
- # .recovery plus either mnt or initrd
- if checkmount /mnt && :>/mnt/.recovery
+ # checkmount checks for sh, chroot, init
+ # and /mnt (i.e. /mnt/mnt in this case)
+ if checkmount /mnt
then
- # sync to ensure .recovery is written
- sync
# pivot to /initrd if available, else /mnt
cd /
if test -d /mnt/initrd
diff --git a/packages/slugos-init/files/functions b/packages/slugos-init/files/functions
index ef10d65fb2..78dcf816b3 100644
--- a/packages/slugos-init/files/functions
+++ b/packages/slugos-init/files/functions
@@ -26,6 +26,20 @@ machine(){
esac
}
#
+# single_user_ok
+# if the machine is capable of single user interaction return
+# true, else return false. The result of this function is
+# preempted by setting SULOGIN to 'yes' or 'ok' in /etc/default/rcS
+single_user_ok() {
+ # list known good machines in the 'case'
+ test "$SULOGIN" = yes -o "$SULOGIN" = ok ||
+ case "$(machine)" in
+ ixdp*|avila|loft)
+ test "$SULOGIN" != never;;
+ *) return 1;;
+ esac
+}
+#
# load_functions "source"
# load the functions in '/sbin/source' - relies on /sbin/source being
# a shell script and having support for this function.
diff --git a/packages/slugos-init/files/leds b/packages/slugos-init/files/leds
index 227ed78ff4..433467b96f 100644
--- a/packages/slugos-init/files/leds
+++ b/packages/slugos-init/files/leds
@@ -169,7 +169,8 @@ sysled(){
#
# beep {arguments}
# emit a beep
-# does nothing if there is no beep executable
+# does nothing if there is no beep executable, is very
+# quiet in the presence of errors
beep(){
local arg
arg=
@@ -177,7 +178,7 @@ beep(){
if test -x /bin/beep
then
test -c /dev/buzzer && arg="-e /dev/buzzer"
- /bin/beep $arg "$@"
+ /bin/beep $arg "$@" 2>/dev/null
fi
return 0
}
diff --git a/packages/slugos-init/slugos-init_0.10.bb b/packages/slugos-init/slugos-init_0.10.bb
index 7c4c21f521..ed183b9278 100644
--- a/packages/slugos-init/slugos-init_0.10.bb
+++ b/packages/slugos-init/slugos-init_0.10.bb
@@ -4,7 +4,7 @@ PRIORITY = "required"
LICENSE = "GPL"
DEPENDS = "base-files devio"
RDEPENDS = "busybox devio"
-PR = "r54"
+PR = "r56"
SRC_URI = "file://boot/flash \
file://boot/disk \