summaryrefslogtreecommitdiff
path: root/packages/skippy/files
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/skippy/files
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/skippy/files')
-rw-r--r--packages/skippy/files/.mtn2git_empty0
-rw-r--r--packages/skippy/files/event_base.patch11
-rw-r--r--packages/skippy/files/fix-makefile.patch37
3 files changed, 48 insertions, 0 deletions
diff --git a/packages/skippy/files/.mtn2git_empty b/packages/skippy/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/skippy/files/.mtn2git_empty
diff --git a/packages/skippy/files/event_base.patch b/packages/skippy/files/event_base.patch
index e69de29bb2..20632edf15 100644
--- a/packages/skippy/files/event_base.patch
+++ b/packages/skippy/files/event_base.patch
@@ -0,0 +1,11 @@
+--- skippy-xd-0.5.0/mainwin.c.old 2005-04-29 03:54:32 +01:00
++++ skippy-xd-0.5.0/mainwin.c 2005-04-29 03:55:06 +01:00
+@@ -67,7 +67,7 @@
+ XRenderPictureAttributes pa;
+ XRenderColor clear;
+ int error_base;
+-#ifdef XINERAMA
++#if 1
+ int event_base;
+ #endif /* XINERAMA */
+
diff --git a/packages/skippy/files/fix-makefile.patch b/packages/skippy/files/fix-makefile.patch
index e69de29bb2..843be52467 100644
--- a/packages/skippy/files/fix-makefile.patch
+++ b/packages/skippy/files/fix-makefile.patch
@@ -0,0 +1,37 @@
+--- skippy-xd-0.5.0/Makefile.old 2005-04-29 03:42:33 +01:00
++++ skippy-xd-0.5.0/Makefile 2005-04-29 03:45:21 +01:00
+@@ -1,17 +1,17 @@
+-PREFIX = /usr/local
+-BINDIR = ${PREFIX}/bin
++#PREFIX = /usr
++#BINDIR = ${PREFIX}/bin
+
+-X11PREFIX = /usr/X11R6
++#X11PREFIX = /usr/X11R6
+
+-CFLAGS += -I${X11PREFIX}/include `pkg-config xft xrender xcomposite xdamage xfixes --cflags` -g -pedantic -Wall
+-LDFLAGS += -L${X11PREFIX}/lib -lX11 -lm `pkg-config xft xrender xcomposite xdamage xfixes --libs`
++CFLAGS += `${PKG_CONFIG} xft xrender xcomposite xdamage xfixes --cflags` -Wall
++LDFLAGS += -lX11 -lm `${PKG_CONFIG} xft xrender xcomposite xdamage xfixes --libs`
+
+ # Disable post-processing effects
+-# CFLAGS += -DNOEFFECTS
++CFLAGS += -DNOEFFECTS
+
+ # Comment these out to disable Xinerama support
+-CFLAGS += -DXINERAMA
+-LDFLAGS += -lXext -lXinerama
++#CFLAGS += -DXINERAMA
++#LDFLAGS += -lXext -lXinerama
+
+ # Uncomment this for Xinerama debugging
+ #CFLAGS += -DDEBUG
+@@ -24,7 +24,7 @@
+ all: skippy-xd${EXESUFFIX}
+
+ skippy-xd${EXESUFFIX}: Makefile ${SOURCES} ${HEADERS}
+- gcc ${CFLAGS} -o skippy-xd${EXESUFFIX} ${SOURCES} ${LDFLAGS}
++ ${CC} ${CFLAGS} -o skippy-xd${EXESUFFIX} ${SOURCES} ${LDFLAGS}
+
+ clean:
+ rm -f skippy-xd${EXESUFFIX}