summaryrefslogtreecommitdiff
path: root/packages/sip/sip-native_4.7.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-19 11:37:30 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-19 11:37:30 +0000
commit6c6ccd4ae6c5c0347bef1f78ecb4699bf1b95350 (patch)
tree2c4e6478d66d3c6e3b6025774aca3d6084bda044 /packages/sip/sip-native_4.7.bb
parent9feb3c3ffe516efe8205d0f6c99af3a22d5c8115 (diff)
sip/python-sip/python-pyqt: revamp naming, start to work on a current PyQt that builds against Qt-X11 4.3.0
Diffstat (limited to 'packages/sip/sip-native_4.7.bb')
-rw-r--r--packages/sip/sip-native_4.7.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/sip/sip-native_4.7.bb b/packages/sip/sip-native_4.7.bb
new file mode 100644
index 0000000000..08cdae4ead
--- /dev/null
+++ b/packages/sip/sip-native_4.7.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
+SECTION = "devel"
+HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+AUTHOR = "Phil Thompson"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://www.riverbankcomputing.com/Downloads/sip4/sip-${PV}.tar.gz"
+S = "${WORKDIR}/sip-${PV}/sipgen"
+
+inherit qmake qt4x11 native
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
+
+do_configure_prepend() {
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+}
+
+do_stage() {
+ install -m 0755 sip ${STAGING_BINDIR}/sip4
+ cd ${WORKDIR}/sip-${PV} && python configure.py
+ install -d ${STAGING_PYDIR}/site-packages
+ install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
+}
+