summaryrefslogtreecommitdiff
path: root/packages/shasum/shasum-native.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-04-02 15:59:35 +0000
committerHolger Freyther <zecke@selfish.org>2007-04-02 15:59:35 +0000
commit40896f4a8f30bc6459fd7147aa43f4ccb4cb2146 (patch)
tree1e55faa501faa675e5ce9ca08c6a47c551dd6543 /packages/shasum/shasum-native.bb
parente7e153b6e9e35a376f1418a4239ad52a4716c40e (diff)
packages/shasum: Add a sha256sum utility with little dependencies
To avoid weird requirements add a sha256sum tool to OpenEmbedded directly. This will be part of the OE manifest and be guarded by the monotone OE trust chain.
Diffstat (limited to 'packages/shasum/shasum-native.bb')
-rw-r--r--packages/shasum/shasum-native.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/packages/shasum/shasum-native.bb b/packages/shasum/shasum-native.bb
new file mode 100644
index 0000000000..9a4b42c64a
--- /dev/null
+++ b/packages/shasum/shasum-native.bb
@@ -0,0 +1,7 @@
+require shasum.inc
+
+inherit native
+
+do_populate_staging() {
+ install ${S}/sha256sum ${STAGING_BINDIR}
+}