summaryrefslogtreecommitdiff
path: root/packages/sharp-binary-only/sharp-sdmmc-support.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-02-08 15:38:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-08 15:38:08 +0000
commit1629da56a64f1323816dbe9d051b82c8348bb6f2 (patch)
treeab50a0210801914c4afafd3af0a28a1e1838da0e /packages/sharp-binary-only/sharp-sdmmc-support.bb
parent4944b24faa03ad5bed435b4a56022cb5b95279b3 (diff)
sharp-sdmmc-support: added some tweaks to fix #653
- /etc/init.d/sd use insmod instead of modprobe to load module (we do not have modules.dep at this moment) - module filename is defined in /etc/default/sharp_sdmmc - renamed recipe as it give false info being only for 2.4.18 - PV of package is set correct to KERNEL_VERSION (no more 2.4.18-rmk7-pxa3-embedix on 2.4.20 machines) taken from .oz354fam083
Diffstat (limited to 'packages/sharp-binary-only/sharp-sdmmc-support.bb')
-rw-r--r--packages/sharp-binary-only/sharp-sdmmc-support.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/sharp-binary-only/sharp-sdmmc-support.bb b/packages/sharp-binary-only/sharp-sdmmc-support.bb
new file mode 100644
index 0000000000..d54402efd3
--- /dev/null
+++ b/packages/sharp-binary-only/sharp-sdmmc-support.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Driver for the SHARP Zaurus SD/MMC Slot for linux ${KERNEL_VERSION}"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "CLOSED"
+RDEPENDS = "kernel (${KERNEL_VERSION})"
+PV = "${KERNEL_VERSION}"
+PR = "r22"
+PACKAGE_ARCH = "${MACHINE}"
+
+SRC_URI = "http://www.openzaurus.org/mirror/sd-modules-2.4.18-rmk7-pxa3-embedix-r4.tar.bz2 \
+ file://sd \
+ file://sdmgr \
+ file://sdcontrol"
+
+S = "${WORKDIR}"
+
+inherit module-base update-rc.d
+
+INITSCRIPT_NAME = "sd"
+INITSCRIPT_PARAMS = "start 39 S . stop 96 0 1 6 ."
+
+do_install() {
+ install -d ${D}${sysconfdir}/init.d \
+ ${D}${sysconfdir}/default \
+ ${D}${base_sbindir} \
+ ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/
+
+ install -m 0755 ${WORKDIR}/sdmgr ${D}${base_sbindir}/
+ install -m 0755 ${WORKDIR}/sdcontrol ${D}${sysconfdir}
+ install -m 0755 ${WORKDIR}/sd ${D}${sysconfdir}/init.d/
+ install -m 0644 ${MACHINE}/sharp_mmcsd_m.o ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/
+ echo "MODULE_FILE='${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/block/sharp_mmcsd_m.o'" > ${D}${sysconfdir}/default/sharp_sdmmc
+}
+
+FILES_${PN} = "/"