summaryrefslogtreecommitdiff
path: root/packages/sgml-common/sgml-common_0.6.3.bb
diff options
context:
space:
mode:
authorRobert Schuster <thebohemian@gmx.net>2007-12-31 11:50:13 +0000
committerRobert Schuster <thebohemian@gmx.net>2007-12-31 11:50:13 +0000
commit4875f9bd2c47f8cdc40c5fd70012e262f8be4934 (patch)
tree9ca93b2b8e7c1b6dd091490ad33119df0e4fe4f0 /packages/sgml-common/sgml-common_0.6.3.bb
parent275f358d054ba5c4721cfe87edaec8202ee8095e (diff)
PR 3656
docbook-dsssl-stylesheets-native: New recipe. docbook-sgml-dtd-native: New recipe. docbook-utils-native 0.6.14: Added recipe for new version. docbook-utils 0.6.14: Added recipe for new version. openjade-native: Made functional from native staging location - fixed compilation error opensp-native: Made functional from native staging location. sgml-common-native 0.6.3: Made functional from native staging location. sgml-common 0.6.3: Added pkginstall and pkgpostinstall.
Diffstat (limited to 'packages/sgml-common/sgml-common_0.6.3.bb')
-rw-r--r--packages/sgml-common/sgml-common_0.6.3.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/sgml-common/sgml-common_0.6.3.bb b/packages/sgml-common/sgml-common_0.6.3.bb
index 8b9fd5aeda..3454b1cb01 100644
--- a/packages/sgml-common/sgml-common_0.6.3.bb
+++ b/packages/sgml-common/sgml-common_0.6.3.bb
@@ -14,3 +14,29 @@ SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/sgml-co
file://autohell.patch;patch=1"
inherit autotools
+
+do_compile_append() {
+ # install-catalog script contains hardcoded reference to /etc/sgml.
+ sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/install-catalog
+}
+
+pkg_postinst() {
+ install-catalog \
+ --add ${sysconfdir}/sgml/sgml-ent.cat \
+ ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
+
+ install-catalog \
+ --add ${sysconfdir}/sgml/sgml-docbook.cat \
+ ${sysconfdir}/sgml/sgml-ent.cat
+}
+
+pkg_postrm() {
+ install-catalog \
+ --remove ${sysconfdir}/sgml/sgml-ent.cat \
+ ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
+
+ install-catalog \
+ --remove ${sysconfdir}/sgml/sgml-docbook.cat \
+ ${sysconfdir}/sgml/sgml-ent.cat
+}
+