summaryrefslogtreecommitdiff
path: root/packages/serial-utils
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-16 08:12:33 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-16 08:12:33 +0000
commit4fe64e497bb8af2ca8298c7b5af3f52d68e0467d (patch)
treed3fcccc25c3024cc8aec0f4a96eea1713609a27c /packages/serial-utils
parent4a5149ccbb13a8425e672d4c1b82754456b747ed (diff)
remove deprecated openmoko stuff, it's no longer buildable anyways
Diffstat (limited to 'packages/serial-utils')
-rw-r--r--packages/serial-utils/.mtn2git_empty0
-rw-r--r--packages/serial-utils/pty-forward-native.bb24
-rw-r--r--packages/serial-utils/serial-forward.bb15
3 files changed, 39 insertions, 0 deletions
diff --git a/packages/serial-utils/.mtn2git_empty b/packages/serial-utils/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/serial-utils/.mtn2git_empty
diff --git a/packages/serial-utils/pty-forward-native.bb b/packages/serial-utils/pty-forward-native.bb
new file mode 100644
index 0000000000..972070d6b6
--- /dev/null
+++ b/packages/serial-utils/pty-forward-native.bb
@@ -0,0 +1,24 @@
+LICENSE="GPL"
+SUMMARY="Receive a forwarded serial from serial-forward and provide a PTY"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S = "${WORKDIR}/serial_forward"
+
+inherit native
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+}
+
+addtask deploy before do_package after do_install
+
diff --git a/packages/serial-utils/serial-forward.bb b/packages/serial-utils/serial-forward.bb
new file mode 100644
index 0000000000..3cc33770d6
--- /dev/null
+++ b/packages/serial-utils/serial-forward.bb
@@ -0,0 +1,15 @@
+LICENSE="GPL"
+SUMMARY="Forward a serial using TCP/IP"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S="${WORKDIR}/serial_forward"
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/forward ${D}/${bindir}/${PN}
+}