summaryrefslogtreecommitdiff
path: root/packages/serial-utils
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-07-16 09:24:30 +0000
committerKoen Kooi <koen@openembedded.org>2008-07-16 09:24:30 +0000
commitc02b12845098ea158f4b22e949f4a966e82314a7 (patch)
tree85a53586ec22458febd56c631fc333bd916eaab9 /packages/serial-utils
parent2f11ba39ea6f6f5c239cfec189bb567404e54958 (diff)
parent3099e5f9471bf2612f39dc6faa9998e679c62351 (diff)
merge of '027df8bfceecb5d21ab2b2b76d0d191124b3446b'
and 'daafad010cbf738246a5e77122c2e1e4f951c9f5'
Diffstat (limited to 'packages/serial-utils')
-rw-r--r--packages/serial-utils/.mtn2git_empty0
-rw-r--r--packages/serial-utils/pty-forward-native.bb24
-rw-r--r--packages/serial-utils/serial-forward.bb15
3 files changed, 39 insertions, 0 deletions
diff --git a/packages/serial-utils/.mtn2git_empty b/packages/serial-utils/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/serial-utils/.mtn2git_empty
diff --git a/packages/serial-utils/pty-forward-native.bb b/packages/serial-utils/pty-forward-native.bb
new file mode 100644
index 0000000000..972070d6b6
--- /dev/null
+++ b/packages/serial-utils/pty-forward-native.bb
@@ -0,0 +1,24 @@
+LICENSE="GPL"
+SUMMARY="Receive a forwarded serial from serial-forward and provide a PTY"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S = "${WORKDIR}/serial_forward"
+
+inherit native
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_stage() {
+ :
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0755 ${S}/pty_forward ${DEPLOY_DIR_IMAGE}/pty-forward
+}
+
+addtask deploy before do_package after do_install
+
diff --git a/packages/serial-utils/serial-forward.bb b/packages/serial-utils/serial-forward.bb
new file mode 100644
index 0000000000..3cc33770d6
--- /dev/null
+++ b/packages/serial-utils/serial-forward.bb
@@ -0,0 +1,15 @@
+LICENSE="GPL"
+SUMMARY="Forward a serial using TCP/IP"
+
+SRC_URI="svn://svn.openmoko.org/developers/zecke/;module=serial_forward;proto=http"
+S="${WORKDIR}/serial_forward"
+
+do_compile() {
+ cd ${S}
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/forward ${D}/${bindir}/${PN}
+}