summaryrefslogtreecommitdiff
path: root/packages/sdlperl/Makefile.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/sdlperl/Makefile.patch
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/sdlperl/Makefile.patch')
-rw-r--r--packages/sdlperl/Makefile.patch17
1 files changed, 17 insertions, 0 deletions
diff --git a/packages/sdlperl/Makefile.patch b/packages/sdlperl/Makefile.patch
index e69de29bb2..ae20c08c77 100644
--- a/packages/sdlperl/Makefile.patch
+++ b/packages/sdlperl/Makefile.patch
@@ -0,0 +1,17 @@
+--- Makefile.linux.orig 2004-06-25 12:44:53.000000000 +0100
++++ Makefile.linux 2004-06-25 12:45:37.000000000 +0100
+@@ -119,12 +119,12 @@
+ my %options = (
+ 'NAME' => 'SDL_perl',
+ 'VERSION_FROM' => 'lib/SDL.pm',
+- 'LIBS' => [ join( " ", "$sdl_libs",
++ 'LIBS' => [ join( " ", $ENV{"LDFLAGS"}, "$sdl_libs",
+ map { $ext{$_}{exists} ? "-l$_" : '' } (sort keys %ext),
+ )
+ ],
+ 'DEFINE' => join ( " ", @defs, map { $ext{$_}{exists} ? "-D$ext{$_}{inc}" : '' } sort keys %ext),
+- 'INC' => "$inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
++ 'INC' => $ENV{"CFLAGS"} . " $inc_flags $sdl_cflags " . join(" ", map { "-I$_" } @dirs),
+ 'OBJECT' => (
+ ($ext{SDL_image}{exists} ? 'SFont.o ' : "") .
+ 'SDL_perl.o ' .