summaryrefslogtreecommitdiff
path: root/packages/samba/samba_3.3.0.bb
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-02-01 01:41:19 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-02-01 01:41:19 +0000
commit4130549e353f40093e0e0cad4362f9284ab6a293 (patch)
tree6dcd6cd4f187db7eaf8429b850e7f2c590673bce /packages/samba/samba_3.3.0.bb
parent765044d771370ab25fd0ea9c33d3734ee7d3348b (diff)
samba: Further fixups to samba:
- Add 3.3.0, works but DEFAULT_PREFERENCE -1 (see comments in recipe) - Ensure various ads deps are not included better - Centralise more repetition into samba-basic.inc - Remove various duplicate smb.conf - Ensure smbfs-doc is only included in 3.0.23c and 3.0.34 as it does not exist in other packages
Diffstat (limited to 'packages/samba/samba_3.3.0.bb')
-rw-r--r--packages/samba/samba_3.3.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/samba/samba_3.3.0.bb b/packages/samba/samba_3.3.0.bb
new file mode 100644
index 0000000000..ccdb24e20e
--- /dev/null
+++ b/packages/samba/samba_3.3.0.bb
@@ -0,0 +1,34 @@
+require samba.inc
+require samba-basic.inc
+
+# 3.3.0 and newer will upgrade your tdb database to a
+# new version that you can not downgrade to use with older
+# releases. More testing will happen before this is removed
+# should there be further issues. Appears to work though :)
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI += "file://configure-3.3.0.patch;patch=1 \
+ file://config-h.patch;patch=1 \
+ file://mtab.patch;patch=1 \
+ "
+
+PR = "r0"
+
+EXTRA_OECONF += "\
+ SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
+ samba_cv_CC_NEGATIVE_ENUM_VALUES=yes \
+ linux_getgrouplist_ok=no \
+ samba_cv_HAVE_BROKEN_GETGROUPS=no \
+ samba_cv_HAVE_FTRUNCATE_EXTEND=yes \
+ samba_cv_have_setresuid=yes \
+ samba_cv_have_setresgid=yes \
+ samba_cv_HAVE_WRFILE_KEYTAB=yes \
+ "
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile () {
+ base_do_compile
+}