summaryrefslogtreecommitdiff
path: root/packages/samba/samba_3.0.34.bb
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-26 21:39:40 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-26 21:39:40 +0000
commitf6dd4a8d0114abd3220eea74749c85db86129f0e (patch)
tree92750a9314099994a652ef8d141e8f38513d047d /packages/samba/samba_3.0.34.bb
parentaf8661dce2df7c244347b561f7acc1915f57889d (diff)
samba: Big clean/fixup of samba including
- Remove repeition of everything, everywhere - Fix uclibc builds of 3.0.34 - Add active directory client support to 3.2.7
Diffstat (limited to 'packages/samba/samba_3.0.34.bb')
-rw-r--r--packages/samba/samba_3.0.34.bb55
1 files changed, 6 insertions, 49 deletions
diff --git a/packages/samba/samba_3.0.34.bb b/packages/samba/samba_3.0.34.bb
index 13107fee69..ecd11badcc 100644
--- a/packages/samba/samba_3.0.34.bb
+++ b/packages/samba/samba_3.0.34.bb
@@ -1,61 +1,18 @@
require samba.inc
-inherit update-rc.d
-PR = "r1"
+PR = "r2"
-SRC_URI += "file://config-lfs.patch;patch=1 \
- file://quota.patch;patch=1;pnum=0 \
- file://init \
- file://smb.conf \
- "
+SRC_URI_append_linux-uclibc = " \
+ file://uclibc-strlcpy-strlcat.patch;patch=1"
+SRC_URI_append_linux-uclibcgnueabi = " \
+ file://uclibc-strlcpy-strlcat.patch;patch=1"
-# file://cifs.patch;patch=1 \
-
-INITSCRIPT_NAME = "samba"
-# No dependencies, goes in at level 20 (NOTE: take care with the
-# level, later levels put the shutdown later too - see the links
-# in rc6.d, the shutdown must precede network shutdown).
-INITSCRIPT_PARAMS = "defaults"
-CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
-
-# The file system settings --foodir=dirfoo and overridden unconditionally
-# in the samba config by --with-foodir=dirfoo - even if the --with is not
-# specified! Fix that here. Set the privatedir to /etc/samba/private.
EXTRA_OECONF += "\
+ --without-ads \
SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
- samba_cv_struct_timespec=yes \
- --with-configdir=${sysconfdir}/samba \
- --with-privatedir=${sysconfdir}/samba/private \
- --with-lockdir=${localstatedir}/lock \
- --with-piddir=${localstatedir}/run \
- --with-logfilebase=${localstatedir}/log \
- --with-libdir=${libdir} \
- --with-mandir=${mandir} \
- --with-swatdir=${datadir}/swat \
"
-do_install_append() {
- install -d "${D}/var/log/samba"
- install -d "${D}${sysconfdir}/init.d"
- install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
- install -d "${D}${sysconfdir}/samba"
- install -c -m 644 ${WORKDIR}/smb.conf ${D}${sysconfdir}/samba/smb.conf
- install -d ${D}/var/spool/samba
-}
-
do_stage() {
install -m 0644 include/libsmbclient.h ${STAGING_INCDIR}
oe_libinstall -C bin -a -so libsmbclient ${STAGING_LIBDIR}
}
-
-PACKAGES =+ "swat"
-
-FILES_swat = "${sbindir}/swat ${datadir}/swat ${libdir}/*.msg"
-FILES_${PN} += "${libdir}/vfs/*.so ${libdir}/charset/*.so ${libdir}/*.dat \
- ${libdir}/auth/*.so ${libdir}/security/*.so"
-FILES_${PN}-dbg += "${libdir}/vfs/.debug/*.so ${libdir}/charset/.debug/*.so \
- ${libdir}/auth/.debug/*.so ${libdir}/security/.debug/*.so"
-
-#
-# bug fix for samba.inc:
-FILES_cifs-doc += "${mandir}/man8/mount.cifs.8"