summaryrefslogtreecommitdiff
path: root/packages/samba/samba-essential_3.0.20.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-05-25 15:53:23 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-25 15:53:23 +0000
commit9125d5edcf62b504cb876afb8e70fd25ee01d157 (patch)
treebdf1fc67a270c1acfb086e560f68d46cfe596af0 /packages/samba/samba-essential_3.0.20.bb
parent4b946fa17c434ce61b9686888758a284d73223fc (diff)
samba: Add samba-essential, a cut-down bare-bone samba server
Diffstat (limited to 'packages/samba/samba-essential_3.0.20.bb')
-rw-r--r--packages/samba/samba-essential_3.0.20.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/packages/samba/samba-essential_3.0.20.bb b/packages/samba/samba-essential_3.0.20.bb
new file mode 100644
index 0000000000..21130bb0ab
--- /dev/null
+++ b/packages/samba/samba-essential_3.0.20.bb
@@ -0,0 +1,61 @@
+PR = "r1"
+
+SRC_URI = "http://us2.samba.org/samba/ftp/stable/samba-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://cifs.patch;patch=1 \
+ file://config-lfs.patch;patch=1 \
+ file://init \
+ file://quota.patch;patch=1;pnum=0 \
+ file://smb-essential.conf \
+ file://Managing-Samba.txt"
+
+S := ${WORKDIR}/samba-${PV}/source
+
+RCONFILCTS = samba
+
+include samba-essential.inc
+inherit update-rc.d
+
+INITSCRIPT_NAME = "samba"
+# No dependencies, goes in at level 20 (NOTE: take care with the
+# level, later levels put the shutdown later too - see the links
+# in rc6.d, the shutdown must precede network shutdown).
+INITSCRIPT_PARAMS = "defaults"
+CONFFILES_${PN} = "${sysconfdir}/samba/smb.conf"
+
+# The file system settings --foodir=dirfoo and overridden unconditionally
+# in the samba config by --with-foodir=dirfoo - even if the --with is not
+# specified! Fix that here. Set the privatedir to /etc/samba/private.
+EXTRA_OECONF += "\
+ --with-configdir=${sysconfdir}/samba \
+ --with-privatedir=${sysconfdir}/samba/private \
+ --with-lockdir=${localstatedir}/lock \
+ --with-piddir=${localstatedir}/run \
+ --with-logfilebase=${localstatedir}/log \
+ --with-libdir=${libdir} \
+ --with-mandir=${mandir} \
+ "
+
+do_install_append() {
+ install -d "${D}${localstatedir}/log"
+ rm -f ${D}/sbin/mount.smbfs
+ rmdir ${D}/sbin
+ install -d "${D}${sysconfdir}/init.d"
+ install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/samba
+
+ install -d "${D}${sysconfdir}/samba"
+ install -d "${D}/usr/share/samba/help"
+
+ install ${WORKDIR}/smb-essential.conf "${D}${sysconfdir}/samba/smb.conf"
+ install ${WORKDIR}/Managing-Samba.txt ${D}/usr/share/samba/help
+
+}
+
+FILES_${PN} = "${bindir}/smbpasswd \
+ ${sbindir}/nmbd \
+ ${sbindir}/smbd \
+ ${libdir}/charset \
+ ${libdir}/vfs \
+ ${libdir}/*.dat \
+ /usr/share/samba \
+ /etc"