summaryrefslogtreecommitdiff
path: root/packages/samba/samba-3.2.7
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-31 20:22:29 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-31 20:22:29 +0000
commitc3270e164d1964d6ef32258dcbcbceda912add07 (patch)
tree2d060050000abf82bdaacc5d5f92048181af1aaf /packages/samba/samba-3.2.7
parent579a5fa166ce8915ca9e00c90a357f61771922d7 (diff)
samba: Rework samba in preparation for separate AD support:
- Move mtab.patch and config-h.patch to files as they will work for 3.3.0 - Remove AD support, krb5 and openldap deps from 3.2.7 - Move the non-AD samba specific stuff into its own include file - Ensure package conflicts with samba-ads, bump PR to pick this up
Diffstat (limited to 'packages/samba/samba-3.2.7')
-rw-r--r--packages/samba/samba-3.2.7/config-h.patch12
-rw-r--r--packages/samba/samba-3.2.7/configure.patch86
-rw-r--r--packages/samba/samba-3.2.7/mtab.patch11
3 files changed, 0 insertions, 109 deletions
diff --git a/packages/samba/samba-3.2.7/config-h.patch b/packages/samba/samba-3.2.7/config-h.patch
deleted file mode 100644
index eeb22684ee..0000000000
--- a/packages/samba/samba-3.2.7/config-h.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -urN source.old//include/config.h.in source//include/config.h.in
---- source.old//include/config.h.in 2008-11-20 14:45:04.000000000 +0000
-+++ source//include/config.h.in 2008-11-30 21:04:17.990008933 +0000
-@@ -2672,7 +2672,7 @@
- #undef USE_SETEUID
-
- /* Whether setresuid() is available */
--#undef USE_SETRESUID
-+#define USE_SETRESUID 1
-
- /* Whether setreuid() is available */
- #undef USE_SETREUID
diff --git a/packages/samba/samba-3.2.7/configure.patch b/packages/samba/samba-3.2.7/configure.patch
deleted file mode 100644
index 94d684813e..0000000000
--- a/packages/samba/samba-3.2.7/configure.patch
+++ /dev/null
@@ -1,86 +0,0 @@
-diff -urN source.old/configure source/configure
---- source.old/configure 2008-11-20 14:45:08.000000000 +0000
-+++ source/configure 2008-11-30 17:53:02.116791281 +0000
-@@ -40777,11 +40777,10 @@
- *linux*)
- # glibc <= 2.3.2 has a broken getgrouplist
- if test "$cross_compiling" = yes; then
-- { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&5
--echo "$as_me: error: cannot run test program while cross compiling
--See \`config.log' for more details." >&2;}
-- { (exit 1); exit 1; }; }
-+# { { echo "$as_me:$LINENO: error: cannot run test program while cross compiling See \`config.log' for more details." >&5
-+# echo "$as_me: error: cannot run test program while cross compiling See \`config.log' for more details." >&2;}
-+# { (exit 1); exit 1; }; }
-+linux_getgrouplist_ok=no
- else
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
-diff -urN source.old/configure.in source/configure.in
---- source.old/configure.in 2008-11-18 15:17:17.000000000 +0000
-+++ source/configure.in 2008-11-30 17:33:10.960791551 +0000
-@@ -275,6 +275,8 @@
- fi
- AC_SUBST(BROKEN_CC)
-
-+AC_TRY_COMPILE([],[(void)sizeof(char[-1])],AC_MSG_ERROR([configure's compilation assert doesn't work with $CC]))
-+
- dnl Check if the C compiler understands -Werror
- AC_CACHE_CHECK([that the C compiler understands -Werror],samba_cv_HAVE_Werror, [
- AC_TRY_RUN_STRICT([
-@@ -325,25 +327,11 @@
- # a runtime test is needed here
- AC_SUBST(PIDL_ARGS)
- AC_CACHE_CHECK([that the C compiler understands negative enum values],samba_cv_CC_NEGATIVE_ENUM_VALUES, [
-- AC_TRY_RUN(
-+ AC_TRY_COMPILE([],
- [
-- #include <stdio.h>
- enum negative_values { NEGATIVE_VALUE = 0xFFFFFFFF };
-- int main(void) {
-- enum negative_values v1 = NEGATIVE_VALUE;
-- unsigned v2 = NEGATIVE_VALUE;
--
-- if (v1 != 0xFFFFFFFF) {
-- printf("%u != 0xFFFFFFFF\n", v1);
-- return 1;
-- }
-- if (v2 != 0xFFFFFFFF) {
-- printf("%u != 0xFFFFFFFF\n", v2);
-- return 1;
-- }
--
-- return 0;
-- }
-+ (void)sizeof(char[1-2*( (unsigned)NEGATIVE_VALUE != 0xFFFFFFFF)]);
-+ (void)sizeof(char[1-2*((enum negative_values)NEGATIVE_VALUE != 0xFFFFFFFF)]);
- ],
- samba_cv_CC_NEGATIVE_ENUM_VALUES=yes,samba_cv__CC_NEGATIVE_ENUM_VALUES=no)])
- if test x"$samba_cv_CC_NEGATIVE_ENUM_VALUES" != x"yes"; then
-@@ -1187,22 +1175,12 @@
- case "$host_os" in
- *linux*)
- # glibc <= 2.3.2 has a broken getgrouplist
-- AC_TRY_RUN([
--#include <unistd.h>
-+ AC_TRY_COMPILE([
- #include <sys/utsname.h>
--main() {
-- /* glibc up to 2.3 has a broken getgrouplist */
-+],[
- #if defined(__GLIBC__) && defined(__GLIBC_MINOR__)
-- int libc_major = __GLIBC__;
-- int libc_minor = __GLIBC_MINOR__;
--
-- if (libc_major < 2)
-- exit(1);
-- if ((libc_major == 2) && (libc_minor <= 3))
-- exit(1);
-+ (void)sizeof(char[1-2*(__GLIBC__ < 2 || __GLIBC__ == 2 && __GLIBC_MINOR__ <= 3)]);
- #endif
-- exit(0);
--}
- ], [linux_getgrouplist_ok=yes], [linux_getgrouplist_ok=no])
- if test x"$linux_getgrouplist_ok" = x"yes"; then
- AC_DEFINE(HAVE_GETGROUPLIST, 1, [Have good getgrouplist])
diff --git a/packages/samba/samba-3.2.7/mtab.patch b/packages/samba/samba-3.2.7/mtab.patch
deleted file mode 100644
index 2ee8ba0941..0000000000
--- a/packages/samba/samba-3.2.7/mtab.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -urN source/client/mtab.c samba-3.2.7//source/client/mtab.c
---- source/client/mtab.c 2008-12-19 13:57:33.000000000 +0000
-+++ source/client/mtab.c 2009-01-09 23:14:00.717671075 +0000
-@@ -32,6 +32,7 @@
- #include <errno.h>
- #include <stdio.h>
- #include <sys/time.h>
-+#include <sys/stat.h>
- #include <time.h>
- #include <fcntl.h>
- #include <mntent.h>