summaryrefslogtreecommitdiff
path: root/packages/rxvt-unicode/rxvt-unicode_5.6.bb
diff options
context:
space:
mode:
authorFrederic Bompart <frederic@unknown.openembedded.org>2005-09-20 07:27:59 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-20 07:27:59 +0000
commit4d091ab7bcad9180be49ff4768602c05a2c6bfa7 (patch)
treedaa7a2c9d7df89e803dce51a58ab62b1e8dfca50 /packages/rxvt-unicode/rxvt-unicode_5.6.bb
parentdd088063c0542a8940f201b33ae6ce904198d9ea (diff)
parent656946b9536f23b212e6ef8111f0fbdbd2d7b446 (diff)
merge of 0f46196206904515c0939c84c80210e251c74960
and 5ec5f2c198db5c371a9cf2cada82144032025895
Diffstat (limited to 'packages/rxvt-unicode/rxvt-unicode_5.6.bb')
-rw-r--r--packages/rxvt-unicode/rxvt-unicode_5.6.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/packages/rxvt-unicode/rxvt-unicode_5.6.bb b/packages/rxvt-unicode/rxvt-unicode_5.6.bb
new file mode 100644
index 0000000000..92915bf872
--- /dev/null
+++ b/packages/rxvt-unicode/rxvt-unicode_5.6.bb
@@ -0,0 +1,55 @@
+SECTION = "x11/utils"
+DEPENDS = "x11 xt libxft"
+DESCRIPTION = "rxvt-unicode is a clone of the well known \
+terminal emulator rxvt, modified to store text in Unicode \
+(either UCS-2 or UCS-4) and to use locale-correct input and \
+output. It also supports mixing multiple fonts at the \
+same time, including Xft fonts."
+LICENSE = "GPL"
+SRC_URI = "http://dist.schmorp.de/rxvt-unicode/Attic/rxvt-unicode-${PV}.tar.bz2 \
+ file://xwc.patch;patch=1 \
+ file://signedchar.patch;patch=1"
+PR = "r2"
+
+inherit autotools update-alternatives
+
+PROVIDES = "virtual/x-terminal-emulator"
+ALTERNATIVE_NAME = "x-terminal-emulator"
+ALTERNATIVE_PATH = "${bindir}/rxvt"
+
+CFLAGS_append = " -fpermissive"
+
+EXTRA_OECONF = "--enable-menubar --enable-xim \
+ --enable-utmp --enable-wtmp --enable-lastlog \
+ --disable-strings --with-term=rxvt --enable-keepscrolling \
+ --enable-xft --with-name=rxvt --enable-frills \
+ --enable-swapscreen --enable-transparency \
+ --with-codesets=eu \
+ --enable-cursor-blink --enable-pointer-blank \
+ --enable-text-blink --enable-rxvt-scroll \
+ --enable-combining --enable-shared \
+ --enable-xgetdefault \
+ --with-x=${STAGING_LIBDIR}/.."
+EXTRA_OEMAKE = "'XINC=-I${STAGING_INCDIR}' \
+ 'XLIB=-L${STAGING_LIBDIR} -lX11'"
+
+do_configure () {
+ mv autoconf/configure.in . || true
+ rm autoconf/libtool.m4
+ libtoolize --force
+ autotools_do_configure
+ echo '#define RXVT_UTMP_FILE "${localstatedir}/run/utmp"' >> config.h
+ echo '#define RXVT_WTMP_FILE "${localstatedir}/log/wtmp"' >> config.h
+ echo '#define RXVT_LASTLOG_FILE "${localstatedir}/log/lastlog"' >> config.h
+ echo '#define HAVE_XLOCALE 1' >> config.h
+}
+
+do_compile () {
+ if test -e ${S}/${HOST_SYS}-libtool; then
+ LIBTOOL=${S}/${HOST_SYS}-libtool
+ else
+ LIBTOOL=${S}/libtool
+ fi
+ # docs need "yodl" and I have no idea what that is
+ oe_runmake -C src "LIBTOOL=$LIBTOOL"
+}