summaryrefslogtreecommitdiff
path: root/packages/rxtx/rxtx_2.1-7r2.bb
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2008-02-13 10:55:47 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2008-02-13 10:55:47 +0000
commit0f0344845902edcbfed4d1bfc4996210f793a947 (patch)
tree99171617514dfbcfb7dd17033ca4f3248d79dd46 /packages/rxtx/rxtx_2.1-7r2.bb
parent5cf7c1a4e24bc8e031ecd57b04682f3d1d698052 (diff)
parent32e690935379493f478d1b7a1cd43fce486083da (diff)
merge of '6828c0e5742385a5f78150f5504e1690ea6c4111'
and 'f26d3059129388297f1542283ce17d100f8c8acc'
Diffstat (limited to 'packages/rxtx/rxtx_2.1-7r2.bb')
-rw-r--r--packages/rxtx/rxtx_2.1-7r2.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/packages/rxtx/rxtx_2.1-7r2.bb b/packages/rxtx/rxtx_2.1-7r2.bb
index 260b70a1fe..0630d498d6 100644
--- a/packages/rxtx/rxtx_2.1-7r2.bb
+++ b/packages/rxtx/rxtx_2.1-7r2.bb
@@ -3,6 +3,10 @@ LICENSE = "LGPL"
SECTION = "libs"
HOMEPAGE = "http://rxtx.org"
+PR = "r1"
+
+DEPENDS = "classpath classpath-native virtual/javac-native"
+
inherit autotools java-library
SRC_URI = "\
@@ -10,6 +14,15 @@ SRC_URI = "\
file://rxtx-fixes-from-debian.patch;patch=1 \
"
+do_compile() {
+ # Whatever configure detected it is completely unusable. So we override heavily.
+ oe_runmake \
+ JAVAH="gjavah -classpath \$(CLASSPATH) -d \$(DEST) -jni" \
+ JAR=gjar \
+ JAVAC="javac -classpath \$(CLASSPATH) -d \$(TOP)/ -O -source 1.3 -target 1.3" \
+ JAVAINCLUDEDIR=${STAGING_INCDIR}/classpath
+}
+
do_install() {
install -d ${D}/${libdir_jni}
install -d ${D}/${datadir_java}