summaryrefslogtreecommitdiff
path: root/packages/ruby
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/ruby
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/ruby')
-rw-r--r--packages/ruby/files/disable_wide_getaddrinfo_check.patch16
-rw-r--r--packages/ruby/files/extmk_run.patch15
-rw-r--r--packages/ruby/files/openssl.patch156
-rw-r--r--packages/ruby/ruby-native_1.8.5.bb2
-rw-r--r--packages/ruby/ruby.inc26
-rw-r--r--packages/ruby/ruby_1.8.5.bb8
6 files changed, 0 insertions, 223 deletions
diff --git a/packages/ruby/files/disable_wide_getaddrinfo_check.patch b/packages/ruby/files/disable_wide_getaddrinfo_check.patch
deleted file mode 100644
index 82137896b9..0000000000
--- a/packages/ruby/files/disable_wide_getaddrinfo_check.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- packages/ruby/ruby-1.8.5/disable_wide_getaddrinfo_check.patch f667776fd8760b7048cc9617930112347b0ef2c0
-+++ packages/ruby/ruby-1.8.5/disable_wide_getaddrinfo_check.patch f667776fd8760b7048cc9617930112347b0ef2c0
-@@ -0,0 +1,13 @@
-+--- ruby-1.8.5/ext/socket/extconf.rb.orig 2006-12-30 15:12:31.000000000 +1100
-++++ ruby-1.8.5/ext/socket/extconf.rb 2006-12-30 15:16:24.000000000 +1100
-+@@ -216,6 +216,10 @@
-+ }
-+ EOF
-+ end
-++# Ignore the actual result of the above test and assume that
-++# everything is OK.
-++getaddr_info_ok = true
-++
-+ if ipv6 and not getaddr_info_ok
-+ abort <<EOS
-+
diff --git a/packages/ruby/files/extmk_run.patch b/packages/ruby/files/extmk_run.patch
deleted file mode 100644
index 57926f51b0..0000000000
--- a/packages/ruby/files/extmk_run.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-============================================================
---- packages/ruby/ruby-1.8.5/extmk_run.patch d9738b5a71e2f9a98d009af9fd0ef1ceaff9ef48
-+++ packages/ruby/ruby-1.8.5/extmk_run.patch d9738b5a71e2f9a98d009af9fd0ef1ceaff9ef48
-@@ -0,0 +1,11 @@
-+--- ruby-1.8.5/common.mk.orig 2006-12-30 13:07:32.000000000 +1100
-++++ ruby-1.8.5/common.mk 2006-12-30 13:08:32.000000000 +1100
-+@@ -56,7 +56,7 @@
-+ --make="$(MAKE)" \
-+ --mflags="$(MFLAGS)" \
-+ --make-flags="$(MAKEFLAGS)"
-+-EXTMK_ARGS = $(SCRIPT_ARGS) --extout="$(EXTOUT)" --extension $(EXTS) --extstatic $(EXTSTATIC) --
-++EXTMK_ARGS = $(SCRIPT_ARGS) --with-ldflags="%%TARGET_LDFLAGS%%" --with-cflags="%%TARGET_CFLAGS%%" --extout="$(EXTOUT)" --extension $(EXTS) --extstatic $(EXTSTATIC) --
-+
-+ all: $(MKFILES) $(PREP) $(RBCONFIG) $(LIBRUBY)
-+ @$(MINIRUBY) $(srcdir)/ext/extmk.rb $(EXTMK_ARGS)
diff --git a/packages/ruby/files/openssl.patch b/packages/ruby/files/openssl.patch
deleted file mode 100644
index 9de37ef3e7..0000000000
--- a/packages/ruby/files/openssl.patch
+++ /dev/null
@@ -1,156 +0,0 @@
-This patch backports changes from ruby 1.8.7 which only includes the
-openssl prototypes for functions that are not in the system openssl
-library.
-
-diff -u ruby-1.8.5.orig/ext/openssl/extconf.rb ruby-1.8.5/ext/openssl/extconf.rb
---- ruby-1.8.5.orig/ext/openssl/openssl_missing.c 2007-02-13 00:01:19.000000000 +0100
-+++ ruby-1.8.5/ext/openssl/openssl_missing.c 2008-05-19 05:00:52.000000000 +0200
-@@ -22,17 +22,15 @@
- #include "openssl_missing.h"
-
- #if !defined(HAVE_HMAC_CTX_COPY)
--int
-+void
- HMAC_CTX_copy(HMAC_CTX *out, HMAC_CTX *in)
- {
-- if (!out || !in) return 0;
-+ if (!out || !in) return;
- memcpy(out, in, sizeof(HMAC_CTX));
-
-- if (!EVP_MD_CTX_copy(&out->md_ctx, &in->md_ctx)
-- || !EVP_MD_CTX_copy(&out->i_ctx, &in->i_ctx)
-- || !EVP_MD_CTX_copy(&out->o_ctx, &in->o_ctx))
-- return 0;
-- return 1;
-+ EVP_MD_CTX_copy(&out->md_ctx, &in->md_ctx);
-+ EVP_MD_CTX_copy(&out->i_ctx, &in->i_ctx);
-+ EVP_MD_CTX_copy(&out->o_ctx, &in->o_ctx);
- }
- #endif /* HAVE_HMAC_CTX_COPY */
- #endif /* NO_HMAC */
-diff -u ruby-1.8.5.orig/ext/openssl/openssl_missing.h ruby-1.8.5/ext/openssl/openssl_missing.h
---- ruby-1.8.5.orig/ext/openssl/openssl_missing.h 2008-08-04 06:43:34.000000000 +0200
-+++ ruby-1.8.5/ext/openssl/openssl_missing.h 2008-08-04 06:44:17.000000000 +0200
-@@ -60,14 +60,33 @@
- (char *(*)())d2i_PKCS7_RECIP_INFO, (char *)ri)
- #endif
-
-+#if !defined(HAVE_EVP_MD_CTX_INIT)
- void HMAC_CTX_init(HMAC_CTX *ctx);
--int HMAC_CTX_copy(HMAC_CTX *out, HMAC_CTX *in);
-+#endif
-+
-+#if !defined(HAVE_HMAC_CTX_COPY)
-+void HMAC_CTX_copy(HMAC_CTX *out, HMAC_CTX *in);
-+#endif
-+
-+#if !defined(HAVE_HMAC_CTX_CLEANUP)
- void HMAC_CTX_cleanup(HMAC_CTX *ctx);
-+#endif
-
-+#if !defined(HAVE_EVP_MD_CTX_CREATE)
- EVP_MD_CTX *EVP_MD_CTX_create(void);
-+#endif
-+
-+#if !defined(HAVE_EVP_MD_CTX_INIT)
- void EVP_MD_CTX_init(EVP_MD_CTX *ctx);
-+#endif
-+
-+#if !defined(HAVE_EVP_MD_CTX_CLEANUP)
- int EVP_MD_CTX_cleanup(EVP_MD_CTX *ctx);
-+#endif
-+
-+#if !defined(HAVE_EVP_MD_CTX_DESTROY)
- void EVP_MD_CTX_destroy(EVP_MD_CTX *ctx);
-+#endif
-
- #if !defined(HAVE_EVP_CIPHER_CTX_COPY)
- int EVP_CIPHER_CTX_copy(EVP_CIPHER_CTX *out, EVP_CIPHER_CTX *in);
-@@ -111,19 +130,54 @@
- #define OPENSSL_cleanse(p, l) memset(p, 0, l)
- #endif
-
-+#if !defined(HAVE_X509_STORE_SET_EX_DATA)
- void *X509_STORE_get_ex_data(X509_STORE *str, int idx);
- int X509_STORE_set_ex_data(X509_STORE *str, int idx, void *data);
-+#endif
-+
-+#if !defined(HAVE_X509_CRL_SET_VERSION)
- int X509_CRL_set_version(X509_CRL *x, long version);
-+#endif
-+
-+#if !defined(HAVE_X509_CRL_SET_ISSUER_NAME)
- int X509_CRL_set_issuer_name(X509_CRL *x, X509_NAME *name);
-+#endif
-+
-+#if !defined(HAVE_X509_CRL_SORT)
- int X509_CRL_sort(X509_CRL *c);
-+#endif
-+
-+#if !defined(HAVE_X509_CRL_ADD0_REVOKED)
- int X509_CRL_add0_revoked(X509_CRL *crl, X509_REVOKED *rev);
-+#endif
-+
-+#if !defined(HAVE_BN_MOD_SQR)
- int BN_mod_sqr(BIGNUM *r, const BIGNUM *a, const BIGNUM *m, BN_CTX *ctx);
-+#endif
-+
-+#if !defined(HAVE_BN_MOD_ADD)
- int BN_mod_add(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
-+#endif
-+
-+#if !defined(HAVE_BN_MOD_SUB)
- int BN_mod_sub(BIGNUM *r, const BIGNUM *a, const BIGNUM *b, const BIGNUM *m, BN_CTX *ctx);
-+#endif
-+
-+#if !defined(HAVE_BN_RAND_RANGE)
- int BN_rand_range(BIGNUM *r, BIGNUM *range);
-+#endif
-+
-+#if !defined(HAVE_BN_PSEUDO_RAND_RANGE)
- int BN_pseudo_rand_range(BIGNUM *r, BIGNUM *range);
-+#endif
-+
-+#if !defined(HAVE_CONF_GET1_DEFAULT_CONFIG_FILE)
- char *CONF_get1_default_config_file(void);
-+#endif
-+
-+#if !defined(HAVE_PEM_DEF_CALLBACK)
- int PEM_def_callback(char *buf, int num, int w, void *key);
-+#endif
-
- #if defined(__cplusplus)
- }
-diff -u ruby-1.8.5.orig/ext/openssl/ossl_hmac.c ruby-1.8.5/ext/openssl/ossl_hmac.c
---- ruby-1.8.5.orig/ext/openssl/ossl_hmac.c 2007-03-12 05:12:32.000000000 +0100
-+++ ruby-1.8.5/ext/openssl/ossl_hmac.c 2008-05-19 05:00:52.000000000 +0200
-@@ -81,12 +87,15 @@
- GetHMAC(self, ctx1);
- SafeGetHMAC(other, ctx2);
-
-- if (!HMAC_CTX_copy(ctx1, ctx2)) {
-- ossl_raise(eHMACError, NULL);
-- }
-+ HMAC_CTX_copy(ctx1, ctx2);
- return self;
- }
-
-+/*
-+ * call-seq:
-+ * hmac.update(string) -> self
-+ *
-+ */
- static VALUE
- ossl_hmac_update(VALUE self, VALUE data)
- {
-@@ -104,9 +113,7 @@
- {
- HMAC_CTX final;
-
-- if (!HMAC_CTX_copy(&final, ctx)) {
-- ossl_raise(eHMACError, NULL);
-- }
-+ HMAC_CTX_copy(&final, ctx);
- if (!(*buf = OPENSSL_malloc(HMAC_size(&final)))) {
- HMAC_CTX_cleanup(&final);
- OSSL_Debug("Allocating %d mem", HMAC_size(&final));
diff --git a/packages/ruby/ruby-native_1.8.5.bb b/packages/ruby/ruby-native_1.8.5.bb
deleted file mode 100644
index e4d2a3361e..0000000000
--- a/packages/ruby/ruby-native_1.8.5.bb
+++ /dev/null
@@ -1,2 +0,0 @@
-require ruby.inc
-inherit native
diff --git a/packages/ruby/ruby.inc b/packages/ruby/ruby.inc
deleted file mode 100644
index 978bf4b229..0000000000
--- a/packages/ruby/ruby.inc
+++ /dev/null
@@ -1,26 +0,0 @@
-DESCRIPTION = "Ruby is an interpreted scripting language \
-for quick and easy object-oriented programming."
-SECTION = "devel/ruby"
-PRIORITY = "optional"
-LICENSE = "GPL"
-
-SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz \
- file://extmk_run.patch;patch=1 \
- file://openssl.patch;patch=1 \
- file://disable_wide_getaddrinfo_check.patch;patch=1"
-
-S = "${WORKDIR}/ruby-${PV}"
-
-inherit autotools
-
-# This snippet lets compiled extensions which rely on external libraries,
-# such as zlib, compile properly. If we don't do this, then when extmk.rb
-# runs, it uses the native libraries instead of the target libraries, and so
-# none of the linking operations succeed -- which makes extconf.rb think
-# that the libraries aren't available and hence that the extension can't be
-# built.
-
-do_configure_prepend() {
- sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
- rm -rf ${S}/ruby/
-}
diff --git a/packages/ruby/ruby_1.8.5.bb b/packages/ruby/ruby_1.8.5.bb
deleted file mode 100644
index 6260614772..0000000000
--- a/packages/ruby/ruby_1.8.5.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-require ruby.inc
-DEPENDS = "ruby-native zlib openssl"
-
-PR = "r1"
-
-FILES_${PN}-dbg += "${libdir}/ruby/1.8/*/.debug \
- ${libdir}/ruby/1.8/*/*/.debug"
-