summaryrefslogtreecommitdiff
path: root/packages/ruby/ruby.inc
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2007-01-18 15:32:42 +0000
committerPhil Blundell <philb@gnu.org>2007-01-18 15:32:42 +0000
commitdb774cfc9ba6f54ebbdbce312481125489116c0a (patch)
tree759b2256b29817e3bff079a6c06d33f4c7a7e5a3 /packages/ruby/ruby.inc
parent1cb09641f0982c8f1c043c45e5349647867b2e4b (diff)
parent419ef2d081af1db73844871ce0858abda1bf7ec9 (diff)
merge of '7022b2fb8c0b08d5f93f14844bb14a13991c7daa'
and 'c77de7a09c5852f1bfe63afbd011ef701c76bdf6'
Diffstat (limited to 'packages/ruby/ruby.inc')
-rw-r--r--packages/ruby/ruby.inc25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/ruby/ruby.inc b/packages/ruby/ruby.inc
new file mode 100644
index 0000000000..9fe8333f6f
--- /dev/null
+++ b/packages/ruby/ruby.inc
@@ -0,0 +1,25 @@
+DESCRIPTION = "Ruby is an interpreted scripting language \
+for quick and easy object-oriented programming."
+SECTION = "devel/ruby"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "ftp://ftp.ruby-lang.org/pub/ruby/ruby-${PV}.tar.gz \
+ file://extmk_run.patch;patch=1 \
+ file://disable_wide_getaddrinfo_check.patch;patch=1"
+
+S = "${WORKDIR}/ruby-${PV}"
+
+inherit autotools
+
+# This snippet lets compiled extensions which rely on external libraries,
+# such as zlib, compile properly. If we don't do this, then when extmk.rb
+# runs, it uses the native libraries instead of the target libraries, and so
+# none of the linking operations succeed -- which makes extconf.rb think
+# that the libraries aren't available and hence that the extension can't be
+# built.
+
+do_configure_prepend() {
+ sed -i "s#%%TARGET_CFLAGS%%#$TARGET_CFLAGS#; s#%%TARGET_LDFLAGS%%#$TARGET_LDFLAGS#" ${S}/common.mk
+ rm -rf ${S}/ruby/
+}