summaryrefslogtreecommitdiff
path: root/packages/rtaudio/rtaudio-tests_3.0.1.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-09-21 17:09:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-21 17:09:53 +0000
commitff284b3d8b85c0d75df6f31996f437e2e4bae558 (patch)
tree3f3dadfa424ead8ed7070d7727568bf167a10dff /packages/rtaudio/rtaudio-tests_3.0.1.bb
parentcac237d6d44bb53b78e92e2381fe969103ef166b (diff)
add librtaudio + tests
rtaudio is a highly efficient and portable C++ sound abstraction layer supporting OSS, ALSA, JACK.
Diffstat (limited to 'packages/rtaudio/rtaudio-tests_3.0.1.bb')
-rw-r--r--packages/rtaudio/rtaudio-tests_3.0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/rtaudio/rtaudio-tests_3.0.1.bb b/packages/rtaudio/rtaudio-tests_3.0.1.bb
new file mode 100644
index 0000000000..53752b73c0
--- /dev/null
+++ b/packages/rtaudio/rtaudio-tests_3.0.1.bb
@@ -0,0 +1,26 @@
+include librtaudio_${PV}.bb
+
+inherit autotools
+
+EXTRA_OECONF = "--with-alsa --with-oss"
+EXTRA_OEMAKE = "-e"
+export CC = "${CXX}"
+CFLAGS += "-I${S}"
+export LIBRARY = "-lasound -lpthread ${LDFLAGS}"
+
+do_compile() {
+ oe_runmake -C tests
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ for binary in `find tests -perm 0755 -type f`
+ do
+ install -m 0755 $binary ${D}${bindir}
+ done
+}
+