summaryrefslogtreecommitdiff
path: root/packages/rtaudio/rtaudio-tests_3.0.1.bb
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2005-09-22 14:08:21 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-22 14:08:21 +0000
commit89dd14a2a673ab49867fa1e815a9238b9ea183eb (patch)
tree69fb61ccc6029696336b95b5f6705ba133f2f5ef /packages/rtaudio/rtaudio-tests_3.0.1.bb
parent58c854e12629358f21447f5a031acc6e41086537 (diff)
parent879f9f39cbb2d061ac85ad8a7ebce71b0aa6760b (diff)
merge of 42b169fabe3df723d70a1502561f5848f1287a98
and a7038c05fef716879570b18652c839a87a2a65f8
Diffstat (limited to 'packages/rtaudio/rtaudio-tests_3.0.1.bb')
-rw-r--r--packages/rtaudio/rtaudio-tests_3.0.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/rtaudio/rtaudio-tests_3.0.1.bb b/packages/rtaudio/rtaudio-tests_3.0.1.bb
new file mode 100644
index 0000000000..53752b73c0
--- /dev/null
+++ b/packages/rtaudio/rtaudio-tests_3.0.1.bb
@@ -0,0 +1,26 @@
+include librtaudio_${PV}.bb
+
+inherit autotools
+
+EXTRA_OECONF = "--with-alsa --with-oss"
+EXTRA_OEMAKE = "-e"
+export CC = "${CXX}"
+CFLAGS += "-I${S}"
+export LIBRARY = "-lasound -lpthread ${LDFLAGS}"
+
+do_compile() {
+ oe_runmake -C tests
+}
+
+do_stage() {
+ :
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ for binary in `find tests -perm 0755 -type f`
+ do
+ install -m 0755 $binary ${D}${bindir}
+ done
+}
+