summaryrefslogtreecommitdiff
path: root/packages/rsync
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-04-18 01:43:08 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-18 01:43:08 +0000
commitc2a4b021eb04924f8c8b0e0af1fac337a04cbcae (patch)
tree7dc31cc35bb3ecdb73521b392170f7037ba58fc8 /packages/rsync
parentf31534c088ac56d6e44e009134a170e2e786e24d (diff)
rsync: Add rsyncd.conf
Diffstat (limited to 'packages/rsync')
-rw-r--r--packages/rsync/files/.mtn2git_empty0
-rw-r--r--packages/rsync/files/rsyncd.conf15
-rw-r--r--packages/rsync/rsync_2.6.7.bb8
3 files changed, 22 insertions, 1 deletions
diff --git a/packages/rsync/files/.mtn2git_empty b/packages/rsync/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/rsync/files/.mtn2git_empty
diff --git a/packages/rsync/files/rsyncd.conf b/packages/rsync/files/rsyncd.conf
new file mode 100644
index 0000000000..845f5b33f5
--- /dev/null
+++ b/packages/rsync/files/rsyncd.conf
@@ -0,0 +1,15 @@
+# /etc/rsyncd.conf
+
+# Minimal configuration file for rsync daemon
+# See rsync(1) and rsyncd.conf(5) man pages for help
+
+# This file is required by rsync --daemon
+pid file = /var/run/rsyncd.pid
+use chroot = yes
+read only = yes
+
+# Simple example for enabling your own local rsync server
+#[everything]
+# path = /
+# comment = Everything except /etc exposed
+# exclude = /etc
diff --git a/packages/rsync/rsync_2.6.7.bb b/packages/rsync/rsync_2.6.7.bb
index b5f8a654dd..421dc76d48 100644
--- a/packages/rsync/rsync_2.6.7.bb
+++ b/packages/rsync/rsync_2.6.7.bb
@@ -4,8 +4,14 @@ SECTION = "console/network"
PRIORITY = "optional"
PR = "r1"
-SRC_URI = "http://rsync.samba.org/ftp/rsync/rsync-${PV}.tar.gz"
+SRC_URI = "http://rsync.samba.org/ftp/rsync/rsync-${PV}.tar.gz \
+file://rsyncd.conf"
inherit autotools
+do_install_append() {
+ install -d ${D}/etc
+ install -m 0644 ${WORKDIR}/rsyncd.conf ${D}/etc
+}
+
EXTRA_OEMAKE='STRIP=""'