summaryrefslogtreecommitdiff
path: root/packages/rp-pppoe/rp-pppoe_3.8.bb
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-04-30 19:02:38 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-04-30 19:02:38 +0000
commit14d8757a50c592986ccc236b6dcd5bf4b61f894b (patch)
treea96f0e21ef3164146e3f89a22e309f5482869d93 /packages/rp-pppoe/rp-pppoe_3.8.bb
parent85e7e5d440d9090d1e5cb1f384655767971445ce (diff)
parentf1d57e9f9f701f19e1ca2987571d059888bd3035 (diff)
merge of '3744a34d57095e84a89851df9f2cabc7b5a0dd0d'
and 'bdbd61d03008d901627ae17450554a101ca42e5b'
Diffstat (limited to 'packages/rp-pppoe/rp-pppoe_3.8.bb')
-rw-r--r--packages/rp-pppoe/rp-pppoe_3.8.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/rp-pppoe/rp-pppoe_3.8.bb b/packages/rp-pppoe/rp-pppoe_3.8.bb
new file mode 100644
index 0000000000..c4d5ff88d2
--- /dev/null
+++ b/packages/rp-pppoe/rp-pppoe_3.8.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "A user-mode PPPoE client and server suite for Linux"
+HOMEPAGE = "http://www.roaringpenguin.com/en/penguin/openSourceProducts/rpPppoe"
+SECTION = "console/network"
+LICENSE = "GPLv2"
+RDEPENDS = "ppp"
+PR = "r0"
+
+SRC_URI = "http://www.roaringpenguin.com/files/download/${P}.tar.gz \
+ file://configure_in_cross.patch;patch=1;pnum=2 \
+ file://pppoe-src-restrictions.patch;patch=1;pnum=2"
+
+S = "${WORKDIR}/${P}/src"
+
+inherit autotools
+
+do_install() {
+ # Set timeout to 0. Fixes lots of reconnect issues
+ # Can't patch this in because it's outside of what we have {S} set to.
+ sed -i -e 's,\(CONNECT_TIMEOUT=\)30,\10,g' ${S}/../configs/pppoe.conf
+ # Install
+ oe_runmake -C ${S} RPM_INSTALL_ROOT=${D} docdir=${docdir} install
+}
+
+pkg_postinst() {
+ if [ x"$D" != "x" ]; then
+ exit 1
+ fi
+ chmod 4755 ${sbindir}/pppoe
+}