summaryrefslogtreecommitdiff
path: root/packages/rp-pppoe/rp-pppoe_3.8.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-06-08 06:13:53 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-06-08 06:13:53 +0000
commit612f7ecab32c79e28074e1a56184df7068bdbf9c (patch)
treee4837f918c5c13db6db8dc85a50e413e35c80886 /packages/rp-pppoe/rp-pppoe_3.8.bb
parentf7acf081277799b12a839fa32f97b36dbe4490fb (diff)
rp-pppoe 3.8: Fix issues caused by autoconf needing to run in the src
subdirectory of the source code. The OE autotools.bbclass runs the autoconf stuff in ${S}, so you need to change ${S} to the src subdirectory to get it to work. But ${S} is also where patches are appplied, so you can't patch the config files and other things which aren't in the src directory. So add some autoconf at the top level which just says there's a sub-autoconf project in the src subdirectory, fix up the patches, remove the sed hacks and add a new patch to do what the sed hacks were doing before.
Diffstat (limited to 'packages/rp-pppoe/rp-pppoe_3.8.bb')
-rw-r--r--packages/rp-pppoe/rp-pppoe_3.8.bb16
1 files changed, 6 insertions, 10 deletions
diff --git a/packages/rp-pppoe/rp-pppoe_3.8.bb b/packages/rp-pppoe/rp-pppoe_3.8.bb
index 8743838909..6b2084ea4a 100644
--- a/packages/rp-pppoe/rp-pppoe_3.8.bb
+++ b/packages/rp-pppoe/rp-pppoe_3.8.bb
@@ -5,25 +5,21 @@ LICENSE = "GPLv2"
RDEPENDS_${PN} = "ppp"
RDEPENDS_${PN}-server = "${PN}"
RRECOMMENDS_${PN} = "ppp-oe"
-PR = "r3"
+PR = "r4"
SRC_URI = "http://www.roaringpenguin.com/files/download/${P}.tar.gz \
- file://configure_in_cross.patch;patch=1;pnum=2 \
- file://pppoe-src-restrictions.patch;patch=1;pnum=2 \
+ file://top-autoconf.patch;patch=1 \
+ file://configure_in_cross.patch;patch=1 \
+ file://pppoe-src-restrictions.patch;patch=1 \
+ file://update-config.patch;patch=1 \
file://pppoe-server.default \
file://pppoe-server.init"
-S = "${WORKDIR}/${P}/src"
+S = "${WORKDIR}/${P}"
inherit autotools update-rc.d
do_install() {
- # Set timeout to 0. Fixes lots of reconnect issues
- # No need for full path to the PPPoE plugin, and it's in a different
- # Can't patch this in because it's outside of what we have {S} set to.
- sed -i -e 's,\(CONNECT_TIMEOUT=\)30,\10,g' \
- -e 's,\(LINUX_PLUGIN=\)/etc/ppp/plugins/rp-pppoe.so,\1rp-pppoe.so,g' \
- ${S}/../configs/pppoe.conf
# Install init script and default settings
install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d
install -m 0644 ${WORKDIR}/pppoe-server.default ${D}${sysconfdir}/default/pppoe-server