summaryrefslogtreecommitdiff
path: root/packages/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-06-08 06:13:53 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-06-08 06:13:53 +0000
commit612f7ecab32c79e28074e1a56184df7068bdbf9c (patch)
treee4837f918c5c13db6db8dc85a50e413e35c80886 /packages/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch
parentf7acf081277799b12a839fa32f97b36dbe4490fb (diff)
rp-pppoe 3.8: Fix issues caused by autoconf needing to run in the src
subdirectory of the source code. The OE autotools.bbclass runs the autoconf stuff in ${S}, so you need to change ${S} to the src subdirectory to get it to work. But ${S} is also where patches are appplied, so you can't patch the config files and other things which aren't in the src directory. So add some autoconf at the top level which just says there's a sub-autoconf project in the src subdirectory, fix up the patches, remove the sed hacks and add a new patch to do what the sed hacks were doing before.
Diffstat (limited to 'packages/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch')
-rw-r--r--packages/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch b/packages/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch
new file mode 100644
index 0000000000..e3b0482984
--- /dev/null
+++ b/packages/rp-pppoe/rp-pppoe-3.8/top-autoconf.patch
@@ -0,0 +1,25 @@
+The autoconf stuff is all in a subdirectory, which is rather annoying
+as OE expects patches to be applied and autoconf stuff to be done in
+S. This adds enough autoconf at the top level to allow it to be
+called there - all it does is run a sub autoconf stuff in the src
+directory.
+
+Index: rp-pppoe-3.8/Makefile.am
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ rp-pppoe-3.8/Makefile.am 2007-06-08 15:58:16.000000000 +1000
+@@ -0,0 +1,5 @@
++PACKAGE = rp-pppoe
++VERSION = 3.8
++
++dnl AM_CFLAGS = -Wall -DDEBUG
++SUBDIRS = src
+Index: rp-pppoe-3.8/configure.in
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ rp-pppoe-3.8/configure.in 2007-06-08 15:58:16.000000000 +1000
+@@ -0,0 +1,4 @@
++AC_INIT(src/pppoe.c)
++AM_INIT_AUTOMAKE([rp-pppoe], [3.8])
++AC_CONFIG_SUBDIRS(src)
++AC_OUTPUT(Makefile)