summaryrefslogtreecommitdiff
path: root/packages/rott/rott_1.0.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-04-24 21:40:24 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-24 21:40:24 +0000
commit74ca65b3d3574905a3bb314c96adf3c04096c3f1 (patch)
tree4431c7e92729d1381f79242adfae481ebbf39bec /packages/rott/rott_1.0.bb
parent07d17b04260013d429e6981cea821c791e79407f (diff)
rott: decouple from opie using sdl.bbclass
Diffstat (limited to 'packages/rott/rott_1.0.bb')
-rw-r--r--packages/rott/rott_1.0.bb20
1 files changed, 10 insertions, 10 deletions
diff --git a/packages/rott/rott_1.0.bb b/packages/rott/rott_1.0.bb
index 821e6ad962..5453001ed0 100644
--- a/packages/rott/rott_1.0.bb
+++ b/packages/rott/rott_1.0.bb
@@ -1,22 +1,22 @@
DESCRIPTION = "Rise of the Triad - an SDL based Doom clone - QtE based Palmtop Environments Edition"
-SECTION = "opie/games"
-PRIORITY = "optional"
+HOMEPAGE = "http://www.icculus.org/root"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL"
-DEPENDS = "virtual/libqpe libsdl-qpe libsdl-image libsdl-mixer"
-PR = "r1"
+PR = "r2"
-SRC_URI = "http://icculus.org/rott/releases/rott-${PV}.tar.gz"
+APPIMAGE = "${WORKDIR}/rott.jpg"
+
+SRC_URI = "http://icculus.org/rott/releases/rott-${PV}.tar.gz \
+ file://gcc4.patch;patch=1;pnum=2 \
+ file://rott.jpg"
S = "${WORKDIR}/rott-${PV}/rott"
CFLAGS += "-DPLATFORM_UNIX"
EXTRA_OEMAKE = 'SDL_INC_DIR=${STAGING_INCDIR}/SDL CC="${CC}" EXTRALDFLAGS="${LDFLAGS}"'
-# FIXME: Add Opie integration, i.e. a .desktop file and a logo
+inherit sdl
do_install() {
- install -d ${D}${palmtopdir}/bin/
- install -m 0755 rott ${D}${palmtopdir}/bin/
+ install -d ${D}${bindir}
+ install -m 0755 rott ${D}${bindir}
}
-
-FILES_${PN} = "${palmtopdir}"