summaryrefslogtreecommitdiff
path: root/packages/rdiff-backup/rdiff-backup.inc
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/rdiff-backup/rdiff-backup.inc
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/rdiff-backup/rdiff-backup.inc')
-rw-r--r--packages/rdiff-backup/rdiff-backup.inc41
1 files changed, 0 insertions, 41 deletions
diff --git a/packages/rdiff-backup/rdiff-backup.inc b/packages/rdiff-backup/rdiff-backup.inc
deleted file mode 100644
index d268736df8..0000000000
--- a/packages/rdiff-backup/rdiff-backup.inc
+++ /dev/null
@@ -1,41 +0,0 @@
-DESCRIPTION = "A python application that backs up one directory to \
-another, possibly over a network. It combines the best features of a \
-mirror and an incremental backup. The target directory ends up a copy \
-of the source directory, but extra reverse diffs are stored in a \
-special subdirectory of that target directory, so you can still \
-recover files lost some time ago. It is also able to preserve \
-subdirectories, hard links, dev files, permissions, uid/gid \
-ownership, modification times, extended attributes, acls, and \
-resource forks."
-HOMEPAGE = "http://www.nongnu.org/rdiff-backup/"
-SECTION = "network"
-LICENSE = "GPL"
-DEPENDS = "librsync"
-RDEPENDS_${PN} = "zlib python-re python-io python-lang python-datetime \
- python-pickle python-shell python-compression python-unixadmin \
- python-netclient"
-
-SRC_URI = "http://savannah.nongnu.org/download/rdiff-backup/rdiff-backup-${PV}.tar.gz"
-
-inherit distutils
-
-#
-# Without this the python interpreter path points to the staging area.
-#
-do_compile() {
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- ${STAGING_BINDIR_NATIVE}/python setup.py build --executable=${bindir}/python || \
- oefatal "python setup.py build execution failed."
-}
-
-#
-# The default do_install sets install-data to ${D}/${datadir} which
-# ends up with documentation in /usr/share/share/... instead of
-# /usr/share/... Modify the install data directory here to get it
-# into the correct place.
-#
-do_install() {
- BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
- ${STAGING_BINDIR_NATIVE}/python setup.py install --prefix=${D}/${prefix} --install-data=${D}/${prefix} || \
- oefatal "python setup.py install execution failed."
-}