summaryrefslogtreecommitdiff
path: root/packages/quagga
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/quagga
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/quagga')
-rw-r--r--packages/quagga/files/fix-for-lib-inpath.patch19
-rw-r--r--packages/quagga/files/quagga.default12
-rw-r--r--packages/quagga/files/quagga.init186
-rw-r--r--packages/quagga/files/volatiles.03_quagga2
-rw-r--r--packages/quagga/files/watchquagga.default7
-rw-r--r--packages/quagga/files/watchquagga.init57
-rw-r--r--packages/quagga/quagga.inc153
-rw-r--r--packages/quagga/quagga_0.99.6.bb5
-rw-r--r--packages/quagga/quagga_0.99.7.bb3
-rw-r--r--packages/quagga/quagga_0.99.8.bb3
10 files changed, 0 insertions, 447 deletions
diff --git a/packages/quagga/files/fix-for-lib-inpath.patch b/packages/quagga/files/fix-for-lib-inpath.patch
deleted file mode 100644
index 50f0ad502f..0000000000
--- a/packages/quagga/files/fix-for-lib-inpath.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-At first this worked, then I tried a clean build in a directory that
-contained lib in it (oe/build/titan-glibc) and vtysh no longer
-worked. It's test for the lib directory was excepting anything
-containing lib.
-
-With this patch you still cannot have lib in the path anywhere, but
-at least things containing lib will now work.
-
---- quagga-0.99.2/vtysh/extract.pl.in 2005/11/16 04:12:04 1.1
-+++ quagga-0.99.2/vtysh/extract.pl.in 2005/11/16 04:12:16
-@@ -89,7 +89,7 @@
- $cmd =~ s/\s+$//g;
-
- # $protocol is VTYSH_PROTO format for redirection of user input
-- if ($file =~ /lib/) {
-+ if ($file =~ /\/lib\//) {
- if ($file =~ /keychain.c/) {
- $protocol = "VTYSH_RIPD";
- }
diff --git a/packages/quagga/files/quagga.default b/packages/quagga/files/quagga.default
deleted file mode 100644
index 4c4bc23071..0000000000
--- a/packages/quagga/files/quagga.default
+++ /dev/null
@@ -1,12 +0,0 @@
-# If this option is set the /etc/init.d/quagga script automatically loads
-# the config via "vtysh -b" when the servers are started.
-vtysh_enable=yes
-
-# Bind all daemons to loopback only by default
-zebra_options=" --daemon -A 127.0.0.1"
-bgpd_options=" --daemon -A 127.0.0.1"
-ospfd_options=" --daemon -A 127.0.0.1"
-ospf6d_options="--daemon -A ::1"
-ripd_options=" --daemon -A 127.0.0.1"
-ripngd_options="--daemon -A ::1"
-isisd_options=" --daemon -A 127.0.0.1"
diff --git a/packages/quagga/files/quagga.init b/packages/quagga/files/quagga.init
deleted file mode 100644
index cfc02d8b81..0000000000
--- a/packages/quagga/files/quagga.init
+++ /dev/null
@@ -1,186 +0,0 @@
-#!/bin/sh
-#
-# /etc/init.d/quagga -- start/stop the Quagga routing daemons
-#
-# Based on debian version by Endre Hirling <endre@mail.elte.hu> and
-# Christian Hammers <ch@debian.org>.
-#
-
-# NOTE: sbin must be before bin so we get the iproute2 ip and not the
-# busybox ip command. The busybox one flushes all routes instead of just
-# the dynamic routes
-PATH=/sbin:/usr/sbin:/bin:/usr/bin:/sbin
-D_PATH=/usr/lib/quagga
-C_PATH=/etc/quagga
-DAEMONS="zebra bgpd ripd ripngd ospfd ospf6d isisd" # keep zebra first!
-
-# Print the name of the pidfile.
-pidfile()
-{
- echo "/var/run/quagga/$1.pid"
-}
-
-# Check if daemon is started by using the pidfile.
-started()
-{
- [ -e `pidfile $1` ] && kill -0 `cat \`pidfile $1\`` 2> /dev/null && return 0
- return 1
-}
-
-# Loads the config via vtysh -b if configured to do so.
-vtysh_b ()
-{
- # Rember, that all variables have been incremented by 1 in convert_daemon_prios()
- if [ "$vtysh_enable" = 2 -a -f $C_PATH/Quagga.conf ]; then
- /usr/bin/vtysh -b
- fi
-}
-
-# Check if the daemon is activated and if its executable and config files
-# are in place.
-# params: daemon name
-# returns: 0=ok, 1=error
-check_daemon()
-{
- # If the integrated config file is used the others are not checked.
- if [ -r "$C_PATH/Quagga.conf" ]; then
- return 0
- fi
-
- # check for config file
- if [ ! -r "$C_PATH/$1.conf" ]; then
- return 1
- fi
- return 0
-}
-
-# Starts the server if it's not alrady running according to the pid file.
-# The Quagga daemons creates the pidfile when starting.
-start()
-{
- if ! check_daemon $1; then echo -n " (!$1)"; return; fi
- echo -n " $1"
- start-stop-daemon \
- --start \
- --pidfile=`pidfile $1` \
- --exec "$D_PATH/$1" \
- -- \
- `eval echo "$""$1""_options"`
-
-}
-
-# Stop the daemon given in the parameter, printing its name to the terminal.
-stop()
-{
- if ! started "$1" ; then
- echo -n " (!$1)"
- return 0
- else
- PIDFILE=`pidfile $1`
- PID=`cat $PIDFILE 2>/dev/null`
- start-stop-daemon --stop --quiet --exec "$D_PATH/$1"
- #
- # Now we have to wait until $DAEMON has _really_ stopped.
- #
- if test -n "$PID" && kill -0 $PID 2>/dev/null; then
- echo -n " (waiting) ."
- cnt=0
- while kill -0 $PID 2>/dev/null; do
- cnt=`expr $cnt + 1`
- if [ $cnt -gt 60 ]; then
- # Waited 120 secs now, fail.
- echo -n "Failed.. "
- break
- fi
- sleep 2
- echo -n "."
- done
- fi
- echo -n " $1"
- rm -f `pidfile $1`
- fi
-}
-
-stop_all()
-{
- local daemon_list
- daemon_list=${1:-$DAEMONS}
-
- echo -n "Stopping Quagga daemons:"
- for daemon_name in $daemon_list; do
- stop "$daemon_name"
- done
- echo "."
-}
-
-start_all()
-{
- local daemon_list
- daemon_list=${1:-$DAEMONS}
-
- echo -n "Starting Quagga daemons:"
- for daemon_name in $daemon_list; do
- start "$daemon_name"
- done
- echo "."
-}
-
-status_all()
-{
- local daemon_list
- daemon_list=${1:-$DAEMONS}
- res=1
-
- echo -n "quagga: "
- for daemon_name in $daemon_list; do
- if started "$daemon_name" ; then
- id=`cat \`pidfile $daemon_name\``
- echo -n "$daemon_name (pid $id) "
- res=0
- fi
- done
- if [ $res -eq 0 ]; then
- echo "is running..."
- else
- echo "is stopped..."
- fi
- exit $res
-}
-
-#########################################################
-# Main program #
-#########################################################
-
-# Load configuration
-test -f /etc/default/quagga && . /etc/default/quagga
-
-case "$1" in
- start)
- cd $C_PATH/
- start_all $2
- vtysh_b
- ;;
-
- stop)
- stop_all $2
- echo "Removing all routes made by zebra."
- ip route flush proto zebra
- ;;
-
- status)
- status_all $2
- ;;
-
- restart|force-reload)
- $0 stop $2
- sleep 1
- $0 start $2
- ;;
-
- *)
- echo "Usage: /etc/init.d/quagga {start|stop|restart|status|force-reload} [daemon]"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/quagga/files/volatiles.03_quagga b/packages/quagga/files/volatiles.03_quagga
deleted file mode 100644
index 672fec6b92..0000000000
--- a/packages/quagga/files/volatiles.03_quagga
+++ /dev/null
@@ -1,2 +0,0 @@
-# <type> <owner> <group> <mode> <path> <linksource>
-d quagga quagga 0755 /var/run/quagga none
diff --git a/packages/quagga/files/watchquagga.default b/packages/quagga/files/watchquagga.default
deleted file mode 100644
index f1520326f1..0000000000
--- a/packages/quagga/files/watchquagga.default
+++ /dev/null
@@ -1,7 +0,0 @@
-# Watchquagga configuration
-#watch_daemons="zebra bgpd ospfd ospf6d ripd ripngd"
-watch_daemons="zebra"
-
-# To enable restarts, uncomment this line (but first be sure to edit
-# the WATCH_DAEMONS line to reflect the daemons you are actually using):
-watch_options="-Az -b_ -r/etc/init.d/quagga_restart_%s -s/etc/init.d/quagga_start_%s -k/etc/init.d/quagga_stop_%s"
diff --git a/packages/quagga/files/watchquagga.init b/packages/quagga/files/watchquagga.init
deleted file mode 100644
index 79be16d3e6..0000000000
--- a/packages/quagga/files/watchquagga.init
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh
-#
-# /etc/init.d/watchquagga -- start/stop the Quagga watchdog
-#
-PATH=/bin:/usr/bin:/sbin:/usr/sbin
-
-# Load configuration
-test -f /etc/default/watchquagga && . /etc/default/watchquagga
-
-# Check that there are daemons to be monitored.
-[ -z "$watch_daemons" ] && exit 0
-
-pidfile="/var/run/quagga/watchquagga.pid"
-
-case "$1" in
- start)
- echo -n "Starting quagga watchdog daemon: watchquagga"
- start-stop-daemon --start \
- --pidfile $pidfile \
- --exec /usr/lib/quagga/watchquagga \
- -- -d $watch_options $watch_daemons
- echo "."
- ;;
-
- stop)
- echo -n "Stopping quagga watchdog daemon: watchquagga"
- start-stop-daemon --stop --quiet \
- --pidfile $pidfile
- echo "."
- ;;
-
- status)
- echo -n "watchquagga "
- res=1
- [ -e $pidfile ] && kill -0 `cat $pidfile` 2> /dev/null
- if [ $? -eq 0 ]; then
- echo "(pid `cat $pidfile`) is running..."
- res=0
- else
- echo "is stopped..."
- fi
- exit $res
- ;;
-
- restart|force-reload)
- $0 stop $2
- sleep 1
- $0 start $2
- ;;
-
- *)
- echo "Usage: /etc/init.d/watchquagga {start|stop|restart|force-reload}"
- exit 1
- ;;
-esac
-
-exit 0
diff --git a/packages/quagga/quagga.inc b/packages/quagga/quagga.inc
deleted file mode 100644
index f81a062ed9..0000000000
--- a/packages/quagga/quagga.inc
+++ /dev/null
@@ -1,153 +0,0 @@
-DESCRIPTION = "Quagga is a routing software suite, providing \
-implementations of OSPFv2, OSPFv3, RIP v1 and v2, RIPv3 and BGPv4 for \
-Unix platforms, particularly FreeBSD, Linux, Solaris and NetBSD. \
-Quagga is a fork of GNU Zebra which was developed by Kunihiro \
-Ishiguro. The Quagga tree aims to build a more involved community \
-around Quagga than the current centralised model of GNU Zebra."
-HOMEPAGE = "http://www.quagga.net/"
-SECTION = "network"
-LICENSE = "GPL"
-DEPENDS = "readline ncurses perl-native"
-# Each of the per-protocol packages depends on the main package
-RDEPENDS_${PN}-ospfd = "${PN}"
-RDEPENDS_${PN}-ospf6d = "${PN}"
-RDEPENDS_${PN}-bgpd = "${PN}"
-RDEPENDS_${PN}-ripd = "${PN}"
-RDEPENDS_${PN}-ripngd = "${PN}"
-RDEPENDS_${PN}-isisd = "${PN}"
-RDEPENDS_${PN}-ospfclient = "${PN}"
-RDEPENDS_${PN}-doc = ""
-RDEPENDS_${PN}-watchquagga = "${PN}"
-# the "ip" command from busybox is not sufficient (flush by protocol flushes all routes)
-RDEPENDS_${PN} += "iproute2"
-
-QUAGGASUBDIR = ""
-
-# ${QUAGGASUBDIR} is deal with old versions. Set to "/attic" for old
-# versions and leave it empty for recent versions.
-SRC_URI = "http://www.quagga.net/download${QUAGGASUBDIR}/quagga-${PV}.tar.gz \
- file://fix-for-lib-inpath.patch;patch=1 \
- file://quagga.init \
- file://quagga.default \
- file://watchquagga.init \
- file://watchquagga.default \
- file://volatiles.03_quagga"
-
-inherit autotools update-rc.d
-
-# Turn on options and changes paths.
-# This matches the layout and configuration of the debian quagga package
-EXTRA_OECONF = "--prefix=${prefix} \
- --libexecdir=${libexecdir}/quagga \
- --sbindir=${libdir}/quagga \
- --sysconfdir=${sysconfdir}/quagga \
- --localstatedir=${localstatedir}/run/quagga \
- --enable-exampledir=${docdir}/quagga/examples/ \
- --enable-vtysh \
- --enable-isisd \
- --enable-watchquagga \
- --enable-ospf-te \
- --enable-opaque-lsa \
- --enable-ipv6 \
- --enable-ospfclient=yes \
- --enable-multipath=64 \
- --enable-user=quagga \
- --enable-group=quagga \
- --enable-vty-group=quaggavty \
- --enable-configfile-mask=0640 \
- --enable-logfile-mask=0640 \
- --enable-rtadv \
- --enable-tcp-md5"
-
-do_install () {
- # Install init script and default settings
- install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d \
- ${D}${sysconfdir}/quagga ${D}${sysconfdir}/default/volatiles
- install -m 0644 ${WORKDIR}/quagga.default ${D}${sysconfdir}/default/quagga
- install -m 0644 ${WORKDIR}/watchquagga.default ${D}${sysconfdir}/default/watchquagga
- install -m 0755 ${WORKDIR}/quagga.init ${D}${sysconfdir}/init.d/quagga
- install -m 0755 ${WORKDIR}/watchquagga.init ${D}${sysconfdir}/init.d/watchquagga
- install -m 0644 ${WORKDIR}/volatiles.03_quagga ${D}${sysconfdir}/default/volatiles/volatiles.03_quagga
- # Install quagga
- oe_runmake install DESTDIR=${D} prefix=${prefix} \
- libexecdir=${libexecdir}/quagga \
- sbindir=${libdir}/quagga \
- sysconfdir=${sysconfdir}/quagga \
- localstatedir=${localstatedir}/run/quagga
-}
-
-# Split into a main package and seperate per-protocol packages
-PACKAGES = "${PN}-dbg ${PN} \
- ${PN}-ospfd ${PN}-ospf6d ${PN}-bgpd ${PN}-ripd ${PN}-ripngd ${PN}-isisd \
- ${PN}-ospfclient ${PN}-watchquagga ${PN}-dev ${PN}-doc"
-
-FILES_${PN}-ospfd = "${libdir}/quagga/ospfd /usr/lib/libospf.so.*"
-FILES_${PN}-ospf6d = "${libdir}/quagga/ospf6d"
-FILES_${PN}-bgpd = "${libdir}/quagga/bgpd"
-FILES_${PN}-ripd = "${libdir}/quagga/ripd"
-FILES_${PN}-ripngd = "${libdir}/quagga/ripngd"
-FILES_${PN}-isisd = "${libdir}/quagga/isisd"
-FILES_${PN}-ospfclient = "${libdir}/quagga/ospfclient /usr/lib/libospfapiclient.so.*"
-FILES_${PN}-dev = "/usr/include /usr/lib/lib*.so /usr/lib/*.la /usr/lib/*.a"
-FILES_${PN}-doc = "/usr/share/doc /usr/share/man /usr/share/info"
-FILES_${PN}-watchquagga = "${libdir}/quagga/watchquagga ${sysconfdir}/default/watchquagga \
- ${sysconfdir}/init.d/watchquagga"
-FILES_${PN} = "${bindir}/vtysh ${libdir}/quagga/zebra /usr/lib/libzebra*.so.* \
- ${sysconfdir}/default/volatiles/volatiles.03_quagga \
- ${sysconfdir}/quagga \
- ${sysconfdir}/default/quagga ${sysconfdir}/init.d/quagga"
-
-# Indicate that the default files are configuration files
-CONFFILES_${PN} = "${sysconfdir}/default/quagga"
-CONFFILES_${PN}-watchquagga = "${sysconfdir}/default/watchquagga"
-
-# Stop the names being rewritten due to the internal shared libraries
-DEBIAN_NOAUTONAME_${PN}-ospfd = "1"
-DEBIAN_NOAUTONAME_${PN}-ospfclient = "1"
-
-# Main init script starts all deamons
-# Seperate init script for watchquagga
-INITSCRIPT_PACKAGES = "${PN} ${PN}-watchquagga"
-INITSCRIPT_NAME_${PN} = "quagga"
-INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
-INITSCRIPT_NAME_${PN}-watchquagga = "watchquagga"
-INITSCRIPT_PARAMS_${PN}-watchquagga = "defaults 90 10"
-
-# Add quagga's user and groups
-pkg_postinst_${PN} () {
- grep -q quagga: /etc/group || addgroup quagga
- grep -q quaggavty: /etc/group || addgroup quaggavty
- grep -q quagga: /etc/passwd || \
- adduser --disabled-password --home=/var/run/quagga/ --system \
- --ingroup quagga --no-create-home -g "Quagga routing suite" quagga
- /etc/init.d/populate-volatile.sh update
-}
-
-# Stop apps before uninstall
-pkg_prerm_${PN} () {
- ${sysconfdir}/init.d/quagga stop
-}
-
-pkg_prerm_${PN}-ospfd () {
- ${sysconfdir}/init.d/quagga stop ospfd
-}
-
-pkg_prerm_${PN}-ospf6d () {
- ${sysconfdir}/init.d/quagga stop ospf6d
-}
-
-pkg_prerm_${PN}-bgpd () {
- ${sysconfdir}/init.d/quagga stop bgpd
-}
-
-pkg_prerm_${PN}-ripd () {
- ${sysconfdir}/init.d/quagga stop ripd
-}
-
-pkg_prerm_${PN}-ripngd () {
- ${sysconfdir}/init.d/quagga stop ripngd
-}
-
-pkg_prerm_${PN}-isisd () {
- ${sysconfdir}/init.d/quagga stop isisd
-}
diff --git a/packages/quagga/quagga_0.99.6.bb b/packages/quagga/quagga_0.99.6.bb
deleted file mode 100644
index 9911f519d0..0000000000
--- a/packages/quagga/quagga_0.99.6.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-PR = "r2"
-
-require quagga.inc
-
-QUAGGASUBDIR = "/attic" \ No newline at end of file
diff --git a/packages/quagga/quagga_0.99.7.bb b/packages/quagga/quagga_0.99.7.bb
deleted file mode 100644
index 7401534db5..0000000000
--- a/packages/quagga/quagga_0.99.7.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require quagga.inc
-
-QUAGGASUBDIR = "/attic" \ No newline at end of file
diff --git a/packages/quagga/quagga_0.99.8.bb b/packages/quagga/quagga_0.99.8.bb
deleted file mode 100644
index 7401534db5..0000000000
--- a/packages/quagga/quagga_0.99.8.bb
+++ /dev/null
@@ -1,3 +0,0 @@
-require quagga.inc
-
-QUAGGASUBDIR = "/attic" \ No newline at end of file