summaryrefslogtreecommitdiff
path: root/packages/qtopia-phone
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-03-15 20:18:24 +0000
committerHolger Freyther <zecke@selfish.org>2008-03-15 20:18:24 +0000
commit15583248362ff2562d5fcb02c1462864dd00e349 (patch)
tree1bf428f88e9d8a76a6ea6d1756403ca7d1fd8a90 /packages/qtopia-phone
parent7ae19771c6dc0f98120a0e30e4fb43bfe2ccfcbd (diff)
Qtopia/X11: Install a qtopia.sh into the profile.d to set PATH, QPEDIR and LD_LIBRARY_PATH
Diffstat (limited to 'packages/qtopia-phone')
-rw-r--r--packages/qtopia-phone/qtopia-phone-x11/qtopia.sh4
-rw-r--r--packages/qtopia-phone/qtopia-phone-x11_4.3.1.bb8
2 files changed, 10 insertions, 2 deletions
diff --git a/packages/qtopia-phone/qtopia-phone-x11/qtopia.sh b/packages/qtopia-phone/qtopia-phone-x11/qtopia.sh
new file mode 100644
index 0000000000..823d27dc93
--- /dev/null
+++ b/packages/qtopia-phone/qtopia-phone-x11/qtopia.sh
@@ -0,0 +1,4 @@
+#!/bin/sh
+export QPEDIR=/opt/Qtopia
+export PATH=$PATH=$QPEDIR/bin
+export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$QPEDIR/lib
diff --git a/packages/qtopia-phone/qtopia-phone-x11_4.3.1.bb b/packages/qtopia-phone/qtopia-phone-x11_4.3.1.bb
index e4be0e7246..89984bf5ef 100644
--- a/packages/qtopia-phone/qtopia-phone-x11_4.3.1.bb
+++ b/packages/qtopia-phone/qtopia-phone-x11_4.3.1.bb
@@ -12,12 +12,13 @@ PRIORITY = "optional"
HOMEPAGE = "http://www.trolltech.com"
DEPENDS = "glib-2.0 dbus freetype alsa-lib bluez-libs virtual/libx11 fontconfig xft libxext libxrender libxrandr libxcursor libxtst"
PROVIDES = "qtopia-phone"
-PR = "r2"
+PR = "r4"
SRCREV = "${AUTOREV}"
SRC_URI = "git://git.openmoko.org/git/qtopia.git;protocol=git \
file://device-conf \
file://qplatformdefs.h \
- file://Xsession.d/99qtopia"
+ file://Xsession.d/99qtopia \
+ file://qtopia.sh"
S = "${WORKDIR}/git"
@@ -116,6 +117,9 @@ do_install() {
# Install some scripts
install -d ${D}${bindir}
install -m 0755 ${S}/bin/qcop-x11-launch ${D}${bindir}
+
+ install -d ${D}${sysconfdir}/profile.d/
+ install -m 0755 ${WORKDIR}/qtopia.sh ${D}${sysconfdir}/profile.d/
}
FILES_${PN} += "${OE_QT_RPREFIX}/bin ${OE_QT_RPREFIX}/help \