summaryrefslogtreecommitdiff
path: root/packages/qtnx/qtnx_0.9.bb
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2008-09-08 06:07:20 +0000
committerMike Westerhof <mwester@dls.net>2008-09-08 06:07:20 +0000
commit078763a440425b9b9a0862e6ecabdf1c1af35def (patch)
tree80e4caca405a3b94eb893b462312e41708ba0659 /packages/qtnx/qtnx_0.9.bb
parentfbe2d6775362947d2aa59f27c3ab190997d10c02 (diff)
parent313ea062889aba322b75726d8bb7276665aa4ea3 (diff)
merge of '79b90d4ef7df69035b001466908501f67f8aac76'
and '81a14649e513b12b58d75276170ffa386580f244'
Diffstat (limited to 'packages/qtnx/qtnx_0.9.bb')
-rw-r--r--packages/qtnx/qtnx_0.9.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/qtnx/qtnx_0.9.bb b/packages/qtnx/qtnx_0.9.bb
new file mode 100644
index 0000000000..d0ed565b36
--- /dev/null
+++ b/packages/qtnx/qtnx_0.9.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "This a the freesource nx client, build with qt"
+HOMEPAGE = "http://freenx.berlios.de/"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r0"
+
+DEPENDS = "libnxcl"
+
+SRC_URI = "http://download.berlios.de/freenx/freenx-client-${PV}.tar.bz2 \
+ file://pro.patch;patch=1 \
+ file://id-path.patch;patch=1 \
+ file://scroll.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/freenx-client-${PV}/qtnx"
+
+inherit qtopia4core
+
+
+FILES_${PN} += ${datadir}/id.key
+
+do_configure_prepend () {
+
+ rm ${S}/qtnxwin32.pro
+
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -s -m 0755 qtnx ${D}${bindir}/
+ install -d ${D}${datadir}/
+ install -m 0644 id.key ${D}${datadir}/
+}
+