summaryrefslogtreecommitdiff
path: root/packages/qtnx/qtnx_0.9.bb
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-09-07 19:20:12 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-09-07 19:20:12 +0000
commit313ea062889aba322b75726d8bb7276665aa4ea3 (patch)
tree163715ed810aaded923d822f62f48d0dff13af34 /packages/qtnx/qtnx_0.9.bb
parent5c13c6371f8dca83d3b8c63cb94150c8d1439738 (diff)
qtnx: import qtnx to openembedded
* added id-path.patch from debian * added pro and scroll.patch, which are my work * final commit for nx-client support in oe * only compile tested against qt-embedded
Diffstat (limited to 'packages/qtnx/qtnx_0.9.bb')
-rw-r--r--packages/qtnx/qtnx_0.9.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/qtnx/qtnx_0.9.bb b/packages/qtnx/qtnx_0.9.bb
new file mode 100644
index 0000000000..d0ed565b36
--- /dev/null
+++ b/packages/qtnx/qtnx_0.9.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "This a the freesource nx client, build with qt"
+HOMEPAGE = "http://freenx.berlios.de/"
+SECTION = "libs"
+LICENSE = "GPL"
+PR = "r0"
+
+DEPENDS = "libnxcl"
+
+SRC_URI = "http://download.berlios.de/freenx/freenx-client-${PV}.tar.bz2 \
+ file://pro.patch;patch=1 \
+ file://id-path.patch;patch=1 \
+ file://scroll.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/freenx-client-${PV}/qtnx"
+
+inherit qtopia4core
+
+
+FILES_${PN} += ${datadir}/id.key
+
+do_configure_prepend () {
+
+ rm ${S}/qtnxwin32.pro
+
+}
+
+do_install () {
+ install -d ${D}${bindir}/
+ install -s -m 0755 qtnx ${D}${bindir}/
+ install -d ${D}${datadir}/
+ install -m 0644 id.key ${D}${datadir}/
+}
+