diff options
author | Paul Sokolovsky <pmiscml@gmail.com> | 2006-11-19 02:29:00 +0000 |
---|---|---|
committer | Paul Sokolovsky <pmiscml@gmail.com> | 2006-11-19 02:29:00 +0000 |
commit | dbfde8f842b65ccfd7bf929e9660c7305e30764b (patch) | |
tree | 3fc6fb4170c9151a58165c164a2bc6a88aa521b8 /packages/qte/qte-common_2.3.10.inc | |
parent | 2380fca3a354471ea5c8a396732b67d1d1257a54 (diff) |
qpe 2.3.10: Apply common keyboardless buttonmap for HH.org kernel ports.
* keyboardless-buttonmap.patch does that
* ipaq-keyboard.patch is patch for 2.4 kernels, should go away.
* ipaq_sound_fix.patch status is unknown. It seems to conatin useful
validation patch, but at the same time talks about hardcoding something
for uda1341 (which also smells of 2.4). Either way, if it contains something
useful, it should be applied consistently for all machines. While it isn't,
it won't be too much issue to disable it for pocket-pc based devices too.
* Tested on h4000.
++
+ case 0x78:
+ # if defined(QT_QWS_IPAQ)
+ keyCode = Key_F24; // record
============================================================
--- packages/qte/qte-common_2.3.10.inc 6323bf41e47d7a950cc2729723dbcbb6f884e853
+++ packages/qte/qte-common_2.3.10.inc b4b84ab449bfd459e2a61d20bac3d2e3e527e2c2
@@ -37,6 +37,7 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/q
file://fix-native-build.patch;patch=1 \
file://simpad-defaultkbd.patch;patch=1 \
file://fix-errno-exception-spec.patch;patch=1 \
+ file://keyboardless-buttonmap.patch;patch=1 \
file://sharp_char.h \
file://switches.h "
@@ -62,16 +63,16 @@ SRC_URI_append_mnci = "file://de
file://mnci-touchscreen.patch;patch=1 \
file://qkeyboard_qws.h \
file://qkeyboard_qws.cpp "
-SRC_URI_append_h1910 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_h1940 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_h2200 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_h3600 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_h3900 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_h4000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_h5xxx = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_h6300 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_hx2000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
-SRC_URI_append_hx4700 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h1910 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h1940 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h2200 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h3600 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h3900 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h4000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h5xxx = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_h6300 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_hx2000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
+#SRC_URI_append_hx4700 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 "
S = "${WORKDIR}/qt-${PV}"
============================================================
--- packages/qte/qte-mt_2.3.10.bb 6bcca53c33775f83f414b169ac273be1b7f443a3
+++ packages/qte/qte-mt_2.3.10.bb 090b792876515bb19e14563250d46729dc54c88d
@@ -1,5 +1,5 @@ require qte-common_${PV}.inc
require qte-common_${PV}.inc
-PR = "r4"
+PR = "r5"
Diffstat (limited to 'packages/qte/qte-common_2.3.10.inc')
-rw-r--r-- | packages/qte/qte-common_2.3.10.inc | 21 |
1 files changed, 11 insertions, 10 deletions
diff --git a/packages/qte/qte-common_2.3.10.inc b/packages/qte/qte-common_2.3.10.inc index 147e83edb0..1b3043bf18 100644 --- a/packages/qte/qte-common_2.3.10.inc +++ b/packages/qte/qte-common_2.3.10.inc @@ -37,6 +37,7 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz;m file://fix-native-build.patch;patch=1 \ file://simpad-defaultkbd.patch;patch=1 \ file://fix-errno-exception-spec.patch;patch=1 \ + file://keyboardless-buttonmap.patch;patch=1 \ file://sharp_char.h \ file://switches.h " @@ -62,16 +63,16 @@ SRC_URI_append_mnci = "file://devfs.patch;patch=1 \ file://mnci-touchscreen.patch;patch=1 \ file://qkeyboard_qws.h \ file://qkeyboard_qws.cpp " -SRC_URI_append_h1910 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_h1940 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_h2200 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_h3600 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_h3900 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_h4000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_h5xxx = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_h6300 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_hx2000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " -SRC_URI_append_hx4700 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h1910 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h1940 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h2200 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h3600 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h3900 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h4000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h5xxx = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_h6300 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_hx2000 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " +#SRC_URI_append_hx4700 = "file://ipaq-keyboard.patch;patch=1 file://ipaq_sound_fix.patch;patch=1 " S = "${WORKDIR}/qt-${PV}" |