summaryrefslogtreecommitdiff
path: root/packages/qt4
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-12-24 01:27:26 +0000
committerHolger Freyther <zecke@selfish.org>2007-12-24 01:27:26 +0000
commit32a24933810026b6a730a0377889fa73430501cc (patch)
tree61bb887e5be79ad6ab5a0668a77be0f2acfe2de5 /packages/qt4
parentf53bfcb679b66b329fe13418d492d9c289472e6e (diff)
packages/qt4/qt4-x11-free, qtopia-core: Move boilerplate lines to a .inc file
Diffstat (limited to 'packages/qt4')
-rw-r--r--packages/qt4/qt4-x11-free.inc23
-rw-r--r--packages/qt4/qt4-x11-free_4.3.3.bb33
-rw-r--r--packages/qt4/qtopia-core.inc17
-rw-r--r--packages/qt4/qtopia-core_4.3.3.bb22
4 files changed, 47 insertions, 48 deletions
diff --git a/packages/qt4/qt4-x11-free.inc b/packages/qt4/qt4-x11-free.inc
new file mode 100644
index 0000000000..3dedb4f548
--- /dev/null
+++ b/packages/qt4/qt4-x11-free.inc
@@ -0,0 +1,23 @@
+DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
+SECTION = "x11/libs"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+LICENSE = "GPL QPL"
+DEPENDS = "pkgconfig-native uicmoc4-native qmake2-native freetype jpeg virtual/libx11 \
+ xft libxext libxrender libxrandr libxcursor dbus openssl"
+PROVIDES = "qt4x11"
+PR = "r6"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
+ file://0001-cross-compile.patch;patch=1 \
+ file://0003-no-tools.patch;patch=1 \
+ file://0004-no-qmake.patch;patch=1 \
+ file://0005-fix-mkspecs.patch;patch=1"
+S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
+
+inherit qmake_base qt4x11
+
+QT_BASE_NAME = "qt4"
+QT_BASE_LIB = "libqt"
+QT_LIBRARY_NAME = "libQt"
+require qt_packaging.inc
diff --git a/packages/qt4/qt4-x11-free_4.3.3.bb b/packages/qt4/qt4-x11-free_4.3.3.bb
index b52b1c0394..b8876541b6 100644
--- a/packages/qt4/qt4-x11-free_4.3.3.bb
+++ b/packages/qt4/qt4-x11-free_4.3.3.bb
@@ -1,27 +1,4 @@
-DESCRIPTION = "Qt is a versatile cross-platform application framework -- this is the X11 version."
-SECTION = "x11/libs"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.trolltech.com"
-LICENSE = "GPL QPL"
-DEPENDS = "pkgconfig-native uicmoc4-native qmake2-native freetype jpeg virtual/libx11 \
- xft libxext libxrender libxrandr libxcursor dbus openssl"
-PROVIDES = "qt4x11"
-PR = "r6"
-
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-x11-opensource-src-${PV}.tar.gz \
- file://0001-cross-compile.patch;patch=1 \
- file://0002-fix-resinit-declaration.patch;patch=1 \
- file://0003-no-tools.patch;patch=1 \
- file://0004-no-qmake.patch;patch=1 \
- file://0005-fix-mkspecs.patch;patch=1 \
- file://0006-freetype-host-includes.patch;patch=1 \
- file://0007-openssl-host-includes.patch;patch=1"
-S = "${WORKDIR}/qt-x11-opensource-src-${PV}"
-
PARALLEL_MAKE = ""
-
-inherit qmake_base qt4x11
-
export QTDIR = "${S}"
STAGING_QT_DIR = "${STAGING_DIR}/${TARGET_SYS}/qt4"
EXTRA_OEMAKE = "-e"
@@ -116,7 +93,9 @@ do_install() {
rm ${D}${bindir}/rcc ${D}${bindir}/uic ${D}${bindir}/moc
}
-QT_BASE_NAME = "qt4"
-QT_BASE_LIB = "libqt"
-QT_LIBRARY_NAME = "libQt"
-require qt_packaging.inc
+require qt4-x11-free.inc
+
+SRC_URI += " \
+ file://0002-fix-resinit-declaration.patch;patch=1 \
+ file://0006-freetype-host-includes.patch;patch=1 \
+ file://0007-openssl-host-includes.patch;patch=1 "
diff --git a/packages/qt4/qtopia-core.inc b/packages/qt4/qtopia-core.inc
new file mode 100644
index 0000000000..cf8c0cc411
--- /dev/null
+++ b/packages/qt4/qtopia-core.inc
@@ -0,0 +1,17 @@
+SUMMARY = "QtopiaCore"
+SECTION = "libs"
+LICENSE = "GPL"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.trolltech.com"
+DEPENDS = "freetype tslib"
+
+SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
+ file://linux-oe-qmake.conf"
+S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
+inherit pkgconfig
+
+
+QT_BASE_NAME = "qtopiacore"
+QT_BASE_LIB = "libqtopiacore"
+QT_LIBRARY_NAME = "libQt"
+require qt_packaging.inc
diff --git a/packages/qt4/qtopia-core_4.3.3.bb b/packages/qt4/qtopia-core_4.3.3.bb
index 3e66d9f1b0..d1a811cc2d 100644
--- a/packages/qt4/qtopia-core_4.3.3.bb
+++ b/packages/qt4/qtopia-core_4.3.3.bb
@@ -1,19 +1,3 @@
-SUMMARY = "QtopiaCore"
-SECTION = "libs"
-LICENSE = "GPL"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.trolltech.com"
-DEPENDS = "freetype tslib"
-
-PR = "r0"
-
-SRC_URI = "ftp://ftp.trolltech.com/qt/source/qtopia-core-opensource-src-${PV}.tar.gz \
- file://linux-oe-qmake.conf"
-
-S = "${WORKDIR}/qtopia-core-opensource-src-${PV}"
-
-inherit pkgconfig
-
# Qmake gets confused by environment variables, as it builds both HOST
# and TARGET objects. The correct compiler settings come from the mkspec
# and are set with the OE_QMAKE_ variables
@@ -148,8 +132,4 @@ do_stage() {
rm -rf ${STAGE_TEMP}
}
-
-QT_BASE_NAME = "qtopiacore"
-QT_BASE_LIB = "libqtopiacore"
-QT_LIBRARY_NAME = "libQt"
-require qt_packaging.inc
+require qtopia-core.inc