summaryrefslogtreecommitdiff
path: root/packages/qt4
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-12-24 01:17:45 +0000
committerHolger Freyther <zecke@selfish.org>2007-12-24 01:17:45 +0000
commitf53bfcb679b66b329fe13418d492d9c289472e6e (patch)
tree7ff349eb9e528d8fff8f20292302dfe1e9359492 /packages/qt4
parent39dbfbe23ad2f6dc14244d27c08fd4979918bea4 (diff)
package/qt4/qt4-x11-free,qtopia-core: Start sharing packaging
The font and translations are a bit hairy and need further work. The idea is that at one point in time we can install Qt/X11 and Qt/Embedded side by side again. Headers and tools still need some time.
Diffstat (limited to 'packages/qt4')
-rw-r--r--packages/qt4/qt4-x11-free_4.3.3.bb73
-rw-r--r--packages/qt4/qt_packaging.inc114
-rw-r--r--packages/qt4/qtopia-core_4.3.3.bb77
3 files changed, 123 insertions, 141 deletions
diff --git a/packages/qt4/qt4-x11-free_4.3.3.bb b/packages/qt4/qt4-x11-free_4.3.3.bb
index 2fa53a4d54..b52b1c0394 100644
--- a/packages/qt4/qt4-x11-free_4.3.3.bb
+++ b/packages/qt4/qt4-x11-free_4.3.3.bb
@@ -5,7 +5,6 @@ HOMEPAGE = "http://www.trolltech.com"
LICENSE = "GPL QPL"
DEPENDS = "pkgconfig-native uicmoc4-native qmake2-native freetype jpeg virtual/libx11 \
xft libxext libxrender libxrandr libxcursor dbus openssl"
-RDEPENDS_${PN} = "${NONDEV_PACKAGES}"
PROVIDES = "qt4x11"
PR = "r6"
@@ -117,71 +116,7 @@ do_install() {
rm ${D}${bindir}/rcc ${D}${bindir}/uic ${D}${bindir}/moc
}
-NONDEV_PACKAGES = "libqtcore4 libqtgui4 libqtnetwork4 \
- libqtsql4 libqtsvg4 libqttest4 \
- libqtxml4 \
- libqtdesigner4 libqtdesignercomponents4 \
- libqt3support4 \
- libqtassistantclient4 libqtscript4 \
- libqtdbus4 \
- qt4-assistant qt4-common qt4-designer qt4-demos qt4-examples qt4-linguist \
- qt4-pixeltool qt4-dbus \
- qt4-plugins-accessible qt4-plugins-codecs qt4-plugins-designer qt4-plugins-imageformats qt4-plugins-sqldrivers \
- qt4-plugins-inputmethods qt4-plugins-iconengines"
-
-PACKAGES += "libqtcore4-dev libqtgui4-dev libqtnetwork4-dev libqtsql4-dev libqtsvg4-dev libqttest4-dev \
- libqtxml4-dev libqtdesigner4-dev libqtdesignercomponents4-dev libqt3support4-dev \
- libqtassistantclient4-dev libqtscript4-dev libqtdbus4-dev \
- ${NONDEV_PACKAGES}"
-
-ALLOW_EMPTY = "1"
-FILES_${PN} = ""
-
-FILES_libqtcore4 = "${libdir}/libQtCore.so.*"
-FILES_libqtcore4-dev = "${libdir}/libQtCore.so"
-FILES_libqtgui4 = "${libdir}/libQtGui.so.*"
-FILES_libqtgui4-dev = "${libdir}/libQtGui.so"
-FILES_libqtnetwork4 = "${libdir}/libQtNetwork.so.*"
-FILES_libqtnetwork4-dev = "${libdir}/libQtNetwork.so"
-FILES_libqtsql4 = "${libdir}/libQtSql.so.*"
-FILES_libqtsql4-dev = "${libdir}/libQtSql.so"
-FILES_libqtsvg4 = "${libdir}/libQtSvg.so.*"
-FILES_libqtsvg4-dev = "${libdir}/libQtSvg.so"
-FILES_libqttest4 = "${libdir}/libQtTest.so.*"
-FILES_libqttest4-dev = "${libdir}/libQtTest.so"
-FILES_libqtxml4 = "${libdir}/libQtXml.so.*"
-FILES_libqtxml4-dev = "${libdir}/libQtXml.so"
-FILES_libqtdesigner4 = "${libdir}/libQtDesigner.so.*"
-FILES_libqtdesigner4-dev = "${libdir}/libQtDesigner.so"
-FILES_libqtdesignercomponents4 = "${libdir}/libQtDesignerComponents.so.*"
-FILES_libqtdesignercomponents4-dev = "${libdir}/libQtDesignerComponents.so"
-FILES_libqt3support4 = "${libdir}/libQt3Support.so.*"
-FILES_libqt3support4-dev = "${libdir}/libQt3Support.so"
-FILES_libqtassistantclient4 = "${libdir}/libQtAssistantClient.so.*"
-FILES_libqtassistantclient4-dev = "${libdir}/libQtAssistantClient.so"
-FILES_libqtscript4 = "${libdir}/libQtScript.so.*"
-FILES_libqtscript4-dev = "${libdir}/libQtScript.so"
-FILES_libqtdbus4 = "${libdir}/libQtDBus.so.*"
-FILES_libqtdbus4-dev = "${libdir}/libQtDBus.so"
-
-FILES_qt4-plugins-accessible = "${libdir}/plugins/accessible/*.so"
-FILES_qt4-plugins-codecs = "${libdir}/plugins/codecs/*.so"
-FILES_qt4-plugins-designer = "${libdir}/plugins/designer/*.so"
-FILES_qt4-plugins-imageformats = "${libdir}/plugins/imageformats/*.so"
-FILES_qt4-plugins-sqldrivers = "${libdir}/plugins/sqldrivers/*.so"
-FILES_qt4-plugins-inputmethods = "${libdir}/plugins/inputmethods/*.so"
-FILES_qt4-plugins-iconengines = "${libdir}/plugins/iconengines/*.so"
-
-FILES_qt4-assistant = "${bindir}/*assistant*"
-FILES_qt4-designer = "${bindir}/*designer*"
-FILES_qt4-linguist = "${bindir}/*linguist* ${bindir}/lrelease ${bindir}/lupdate ${bindir}/qm2ts"
-FILES_qt4-pixeltool = "${bindir}/pixeltool"
-FILES_qt4-dbus = "${bindir}/qdbus ${bindir}/qdbusxml2cpp ${bindir}/qdbuscpp2xml ${bindir}/qdbusviewer"
-
-FILES_qt4-common = "${bindir}/qtconfig"
-FILES_qt4-examples = "${bindir}/qt4-examples/*"
-FILES_qt4-demos = "${bindir}/qtdemo ${bindir}/qt4-demos/*"
-
-FILES_${PN}-dev += "${bindir}/rcc ${bindir}/uic* ${bindir}/moc ${bindir}/qmake ${bindir}/syncqt \
- ${bindir}/qt3to4 ${bindir}/findtr"
-FILES_${PN}-dbg += "${bindir}/*/.debug ${plugindir}/.debug"
+QT_BASE_NAME = "qt4"
+QT_BASE_LIB = "libqt"
+QT_LIBRARY_NAME = "libQt"
+require qt_packaging.inc
diff --git a/packages/qt4/qt_packaging.inc b/packages/qt4/qt_packaging.inc
new file mode 100644
index 0000000000..01942866c7
--- /dev/null
+++ b/packages/qt4/qt_packaging.inc
@@ -0,0 +1,114 @@
+NONDEV_PACKAGES = "${QT_BASE_LIB}core4 ${QT_BASE_LIB}gui4 ${QT_BASE_LIB}network4 \
+ ${QT_BASE_LIB}sql4 ${QT_BASE_LIB}svg4 ${QT_BASE_LIB}test4 ${QT_BASE_LIB}xml4 \
+ ${QT_BASE_LIB}designer4 ${QT_BASE_LIB}designercomponents4 \
+ ${QT_BASE_LIB}3support4 ${QT_BASE_LIB}assistantclient4 ${QT_BASE_LIB}script4 \
+ ${QT_BASE_LIB}dbus4 \
+ ${QT_BASE_NAME}-assistant ${QT_BASE_NAME}-common \
+ ${QT_BASE_NAME}-designer \
+ ${QT_BASE_NAME}-demos ${QT_BASE_NAME}-examples \
+ ${QT_BASE_NAME}-linguist \
+ ${QT_BASE_NAME}-pixeltool ${QT_BASE_NAME}-dbus \
+ ${QT_BASE_NAME}-plugins-accessible \
+ ${QT_BASE_NAME}-plugins-codecs \
+ ${QT_BASE_NAME}-plugins-designer \
+ ${QT_BASE_NAME}-plugins-imageformats \
+ ${QT_BASE_NAME}-plugins-sqldrivers \
+ ${QT_BASE_NAME}-plugins-inputmethods \
+ ${QT_BASE_NAME}-plugins-iconengines \
+ ${QT_BASE_NAME}-fonts "
+
+DEV_PACKAGES += "${QT_BASE_LIB}core4-dev ${QT_BASE_LIB}core4-dbg \
+ ${QT_BASE_LIB}gui4-dev ${QT_BASE_LIB}gui4-dbg \
+ ${QT_BASE_LIB}network4-dev ${QT_BASE_LIB}network4-dbg \
+ ${QT_BASE_LIB}sql4-dev ${QT_BASE_LIB}sql4-dbg \
+ ${QT_BASE_LIB}svg4-dev ${QT_BASE_LIB}svg4-dbg \
+ ${QT_BASE_LIB}test4-dev ${QT_BASE_LIB}test4-dbg \
+ ${QT_BASE_LIB}xml4-dev ${QT_BASE_LIB}xml4-dbg \
+ ${QT_BASE_LIB}designer4-dev ${QT_BASE_LIB}designer4-dbg \
+ ${QT_BASE_LIB}designercomponents4-dev ${QT_BASE_LIB}designercomponents4-dbg \
+ ${QT_BASE_LIB}3support4-dev ${QT_BASE_LIB}3support4-dbg \
+ ${QT_BASE_LIB}assistantclient4-dev ${QT_BASE_LIB}assistantclient4-dbg \
+ ${QT_BASE_LIB}script4-dev ${QT_BASE_LIB}script4-dbg \
+ ${QT_BASE_LIB}dbus4-dev ${QT_BASE_LIB}dbus4-dbg "
+
+PACKAGES += "${DEV_PACKAGES} ${NONDEV_PACKAGES}"
+
+ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY_${PN}-dev = "1"
+FILES_${PN} = ""
+FILES_${PN}-dev = ""
+RDEPENDS_${PN} = "${NONDEV_PACKAGES}"
+RDEPENDS_${PN}-dev = "${DEV_PACKAGES}"
+
+
+FILES_${QT_BASE_LIB}core4 = "${libdir}/${QT_LIBRARY_NAME}Core.so.*"
+FILES_${QT_BASE_LIB}core4-dev = "${libdir}/${QT_LIBRARY_NAME}Core.so"
+FILES_${QT_BASE_LIB}core4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Core*"
+FILES_${QT_BASE_LIB}gui4 = "${libdir}/${QT_LIBRARY_NAME}Gui.so.*"
+FILES_${QT_BASE_LIB}gui4-dev = "${libdir}/${QT_LIBRARY_NAME}Gui.so"
+FILES_${QT_BASE_LIB}gui4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Gui*"
+FILES_${QT_BASE_LIB}network4 = "${libdir}/${QT_LIBRARY_NAME}Network.so.*"
+FILES_${QT_BASE_LIB}network4-dev = "${libdir}/${QT_LIBRARY_NAME}Network.so"
+FILES_${QT_BASE_LIB}network4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Network*"
+FILES_${QT_BASE_LIB}sql4 = "${libdir}/${QT_LIBRARY_NAME}Sql.so.*"
+FILES_${QT_BASE_LIB}sql4-dev = "${libdir}/${QT_LIBRARY_NAME}Sql.so"
+FILES_${QT_BASE_LIB}sql4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Sql*"
+FILES_${QT_BASE_LIB}svg4 = "${libdir}/${QT_LIBRARY_NAME}Svg.so.*"
+FILES_${QT_BASE_LIB}svg4-dev = "${libdir}/${QT_LIBRARY_NAME}Svg.so"
+FILES_${QT_BASE_LIB}svg4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Svg*"
+FILES_${QT_BASE_LIB}test4 = "${libdir}/${QT_LIBRARY_NAME}Test.so.*"
+FILES_${QT_BASE_LIB}test4-dev = "${libdir}/${QT_LIBRARY_NAME}Test.so"
+FILES_${QT_BASE_LIB}test4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Test"
+FILES_${QT_BASE_LIB}xml4 = "${libdir}/${QT_LIBRARY_NAME}Xml.so.*"
+FILES_${QT_BASE_LIB}xml4-dev = "${libdir}/${QT_LIBRARY_NAME}Xml.so"
+FILES_${QT_BASE_LIB}xml4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Xml*"
+FILES_${QT_BASE_LIB}designer4 = "${libdir}/${QT_LIBRARY_NAME}Designer.so.*"
+FILES_${QT_BASE_LIB}designer4-dev = "${libdir}/${QT_LIBRARY_NAME}Designer.so"
+FILES_${QT_BASE_LIB}designer4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Designer*"
+FILES_${QT_BASE_LIB}designercomponents4 = "${libdir}/${QT_LIBRARY_NAME}DesignerComponents.so.*"
+FILES_${QT_BASE_LIB}designercomponents4-dev = "${libdir}/${QT_LIBRARY_NAME}DesignerComponents.so"
+FILES_${QT_BASE_LIB}designercomponents4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}DesignerComponents*"
+FILES_${QT_BASE_LIB}3support4 = "${libdir}/${QT_LIBRARY_NAME}3Support.so.*"
+FILES_${QT_BASE_LIB}3support4-dev = "${libdir}/${QT_LIBRARY_NAME}3Support.so"
+FILES_${QT_BASE_LIB}3support4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}3Support*"
+FILES_${QT_BASE_LIB}assistantclient4 = "${libdir}/${QT_LIBRARY_NAME}AssistantClient.so.*"
+FILES_${QT_BASE_LIB}assistantclient4-dev = "${libdir}/${QT_LIBRARY_NAME}AssistantClient.so"
+FILES_${QT_BASE_LIB}assistantclient4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}AssistantClient*"
+FILES_${QT_BASE_LIB}script4 = "${libdir}/${QT_LIBRARY_NAME}Script.so.*"
+FILES_${QT_BASE_LIB}script4-dev = "${libdir}/${QT_LIBRARY_NAME}Script.so"
+FILES_${QT_BASE_LIB}script4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}Script*"
+FILES_${QT_BASE_LIB}dbus4 = "${libdir}/${QT_LIBRARY_NAME}DBus.so.*"
+FILES_${QT_BASE_LIB}dbus4-dev = "${libdir}/${QT_LIBRARY_NAME}DBus.so"
+FILES_${QT_BASE_LIB}dbus4-dbg = "${libdir}/.debug/${QT_LIBRARY_NAME}DBus*"
+
+FILES_${QT_BASE_NAME}-plugins-accessible = "${libdir}/plugins/accessible/*.so"
+FILES_${QT_BASE_NAME}-plugins-codecs = "${libdir}/plugins/codecs/*.so"
+FILES_${QT_BASE_NAME}-plugins-designer = "${libdir}/plugins/designer/*.so"
+FILES_${QT_BASE_NAME}-plugins-imageformats = "${libdir}/plugins/imageformats/*.so"
+FILES_${QT_BASE_NAME}-plugins-sqldrivers = "${libdir}/plugins/sqldrivers/*.so"
+FILES_${QT_BASE_NAME}-plugins-inputmethods = "${libdir}/plugins/inputmethods/*.so"
+FILES_${QT_BASE_NAME}-plugins-iconengines = "${libdir}/plugins/iconengines/*.so"
+
+FILES_${QT_BASE_NAME}-plugins += "${datadir}/qtopia/plugins/*/*.so"
+FILES_${QT_BASE_NAME}-plugins-dbg += "${datadir}/qtopia/plugins/*/.debug/*.so"
+
+FILES_${QT_BASE_NAME}-assistant = "${bindir}/*assistant*"
+FILES_${QT_BASE_NAME}-designer = "${bindir}/*designer*"
+FILES_${QT_BASE_NAME}-linguist = "${bindir}/*linguist* ${bindir}/lrelease ${bindir}/lupdate ${bindir}/qm2ts"
+FILES_${QT_BASE_NAME}-pixeltool = "${bindir}/pixeltool"
+FILES_${QT_BASE_NAME}-dbus = "${bindir}/qdbus ${bindir}/qdbusxml2cpp ${bindir}/qdbuscpp2xml ${bindir}/qdbusviewer"
+
+FILES_${QT_BASE_NAME}-common = "${bindir}/qtconfig"
+FILES_${QT_BASE_NAME}-examples = "${bindir}/${QT_BASE_NAME}-examples/*"
+FILES_${QT_BASE_NAME}-demos = "${bindir}/qtdemo ${bindir}/${QT_BASE_NAME}-demos/*"
+
+FILES_${QT_BASE_NAME}-fonts = "${libdir}/fonts"
+
+FILES_${PN}-dev += "${bindir}/rcc ${bindir}/uic* ${bindir}/moc ${bindir}/qmake ${bindir}/syncqt \
+ ${bindir}/qt3to4 ${bindir}/findtr"
+FILES_${PN}-dbg += "${bindir}/*/.debug ${plugindir}/.debug"
+
+python populate_packages_prepend() {
+ translationdir = bb.data.expand('${datadir}/qtopia/translations/', d)
+ do_split_packages(d, translationdir, '^qt_(.*)\.qm$', 'qtopia-translation-%s', 'Qtopia translation for %s', extra_depends='' )
+}
diff --git a/packages/qt4/qtopia-core_4.3.3.bb b/packages/qt4/qtopia-core_4.3.3.bb
index 0e94145df0..3e66d9f1b0 100644
--- a/packages/qt4/qtopia-core_4.3.3.bb
+++ b/packages/qt4/qtopia-core_4.3.3.bb
@@ -128,78 +128,6 @@ do_install() {
touch ${D}/${libdir}/fonts/fontdir
}
-# We might want to package all the libraries separately, so you can really
-# fine-tune what to install. This is e.g. done in qt4-x11-free_4.1.2.bb.
-# What should these packages be called? I'm tempted to call them the same
-# as in qt4 version, as the API is supposed to be compatible, e.g.
-# libqtcore4 and libqtgui4. This will however conflict if you have QT and
-# Qtopia, but this is something you don't want anyway, I guess.
-# Another solution is making virtual/libqtfoo4, and DEPENDing on that one
-# and let both the PACKAGES in QT and Qtopia PROVIDE these. The packages
-# themselves could then be called libqtopiafoo4.
-# I'll postpone this discussion by not making separate Qtopia packages.
-
-# Also, I don't package the plugins and translations atm, I don't use them
-# and I don't feel like thinking about a sensible separation.
-
-PACKAGES =+ " libqtcore libqtcore-dev libqtcore-dbg \
- libqtxml libqtxml-dev libqtxml-dbg \
- libqtgui libqtgui-dev libqtgui-dbg \
- libqtsql libqtsql-dev libqtsql-dbg \
- libqtnetwork libqtnetwork-dev libqtnetwork-dbg \
- libqtsvg libqtsvg-dev libqtsvg-dbg \
- libqt3support libqt3support-dev libqt3support-dbg \
- qtopia-core-plugins qtopia-core-plugins-dbg \
- libqtscript libqtscript-dev libqtscript-dbg \
- "
-
-PACKAGES += " ${PN}-fonts "
-
-# The default included fonts are around 75MB and consist of a number of
-# FreeType-renderable fonts as well as QPF (Qtopia Prerendered Fonts).
-# As FreeType is generally slow on embedded platforms, and 75MB is
-# quite huge, we downsize the fonts dir in the do_install. I've decided
-# to include only the QPF (Helvetica and Fixed), amounting to 500KB. This
-# also results in tremendously faster application startup time.
-FILES_libqtcore += " ${libdir}/fonts/helvetic* ${libdir}/fonts/fixed* ${D}/${libdir}/fonts/fontdir"
-FILES_${PN}-fonts = "${libdir}/fonts"
-
-FILES_qtopia-core-plugins += "${datadir}/qtopia/plugins/*/*.so"
-FILES_qtopia-core-plugins-dbg += "${datadir}/qtopia/plugins/*/.debug/*.so"
-
-FILES_libqtcore += "${libdir}/libQtCore.so.*"
-FILES_libqtxml += "${libdir}/libQtXml.so.*"
-FILES_libqtgui += "${libdir}/libQtGui.so.*"
-FILES_libqtsql += "${libdir}/libQtSql.so.*"
-FILES_libqtnetwork += "${libdir}/libQtNetwork.so.*"
-FILES_libqtsvg += "${libdir}/libQtSvg.so.*"
-FILES_libqt3support += "${libdir}/libQt3Support.so.*"
-FILES_libqtscript += "${libdir}/libQtScript.so.*"
-
-FILES_libqtcore-dev += "${libdir}/*QtCore.*"
-FILES_libqtxml-dev += "${libdir}/*QtXml.*"
-FILES_libqtgui-dev += "${libdir}/*QtGui.*"
-FILES_libqtsql-dev += "${libdir}/*QtSql.*"
-FILES_libqtnetwork-dev += "${libdir}/*QtNetwork.*"
-FILES_libqtsvg-dev += "${libdir}/*QtSvg.*"
-FILES_libqt3support-dev += "${libdir}/*Qt3Support.*"
-FILES_libqtscript-dev += "${libdir}/*QtScript.*"
-
-FILES_libqtcore-dbg += "${libdir}/.debug/libQtCore*"
-FILES_libqtxml-dbg += "${libdir}/.debug/libQtXml*"
-FILES_libqtgui-dbg += "${libdir}/.debug/libQtGui*"
-FILES_libqtsql-dbg += "${libdir}/.debug/libQtSql*"
-FILES_libqtnetwork-dbg += "${libdir}/.debug/libQtNetwork*"
-FILES_libqtsvg-dbg += "${libdir}/.debug/libQtSvg*"
-FILES_libqt3support-dbg += "${libdir}/.debug/libQt3Support*"
-FILES_libqtscript-dbg += "${libdir}/.debug/libQtScript*"
-
-
-python populate_packages_prepend() {
- translationdir = bb.data.expand('${datadir}/qtopia/translations/', d)
- do_split_packages(d, translationdir, '^qt_(.*)\.qm$', 'qtopia-translation-%s', 'Qtopia translation for %s', extra_depends='' )
-}
-
STAGE_TEMP = "${WORKDIR}/temp-staging"
@@ -220,3 +148,8 @@ do_stage() {
rm -rf ${STAGE_TEMP}
}
+
+QT_BASE_NAME = "qtopiacore"
+QT_BASE_LIB = "libqtopiacore"
+QT_LIBRARY_NAME = "libQt"
+require qt_packaging.inc