summaryrefslogtreecommitdiff
path: root/packages/qpf-fonts
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/qpf-fonts
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/qpf-fonts')
-rwxr-xr-xpackages/qpf-fonts/files/update-qtfontdir74
-rw-r--r--packages/qpf-fonts/qpf-arabic_1.0.bb9
-rw-r--r--packages/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb36
-rw-r--r--packages/qpf-fonts/qpf-bitstream-vera_1.10.bb24
-rw-r--r--packages/qpf-fonts/qpf-font-common_1.0.bb14
-rw-r--r--packages/qpf-fonts/qpf-freemono_1.0.bb10
-rw-r--r--packages/qpf-fonts/qpf-freeserif_1.0.bb10
-rw-r--r--packages/qpf-fonts/qpf-helvetica_1.0.bb9
-rw-r--r--packages/qpf-fonts/qpf-hunkysans_0.3.0.bb10
-rw-r--r--packages/qpf-fonts/qpf-hunkyserif_0.3.0.bb10
-rw-r--r--packages/qpf-fonts/qpf-qte_2.3.10.bb35
-rw-r--r--packages/qpf-fonts/qpf-qte_3.3.5.bb57
-rw-r--r--packages/qpf-fonts/qpf-terminus.bb10
-rw-r--r--packages/qpf-fonts/qpf-unifont_1.0.bb9
-rw-r--r--packages/qpf-fonts/qpf-unismall_1.0.0.bb11
-rw-r--r--packages/qpf-fonts/qpf-utopia_1.0.bb9
-rw-r--r--packages/qpf-fonts/qpf.inc32
17 files changed, 0 insertions, 369 deletions
diff --git a/packages/qpf-fonts/files/update-qtfontdir b/packages/qpf-fonts/files/update-qtfontdir
deleted file mode 100755
index 34f2ffd825..0000000000
--- a/packages/qpf-fonts/files/update-qtfontdir
+++ /dev/null
@@ -1,74 +0,0 @@
-#!/bin/sh
-
-usage()
-{
- echo "usage: $0 [font directory, defaults to \$QTDIR/lib/fonts]"
- exit 1
-}
-
-setVar()
-{
- eval "$1='$2'"
-}
-
-getVar()
-{
- eval "echo \$$1"
-}
-
-handleQPF()
-{
- base=`basename $1`
- family=`echo $base|cut -d_ -f1`
- pt=`echo $base|cut -d_ -f2`
- weight=`echo $base|cut -d_ -f3|sed -e 's,i$,,'`
- if (echo $base|cut -d_ -f3|grep -q 'i$'); then
- italic="y"
- else
- italic="n"
- fi
- echo "$family $base.qpf QPF $italic $weight $pt u"
-}
-
-if [ "$1" = "-f" ]; then
- FORCE=1
- shift
-else
- FORCE=0
-fi
-
-if [ -z "$1" ]; then
- if [ -n "$QTDIR" ]; then
- fontdir=$QTDIR/lib/fonts
- else
- fontdir=@palmtopdir@/lib/fonts
- fi
-else
- fontdir=$1
-fi
-
-if ! [ -d $fontdir ]; then
- echo Error: $fontdir not a directory
- exit 1
-fi
-
-if [ -e $fontdir/fontdir ]; then
- if find $fontdir -newer $fontdir/fontdir | grep -q "\(qpf\|ttf\)"; then
- #echo "fontdir needs updating..."
- :
- elif [ "$FORCE" = "0" ]; then
- #echo "fontdir already up to date - exiting"
- exit 0
- fi
- cat $fontdir/fontdir | grep -v '\.qpf' > $fontdir/fontdir.new
-fi
-
-(
- for file in `ls $fontdir/*.qpf 2>/dev/null |sed -e's,\.qpf$,,; s,_t[^_]*$,,;'|sort -u`; do
- handleQPF $file
- done
-) >> $fontdir/fontdir.new
-
-mv $fontdir/fontdir.new $fontdir/fontdir
-
-exit 0
diff --git a/packages/qpf-fonts/qpf-arabic_1.0.bb b/packages/qpf-fonts/qpf-arabic_1.0.bb
deleted file mode 100644
index d2ef3af639..0000000000
--- a/packages/qpf-fonts/qpf-arabic_1.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Arabic fonts from Arabeyes.org"
-HOMEPAGE = "http://www.arabeyes.org"
-LICENSE = "GPL"
-PR = "r1"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/arabeyes/arabic-fonts-${PV}.tar.gz"
-S = "${WORKDIR}"
diff --git a/packages/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb b/packages/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb
deleted file mode 100644
index 98c9016ee4..0000000000
--- a/packages/qpf-fonts/qpf-bitstream-vera-sans-mono_1.10.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Bitstream Vera Monospaced Font, QPF for Qt/Embedded"
-LICENSE = "Bitstream Vera"
-PR = "r4"
-
-PROVIDES += "qpf-bitstream-vera-sans-mono-small"
-PROVIDES += "qpf-bitstream-vera-sans-mono-larger"
-PROVIDES += "qpf-bitstream-vera-sans-mono-large"
-PROVIDES += "qpf-bitstream-vera-sans-mono-huge"
-
-SRC_URI = "http://openzaurus.org/mirror/fonts-bitstream-vera-sans-mono.tar.gz"
-S = "${WORKDIR}/verasansmono"
-
-FILES_${PN} += "${palmtopdir}"
-
-PACKAGES = "${PN}-dbg \
-qpf-bitstream-vera-sans-mono-small \
-qpf-bitstream-vera-sans-mono-large \
-qpf-bitstream-vera-sans-mono-larger \
-qpf-bitstream-vera-sans-mono-huge ${PN}"
-
-FILES_qpf-bitstream-vera-sans-mono-small = "\
-${palmqtdir}/lib/fonts/verasansmono_10* \
- ${palmqtdir}/lib/fonts/verasansmono_11* \
- ${palmqtdir}/lib/fonts/verasansmono_12* \
- ${palmqtdir}/lib/fonts/verasansmono_13* \
- ${palmqtdir}/lib/fonts/verasansmono_14*"
-FILES_qpf-bitstream-vera-sans-mono-large = "\
- ${palmqtdir}/lib/fonts/verasansmono_15*" \
- ${palmqtdir}/lib/fonts/verasansmono_16* \
- ${palmqtdir}/lib/fonts/verasansmono_17* \
- ${palmqtdir}/lib/fonts/verasansmono_18* \
- ${palmqtdir}/lib/fonts/verasansmono_19*"
-FILES_qpf-bitstream-vera-sans-mono-larger = "${palmqtdir}/lib/fonts/verasansmono_2*"
-FILES_qpf-bitstream-vera-sans-mono-huge = "${palmqtdir}/lib/fonts/verasansmono_3*"
diff --git a/packages/qpf-fonts/qpf-bitstream-vera_1.10.bb b/packages/qpf-fonts/qpf-bitstream-vera_1.10.bb
deleted file mode 100644
index fc05ad99f6..0000000000
--- a/packages/qpf-fonts/qpf-bitstream-vera_1.10.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "The Bitstream Vera fonts - QPF Edition"
-LICENSE = "Bitstream Vera"
-PR = "r3"
-
-PROVIDES = "qpf-bitstream-vera-small qpf-bitstream-vera-large"
-
-SRC_URI = "http://openzaurus.org/mirror/vera-qpf_1.10-3.tar.gz"
-S = "${WORKDIR}/vera-qpf"
-
-PACKAGES = "${PN}-dbg qpf-bitstream-vera-small qpf-bitstream-vera-large ${PN}"
-
-FILES_qpf-bitstream-vera-small = "${palmqtdir}/lib/fonts/vera_80_50* \
-${palmqtdir}/lib/fonts/vera_80_50i* ${palmqtdir}/lib/fonts/vera_80_75* ${palmqtdir}/lib/fonts/vera_80_75i* \
-${palmqtdir}/lib/fonts/vera_100_50* ${palmqtdir}/lib/fonts/vera_100_50i* ${palmqtdir}/lib/fonts/vera_100_75* \
-${palmqtdir}/lib/fonts/vera_100_75i* ${palmqtdir}/lib/fonts/vera_120_50* ${palmqtdir}/lib/fonts/vera_120_50i* \
-${palmqtdir}/lib/fonts/vera_120_75* ${palmqtdir}/lib/fonts/vera_120_75i*"
-
-FILES_qpf-bitstream-vera-large = "${palmqtdir}/lib/fonts/vera_140_50* ${palmqtdir}/lib/fonts/vera_140_50i* \
-${palmqtdir}/lib/fonts/vera_140_75* \
-${palmqtdir}/lib/fonts/vera_140_75i* ${palmqtdir}/lib/fonts/vera_160_50* ${palmqtdir}/lib/fonts/vera_160_50i* \
-${palmqtdir}/lib/fonts/vera_160_75* ${palmqtdir}/lib/fonts/vera_160_75i* ${palmqtdir}/lib/fonts/vera_180_50* \
-${palmqtdir}/lib/fonts/vera_180_50i* ${palmqtdir}/lib/fonts/vera_180_75* ${palmqtdir}/lib/fonts/vera_180_75i*"
diff --git a/packages/qpf-fonts/qpf-font-common_1.0.bb b/packages/qpf-fonts/qpf-font-common_1.0.bb
deleted file mode 100644
index ba4f0867ad..0000000000
--- a/packages/qpf-fonts/qpf-font-common_1.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-DESCRIPTION = "Common files for Qt/Embedded fonts"
-LICENSE = "GPL QPL"
-PR = "r4"
-
-SRC_URI = "file://update-qtfontdir"
-S = "${WORKDIR}/qt-${PV}"
-
-do_install() {
- install -d ${D}${sbindir}/
- install -m 0755 ${WORKDIR}/update-qtfontdir ${D}${sbindir}/
- sed -i -e 's,@palmtopdir@,${palmtopdir},g' ${D}${sbindir}/update-qtfontdir
-}
-
-PACKAGE_ARCH = "all"
diff --git a/packages/qpf-fonts/qpf-freemono_1.0.bb b/packages/qpf-fonts/qpf-freemono_1.0.bb
deleted file mode 100644
index a4c73f2b7f..0000000000
--- a/packages/qpf-fonts/qpf-freemono_1.0.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "FreeMono font - QPF Edition"
-HOMEPAGE = "http://savannah.nongnu.org/projects/freefont/"
-LICENSE = "GPL"
-PR = "r1"
-
-SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/hrw-oe-sources/${PN}-${PV}.tar.bz2"
-
-S = "${WORKDIR}/${PN}"
diff --git a/packages/qpf-fonts/qpf-freeserif_1.0.bb b/packages/qpf-fonts/qpf-freeserif_1.0.bb
deleted file mode 100644
index a45abbdcd3..0000000000
--- a/packages/qpf-fonts/qpf-freeserif_1.0.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "FreeSerif font - QPF Edition"
-HOMEPAGE = "http://savannah.nongnu.org/projects/freefont/"
-LICENSE = "GPL"
-PR = "r3"
-
-SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/hrw-oe-sources/${PN}-${PV}.tar.bz2"
-
-S = "${WORKDIR}/${PN}"
diff --git a/packages/qpf-fonts/qpf-helvetica_1.0.bb b/packages/qpf-fonts/qpf-helvetica_1.0.bb
deleted file mode 100644
index 1d2c672bcb..0000000000
--- a/packages/qpf-fonts/qpf-helvetica_1.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Helvetica fonts - QPF Edition"
-HOMEPAGE = "http://www.pobox.sk/~mico/zaurus.html"
-LICENSE = "GPL QPL"
-PR = "r2"
-
-SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/hrw-oe-sources/qpf-helvetica.tar.bz2"
-S = "${WORKDIR}/helvetica"
diff --git a/packages/qpf-fonts/qpf-hunkysans_0.3.0.bb b/packages/qpf-fonts/qpf-hunkysans_0.3.0.bb
deleted file mode 100644
index 6f9db1202c..0000000000
--- a/packages/qpf-fonts/qpf-hunkysans_0.3.0.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Hunky Sans font - QPF Edition"
-HOMEPAGE = "http://www.yoper.com/ariszlo/hunky.html http://sourceforge.net/projects/hunkyfonts"
-LICENSE = "LGPL"
-PR = "r6"
-
-SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/hrw-oe-sources/${PN}-${PV}-r4.tar.bz2"
-
-S = "${WORKDIR}/${PN}"
diff --git a/packages/qpf-fonts/qpf-hunkyserif_0.3.0.bb b/packages/qpf-fonts/qpf-hunkyserif_0.3.0.bb
deleted file mode 100644
index f06599f9eb..0000000000
--- a/packages/qpf-fonts/qpf-hunkyserif_0.3.0.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Hunky Serif font - QPF Edition"
-HOMEPAGE = "http://www.yoper.com/ariszlo/hunky.html http://sourceforge.net/projects/hunkyfonts"
-LICENSE = "LGPL"
-PR = "r6"
-
-SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/hrw-oe-sources/${PN}-${PV}-r4.tar.bz2"
-
-S = "${WORKDIR}/${PN}"
diff --git a/packages/qpf-fonts/qpf-qte_2.3.10.bb b/packages/qpf-fonts/qpf-qte_2.3.10.bb
deleted file mode 100644
index a1a589f003..0000000000
--- a/packages/qpf-fonts/qpf-qte_2.3.10.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Qt/Embedded fonts version ${PV}"
-HOMEPAGE = "http://www.trolltech.com"
-LICENSE = "GPL QPL"
-PR = "r2"
-
-PROVIDES = "qte-font-helvetica-100 qte-font-helvetica-120"
-PROVIDES += "qte-font-fixed-70 qte-font-fixed-120"
-PROVIDES += "qte-font-helvetica-80 qte-font-helvetica-140 qte-font-helvetica-180 qte-font-helvetica-240"
-PROVIDES += "qte-font-smallsmooth-90"
-PROVIDES += "qte-font-micro-40"
-PROVIDES += "qte-font-japanese-230"
-PROVIDES += "qte-font-smoothmono-90 qte-font-smoothmono-100 qte-font-smoothmono-110 qte-font-smoothmono-120"
-PROVIDES += "qte-font-smoothmono-140 qte-font-smoothmono-180 qte-font-smoothmono-240"
-PROVIDES += "qte-font-smoothsans-90 qte-font-smoothsans-100 qte-font-smoothsans-110 qte-font-smoothsans-120"
-PROVIDES += "qte-font-smoothsans-140 qte-font-smoothsans-180 qte-font-smoothsans-240"
-PROVIDES += "qte-font-smoothserif-90 qte-font-smoothserif-100 qte-font-smoothserif-110 qte-font-smoothserif-120"
-PROVIDES += "qte-font-smoothserif-140 qte-font-smoothserif-180 qte-font-smoothserif-240"
-PROVIDES += "qte-font-smoothtimes-100 qte-font-smoothtimes-160 qte-font-smoothtimes-170"
-PROVIDES += "qte-font-smoothtimes-220 qte-font-smoothtimes-250 qte-font-smoothtimes-440"
-PROVIDES += "qte-font-unifont"
-RPROVIDES_qte-font-unifont += "virtual/japanese-font"
-RPROVIDES_qte-font-japanese += "virtual/japanese-font"
-
-SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz"
-S = "${WORKDIR}/qt-${PV}"
-
-QPF_PKGPATTERN = "qte-font-%s"
-QPF_DESCRIPTION = "Qt/E font %s"
-
-do_install() {
- install -d ${D}${palmqtdir}/lib/fonts/
- cp -pPR lib/fonts/* ${D}${palmqtdir}/lib/fonts/
-}
diff --git a/packages/qpf-fonts/qpf-qte_3.3.5.bb b/packages/qpf-fonts/qpf-qte_3.3.5.bb
deleted file mode 100644
index 6ac091f29d..0000000000
--- a/packages/qpf-fonts/qpf-qte_3.3.5.bb
+++ /dev/null
@@ -1,57 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Qt/Embedded fonts version ${PV}"
-HOMEPAGE = "http://www.trolltech.com"
-LICENSE = "GPL QPL"
-PR = "r6"
-
-SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.bz2"
-S = "${WORKDIR}/qt-embedded-free-${PV}"
-
-do_compile() {
- :
-}
-
-do_install() {
- mkdir -p ${D}${sbindir}
- mkdir -p ${D}${palmtopdir}/lib/fonts
- cp -pPR lib/fonts/* ${D}${palmtopdir}/lib/fonts
- # Delete all other font formats, Qt/E would have a dead slow
- # application start time if it had to use any other font format
- # as *.qpf ...
- find ${D}${palmtopdir}/lib/fonts \
- -name "*.bdf" \
- -o -name "*.ttf" \
- -o -name "*.pfa" \
- -o -name "*.pfb" | xargs rm
-}
-
-PACKAGES = "qte-font-fixed"
-PROVIDES += "qte-font-fixed"
-FILES_qte-font-fixed = "${palmtopdir}/lib/fonts/fixed*"
-
-PACKAGES += "qte-font-helvetica-small"
-PROVIDES += "qte-font-helvetica-small"
-FILES_qte-font-helvetica-small = "${palmtopdir}/lib/fonts/helvetica_80*.qpf \
- ${palmtopdir}/lib/fonts/helvetica_100*.qpf ${palmtopdir}/lib/fonts/helvetica_120*.qpf"
-
-PACKAGES += "qte-font-helvetica-large"
-PROVIDES += "qte-font-helvetica-large"
-FILES_qte-font-helvetica-large = "${palmtopdir}/lib/fonts/helvetica_140*.qpf \
- ${palmtopdir}/lib/fonts/helvetica_180*.qpf ${palmtopdir}/lib/fonts/helvetica_240*.qpf"
-
-PACKAGES += "qte-font-smoothtimes"
-PROVIDES += "qte-font-smoothtimes"
-FILES_qte-font-smoothtimes = "${palmtopdir}/lib/fonts/smoothtimes*"
-
-PACKAGES += "qte-font-smallsmooth"
-PROVIDES += "qte-font-smallsmooth"
-FILES_qte-font-smallsmooth = "${palmtopdir}/lib/fonts/smallsmooth*"
-
-PACKAGES += "qte-font-unicode"
-PROVIDES += "qte-font-unicode"
-FILES_qte-font-unicode = "${palmtopdir}/lib/fonts/unifont*.qpf"
-
-PACKAGES += "qte-font-micro"
-PROVIDES += "qte-font-micro"
-FILES_qte-font-micro = "${palmtopdir}/lib/fonts/micro*.qpf"
diff --git a/packages/qpf-fonts/qpf-terminus.bb b/packages/qpf-fonts/qpf-terminus.bb
deleted file mode 100644
index 7e8bbfe393..0000000000
--- a/packages/qpf-fonts/qpf-terminus.bb
+++ /dev/null
@@ -1,10 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Qt/Embedded terminus font"
-HOMEPAGE = "http://www.is-vn.bg/hamster/jimmy-en.html"
-LICENSE = "GPL"
-PR = "r3"
-
-#SRC_URI = "http://www.mn-solutions.de/downloads/mnci/terminus-fonts.tar.bz2" -> 404 error
-SRC_URI = "http://openzaurus.linuxtogo.org/download/3.5.4/sources/terminus-fonts.tar.bz2"
-S = "${WORKDIR}/terminus-fonts"
diff --git a/packages/qpf-fonts/qpf-unifont_1.0.bb b/packages/qpf-fonts/qpf-unifont_1.0.bb
deleted file mode 100644
index e91e762845..0000000000
--- a/packages/qpf-fonts/qpf-unifont_1.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Unicode fonts - QPF Edition"
-LICENSE = "GPL QPL"
-RPROVIDES = "virtual/japanese-font"
-PR = "r2"
-
-SRC_URI = "http://www.openzaurus.org/mirror/qpf-unifont.tar.bz2"
-S = "${WORKDIR}"
diff --git a/packages/qpf-fonts/qpf-unismall_1.0.0.bb b/packages/qpf-fonts/qpf-unismall_1.0.0.bb
deleted file mode 100644
index 6298e2dfc4..0000000000
--- a/packages/qpf-fonts/qpf-unismall_1.0.0.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Lightweight Japanese font in 10 point suitable for 320x240 display"
-HOMEPAGE = "http://sourceforge.jp/projects/zaurus-ja/"
-LICENSE = "GPL"
-RPROVIDES = "virtual/japanese-font"
-PR = "r4"
-
-SRC_URI = "http://osdn.dl.sourceforge.jp/zaurus-ja/773/unismall-${PV}.tar.gz"
-
-S = "${WORKDIR}"
diff --git a/packages/qpf-fonts/qpf-utopia_1.0.bb b/packages/qpf-fonts/qpf-utopia_1.0.bb
deleted file mode 100644
index eaee2d07a4..0000000000
--- a/packages/qpf-fonts/qpf-utopia_1.0.bb
+++ /dev/null
@@ -1,9 +0,0 @@
-require qpf.inc
-
-DESCRIPTION = "Utopia fonts - QPF Edition"
-HOMEPAGE = "http://www.pobox.sk/~mico/zaurus.html"
-LICENSE = "GPL QPL"
-PR = "r2"
-
-SRC_URI = "http://ewi546.ewi.utwente.nl/mirror/hrw-oe-sources/qpf-utopia.tar.bz2"
-S = "${WORKDIR}/utopia"
diff --git a/packages/qpf-fonts/qpf.inc b/packages/qpf-fonts/qpf.inc
deleted file mode 100644
index 97e66587d2..0000000000
--- a/packages/qpf-fonts/qpf.inc
+++ /dev/null
@@ -1,32 +0,0 @@
-RDEPENDS = "font-update-common qpf-font-common"
-
-do_configure() {
- :
-}
-
-do_compile() {
- :
-}
-
-pkg_postinst_fonts() {
- update-fonts
-}
-
-pkg_postrm_fonts() {
- update-fonts
-}
-
-python populate_packages_prepend() {
- postinst = bb.data.getVar('pkg_postinst_fonts', d, 1)
- postrm = bb.data.getVar('pkg_postrm_fonts', d, 1)
- fontdir = bb.data.getVar('palmtopdir', d, 1) + '/lib/fonts'
- pkgregex = "^([a-z-]*_[0-9]*).*.qpf$"
- pkgpattern = bb.data.getVar('QPF_PKGPATTERN', d, 1) or 'qpf-%s'
- pkgdescription = bb.data.getVar('QPF_DESCRIPTION', d, 1) or 'QPF font %s'
-
- do_split_packages(d, root=fontdir, file_regex=pkgregex, output_pattern=pkgpattern,
- description=pkgdescription, postinst=postinst, postrm=postrm, recursive=True, hook=None,
- extra_depends='qpf-font-common')
-}
-
-PACKAGE_ARCH = "all"