summaryrefslogtreecommitdiff
path: root/packages/qpf-fonts/qpf-helvetica_1.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2005-02-15 12:12:20 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2005-02-15 12:12:20 +0000
commit7e28ce87293ab6d14b9164673c70bf4c8f4b89bf (patch)
tree4f304d2eafb5dcc35ecc17c844ba3d5ed0b76a06 /packages/qpf-fonts/qpf-helvetica_1.0.bb
parentc5b77bf7fd2a5d21046f583e567f7665e21d11f0 (diff)
split QPF fonts into one-size packages via "qpf" bbclass
BKrev: 4211e724Lhd2ybrh-IXMaPuPThuqvA
Diffstat (limited to 'packages/qpf-fonts/qpf-helvetica_1.0.bb')
-rw-r--r--packages/qpf-fonts/qpf-helvetica_1.0.bb22
1 files changed, 4 insertions, 18 deletions
diff --git a/packages/qpf-fonts/qpf-helvetica_1.0.bb b/packages/qpf-fonts/qpf-helvetica_1.0.bb
index 9e10bc7dc4..f5f00518c5 100644
--- a/packages/qpf-fonts/qpf-helvetica_1.0.bb
+++ b/packages/qpf-fonts/qpf-helvetica_1.0.bb
@@ -4,30 +4,16 @@ SECTION = "opie/fonts"
PRIORITY = "optional"
MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
HOMEPAGE = "http://www.pobox.sk/~mico/zaurus.html"
-PACKAGE_ARCH = "all"
+PR = "r1"
SRC_URI = "http://www.hrw.one.pl/_pliki/oe/files/qpf-helvetica.tar.bz2"
S = "${WORKDIR}/helvetica"
do_install () {
install -d ${D}${palmqtdir}/lib/fonts/
- for i in *.qpf; do
- install -m 644 $i ${D}${palmqtdir}/lib/fonts/${i}
+ for font in *.qpf; do
+ install -m 644 $font ${D}${palmqtdir}/lib/fonts/
done
}
-pkg_postinst () {
-#!/bin/sh
-if [ -n "$D" ]; then exit 1; fi
-set -e
-. /etc/profile
-${sbindir}/update-qtfontdir
-}
-
-PACKAGES = "qpf-helvetica-small qpf-helvetica-large"
-
-FILES_qpf-helvetica-small = "${palmqtdir}/lib/fonts/helvetica_80* \
-${palmqtdir}/lib/fonts/helvetica_100* ${palmqtdir}/lib/fonts/helvetica_120*"
-
-FILES_qpf-helvetica-large = "${palmqtdir}/lib/fonts/helvetica_140* \
-${palmqtdir}/lib/fonts/helvetica_180* ${palmqtdir}/lib/fonts/helvetica_240*"
+inherit qpf