summaryrefslogtreecommitdiff
path: root/packages/qpe-nmap/qpe-nmap_0.02.bb
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-09-25 10:52:18 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-09-25 10:52:18 +0000
commit2cac5a4b33a16c8ce06ce3593c53022a6b815993 (patch)
tree12c0ee88a9b90335b77de0d166e09f932db93f7d /packages/qpe-nmap/qpe-nmap_0.02.bb
parent559773acb2a0d7cec0e48511a8b29cebe4ba237e (diff)
parent0b81567828ef0d0faf043f08c8bc83ff47746a7c (diff)
merge of '8f2834d1d878c2216e0ae7674e3ab70dcfdef7e1'
and 'eb29a45193648ce5a1e591048cb7ee4555a08217'
Diffstat (limited to 'packages/qpe-nmap/qpe-nmap_0.02.bb')
-rw-r--r--packages/qpe-nmap/qpe-nmap_0.02.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/qpe-nmap/qpe-nmap_0.02.bb b/packages/qpe-nmap/qpe-nmap_0.02.bb
new file mode 100644
index 0000000000..43cd451957
--- /dev/null
+++ b/packages/qpe-nmap/qpe-nmap_0.02.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A frontend for the nmap port scanner, Qt/Embedded Palmtop Environment"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "nmap"
+PR = "r0"
+
+SRC_URI = "http://www.bluelightning.org/qpe-nmap/files/qpe-nmap-${PV}.tar.bz2"
+
+APPNAME = "qpe-nmap"
+APPTYPE = "binary"
+APPDESKTOP = "${WORKDIR}"
+
+S = "${WORKDIR}/qpe-nmap"
+
+inherit opie
+
+do_install () {
+ install -d ${D}${palmtopdir}/pics/${APPNAME}/
+ install -m 0644 ${WORKDIR}/qpe-nmap/ipk/opt/QtPalmtop/pics/qpe-nmap.png ${D}${palmtopdir}/pics/
+ install -d ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${WORKDIR}/qpe-nmap/ipk/opt/QtPalmtop/apps/Applications/qpe-nmap.desktop ${D}${palmtopdir}/apps/Applications/
+}
+