summaryrefslogtreecommitdiff
path: root/packages/qmake/qmake2-native/use-lflags-last.patch
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-12-23 00:39:08 +0000
committerHolger Freyther <zecke@selfish.org>2007-12-23 00:39:08 +0000
commit2068d289bb9a9d0c2823a110d7751ba9e72e6542 (patch)
tree1b6b3ba2d36e15f57b66aa8e3e95c8244832162d /packages/qmake/qmake2-native/use-lflags-last.patch
parenta4d3737a7b1dd58c2364782f0a78988dccc6aec7 (diff)
packages/qmake/qmake2: Make it more easy to do updates
Create a qmake2-native.inc, get the files from qmake2-native. Recreate qmake2-native_2.10a.bb and require the above file and say which version of QtopiaCore to get.
Diffstat (limited to 'packages/qmake/qmake2-native/use-lflags-last.patch')
-rw-r--r--packages/qmake/qmake2-native/use-lflags-last.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/packages/qmake/qmake2-native/use-lflags-last.patch b/packages/qmake/qmake2-native/use-lflags-last.patch
new file mode 100644
index 0000000000..4197dbbf64
--- /dev/null
+++ b/packages/qmake/qmake2-native/use-lflags-last.patch
@@ -0,0 +1,22 @@
+Index: qtopia-core-opensource-src-4.3.1/qmake/generators/unix/unixmake2.cpp
+===================================================================
+--- qtopia-core-opensource-src-4.3.1.orig/qmake/generators/unix/unixmake2.cpp 2007-10-07 13:45:26.000000000 +0200
++++ qtopia-core-opensource-src-4.3.1/qmake/generators/unix/unixmake2.cpp 2007-10-07 13:57:09.000000000 +0200
+@@ -416,7 +416,7 @@
+ t << "\n\t" << mkdir_p_asstring(destdir) << "\n\t";
+ if(!project->isEmpty("QMAKE_PRE_LINK"))
+ t << var("QMAKE_PRE_LINK") << "\n\t";
+- t << "$(LINK) $(LFLAGS) -o $(TARGET) " << incr_deps << " " << incr_objs << " $(OBJCOMP) $(LIBS)";
++ t << "$(LINK) -o $(TARGET) " << incr_deps << " " << incr_objs << " $(OBJCOMP) $(LIBS) $(LFLAGS)";
+ if(!project->isEmpty("QMAKE_POST_LINK"))
+ t << "\n\t" << var("QMAKE_POST_LINK");
+ t << endl << endl;
+@@ -430,7 +430,7 @@
+ t << mkdir_p_asstring(destdir) << "\n\t";
+ if(!project->isEmpty("QMAKE_PRE_LINK"))
+ t << var("QMAKE_PRE_LINK") << "\n\t";
+- t << "$(LINK) $(LFLAGS) -o $(TARGET) $(OBJECTS) $(OBJCOMP) $(LIBS)";
++ t << "$(LINK) -o $(TARGET) $(OBJECTS) $(OBJCOMP) $(LIBS) $(LFLAGS)";
+ if(!project->isEmpty("QMAKE_POST_LINK"))
+ t << "\n\t" << var("QMAKE_POST_LINK");
+ t << endl << endl;