summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-17 18:07:12 +0000
commit12f8a39939c28003a39b84713d9a51305511650d (patch)
tree2235c3d2a30eac66c0319b7cff55928990c89bbd /packages/python
parent058132b8be45ac2041a574782b8800c1956e44d3 (diff)
parentfcbe107913b10643d1ba8ac137de273e12e8854a (diff)
merge of '470ca3fe64c9411d3a7d992db39d5efbed869839'
and '912f388483a3e1703ca89d7b2309723fd3407420'
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.5.2/default-is-optimized.patch41
-rw-r--r--packages/python/python-evas_cvs.bb4
-rw-r--r--packages/python/python-native-2.5.1/catchup-with-swig.patch13
-rw-r--r--packages/python/python-native_2.5.1.bb20
-rw-r--r--packages/python/python-setuptools-native_0.6c8.bb (renamed from packages/python/python-setuptools-native_0.6c6.bb)0
-rw-r--r--packages/python/python-setuptools_0.6c8.bb (renamed from packages/python/python-setuptools_0.6c6.bb)2
-rw-r--r--packages/python/python_2.5.2.bb2
7 files changed, 66 insertions, 16 deletions
diff --git a/packages/python/python-2.5.2/default-is-optimized.patch b/packages/python/python-2.5.2/default-is-optimized.patch
index 6beeb6e022..072bf0b059 100644
--- a/packages/python/python-2.5.2/default-is-optimized.patch
+++ b/packages/python/python-2.5.2/default-is-optimized.patch
@@ -1,7 +1,7 @@
-Index: Python-2.5.1/Python/compile.c
+Index: Python-2.5.2/Python/compile.c
===================================================================
---- Python-2.5.1.orig/Python/compile.c
-+++ Python-2.5.1/Python/compile.c
+--- Python-2.5.2.orig/Python/compile.c
++++ Python-2.5.2/Python/compile.c
@@ -30,7 +30,7 @@
#include "symtable.h"
#include "opcode.h"
@@ -11,3 +11,38 @@ Index: Python-2.5.1/Python/compile.c
/*
ISSUES:
+Index: Python-2.5.2/Modules/main.c
+===================================================================
+--- Python-2.5.2.orig/Modules/main.c
++++ Python-2.5.2/Modules/main.c
+@@ -40,7 +40,7 @@ static char **orig_argv;
+ static int orig_argc;
+
+ /* command line options */
+-#define BASE_OPTS "c:dEhim:OQ:StuUvVW:xX?"
++#define BASE_OPTS "c:dEhim:ONQ:StuUvVW:xX?"
+
+ #ifndef RISCOS
+ #define PROGRAM_OPTS BASE_OPTS
+@@ -68,8 +68,7 @@ Options and arguments (and corresponding
+ ";
+ static char *usage_2 = "\
+ -m mod : run library module as a script (terminates option list)\n\
+--O : optimize generated bytecode (a tad; also PYTHONOPTIMIZE=x)\n\
+--OO : remove doc-strings in addition to the -O optimizations\n\
++-N : do NOT optimize generated bytecode\n\
+ -Q arg : division options: -Qold (default), -Qwarn, -Qwarnall, -Qnew\n\
+ -S : don't imply 'import site' on initialization\n\
+ -t : issue warnings about inconsistent tab usage (-tt: issue errors)\n\
+@@ -302,7 +301,10 @@ Py_Main(int argc, char **argv)
+ break;
+
+ case 'O':
+- Py_OptimizeFlag++;
++ fprintf(stderr, "-O is already default in this version. Ignoring\n");
++
++ case 'N':
++ Py_OptimizeFlag=0;
+ break;
+
+ case 'S':
diff --git a/packages/python/python-evas_cvs.bb b/packages/python/python-evas_cvs.bb
index 92f4466a24..57e28b28ed 100644
--- a/packages/python/python-evas_cvs.bb
+++ b/packages/python/python-evas_cvs.bb
@@ -3,6 +3,10 @@ DEPENDS += "evas"
PV = "0.2.1+cvs${SRCDATE}"
PR = "r0"
+do_compile_prepend() {
+ touch include/evas/__init__.py
+}
+
do_stage() {
distutils_stage_all
}
diff --git a/packages/python/python-native-2.5.1/catchup-with-swig.patch b/packages/python/python-native-2.5.1/catchup-with-swig.patch
new file mode 100644
index 0000000000..f049b759f4
--- /dev/null
+++ b/packages/python/python-native-2.5.1/catchup-with-swig.patch
@@ -0,0 +1,13 @@
+Index: Python-2.5.1/Lib/distutils/command/build_ext.py
+===================================================================
+--- Python-2.5.1.orig/Lib/distutils/command/build_ext.py
++++ Python-2.5.1/Lib/distutils/command/build_ext.py
+@@ -513,7 +513,7 @@ class build_ext (Command):
+ target_lang=language)
+
+
+- def swig_sources (self, sources, extension):
++ def swig_sources (self, sources, extension=None):
+
+ """Walk the list of source files in 'sources', looking for SWIG
+ interface (.i) files. Run SWIG on all that are found, and
diff --git a/packages/python/python-native_2.5.1.bb b/packages/python/python-native_2.5.1.bb
index ea6e257043..3f58d36a2e 100644
--- a/packages/python/python-native_2.5.1.bb
+++ b/packages/python/python-native_2.5.1.bb
@@ -4,15 +4,18 @@ LICENSE = "PSF"
SECTION = "devel/python"
PRIORITY = "optional"
DEPENDS = ""
-PR = "ml1"
+PR = "ml2"
EXCLUDE_FROM_WORLD = "1"
-SRC_URI = "http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
- file://bindir-libdir.patch;patch=1 \
- file://cross-distutils.patch;patch=1 \
- file://dont-modify-shebang-line.patch;patch=1 \
- file://default-is-optimized.patch;patch=1"
+SRC_URI = "\
+ http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
+ file://bindir-libdir.patch;patch=1 \
+ file://cross-distutils.patch;patch=1 \
+ file://dont-modify-shebang-line.patch;patch=1 \
+ file://default-is-optimized.patch;patch=1 \
+ file://catchup-with-swig.patch;patch=1 \
+"
S = "${WORKDIR}/Python-${PV}"
inherit autotools native
@@ -24,11 +27,6 @@ EXTRA_OECONF = "--with-threads --with-pymalloc --with-cyclic-gc \
--without-cxx --with-signal-module --with-wctype-functions"
EXTRA_OEMAKE = 'BUILD_SYS="" HOST_SYS=""'
-#do_configure() {
-# # the autofoo stuff is too old to allow regenerating
-# oe_runconf
-#}
-
do_stage_append() {
install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/
}
diff --git a/packages/python/python-setuptools-native_0.6c6.bb b/packages/python/python-setuptools-native_0.6c8.bb
index b7716d8cac..b7716d8cac 100644
--- a/packages/python/python-setuptools-native_0.6c6.bb
+++ b/packages/python/python-setuptools-native_0.6c8.bb
diff --git a/packages/python/python-setuptools_0.6c6.bb b/packages/python/python-setuptools_0.6c8.bb
index fe78e585f7..19f73d3f67 100644
--- a/packages/python/python-setuptools_0.6c6.bb
+++ b/packages/python/python-setuptools_0.6c8.bb
@@ -5,7 +5,7 @@ PRIORITY = "optional"
LICENSE = "MIT-like"
RDEPENDS = "python-distutils python-compression"
SRCNAME = "setuptools"
-PR = "ml2"
+PR = "ml0"
SRC_URI = "http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz"
S = "${WORKDIR}/${SRCNAME}-${PV}"
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index 22aac7c9ee..9617871fff 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
# bump this on every change in contrib/python/generate-manifest-2.5.py
-PR = "ml4"
+PR = "ml6"
PYTHON_MAJMIN = "2.5"