summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2007-03-23 11:06:52 +0000
committerMarcin Juszkiewicz <hrw@openembedded.org>2007-03-23 11:06:52 +0000
commitaecc06a22bfbba7a2ec7242183fc2aaf2305cf1c (patch)
tree7a0b5b4315ff3b2d6cc424f844c5cc6456a88b16 /packages/python
parent9ca244720e005906aa4292159689d81ea2dd5751 (diff)
python-gst: updated to 0.10.7, added fix to get it built on 64bit (from Poky)
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-gst/.mtn2git_empty0
-rw-r--r--packages/python/python-gst/python-path.patch24
-rw-r--r--packages/python/python-gst_0.10.6.bb16
-rw-r--r--packages/python/python-gst_0.10.7.bb22
4 files changed, 46 insertions, 16 deletions
diff --git a/packages/python/python-gst/.mtn2git_empty b/packages/python/python-gst/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-gst/.mtn2git_empty
diff --git a/packages/python/python-gst/python-path.patch b/packages/python/python-gst/python-path.patch
new file mode 100644
index 0000000000..465d5b180a
--- /dev/null
+++ b/packages/python/python-gst/python-path.patch
@@ -0,0 +1,24 @@
+Index: gst-python-0.10.7/acinclude.m4
+===================================================================
+--- gst-python-0.10.7.orig/acinclude.m4 2007-03-02 14:10:28.652128590 +0100
++++ gst-python-0.10.7/acinclude.m4 2007-03-02 14:41:00.106728708 +0100
+@@ -43,12 +43,19 @@
+ [AC_REQUIRE([AM_PATH_PYTHON])
+ AC_MSG_CHECKING(for headers required to compile python extensions)
+ dnl deduce PYTHON_INCLUDES
++
++AC_ARG_WITH(python-includes,
++ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
++if test x$py_exec_prefix != x; then
++PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
++else
+ py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+ py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+ PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+ if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+ fi
++fi
+ AC_SUBST(PYTHON_INCLUDES)
+ dnl check if the headers exist:
+ save_CPPFLAGS="$CPPFLAGS"
diff --git a/packages/python/python-gst_0.10.6.bb b/packages/python/python-gst_0.10.6.bb
deleted file mode 100644
index 28dba93cb5..0000000000
--- a/packages/python/python-gst_0.10.6.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-LICENSE = "GPL"
-DESCRIPTION = "Python gstreamer Bindings"
-SECTION = "devel/python"
-HOMEPAGE = "http://gstreamer.freedesktop.org"
-PRIORITY = "optional"
-#DEPENDS = "gstreamer"
-#RDEPENDS = "gstreamer"
-
-SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.gz"
-S = "${WORKDIR}/gst-python-${PV}"
-
-inherit autotools pkgconfig
-
-do_configure() {
- oe_runconf
-}
diff --git a/packages/python/python-gst_0.10.7.bb b/packages/python/python-gst_0.10.7.bb
new file mode 100644
index 0000000000..d206c0ab12
--- /dev/null
+++ b/packages/python/python-gst_0.10.7.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Python Gstreamer bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "gstreamer"
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gst-python/gst-python-${PV}.tar.bz2 \
+ file://python-path.patch;patch=1"
+
+S = "${WORKDIR}/gst-python-${PV}"
+
+inherit autotools distutils-base pkgconfig
+
+EXTRA_OECONF += "--with-python-includes=${STAGING_INCDIR}/../"
+
+do_configure_prepend() {
+ install -d ${S}/m4
+ install -m 0644 ${S}/common/m4/*.m4 ${S}/m4/
+}
+
+do_stage() {
+ autotools_stage_all
+}