summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-07-24 02:22:33 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-07-24 02:22:33 +0000
commit36bd4d761748b0f5d4b6bfe916dc183c9167672b (patch)
tree6720225a86b6a0890a329b3f9f66c6f3b04296f1 /packages/python
parent95518b26ac8b1a412ecbaa96823454d34ea10b53 (diff)
python-setuptools, python-simplejson: catch up with changes in distutils build class
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-setuptools_0.6c6.bb (renamed from packages/python/python-setuptools_0.6c5.bb)6
-rw-r--r--packages/python/python-simplejson_1.7.1.bb10
2 files changed, 2 insertions, 14 deletions
diff --git a/packages/python/python-setuptools_0.6c5.bb b/packages/python/python-setuptools_0.6c6.bb
index 0ee3a02229..ef56b9b652 100644
--- a/packages/python/python-setuptools_0.6c5.bb
+++ b/packages/python/python-setuptools_0.6c6.bb
@@ -5,7 +5,7 @@ PRIORITY = "optional"
LICENSE = "MIT-like"
RDEPENDS = "python-core python-zlib"
SRCNAME = "setuptools"
-PR = "r0"
+PR = "ml1"
SRC_URI = "http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz"
S = "${WORKDIR}/${SRCNAME}-${PV}"
@@ -20,7 +20,3 @@ do_stage() {
BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
${STAGING_BINDIR_NATIVE}/python setup.py install
}
-
-# Deal with .pth file error
-export PYTHONPATH="${D}/${libdir}/${PYTHON_DIR}/site-packages"
-
diff --git a/packages/python/python-simplejson_1.7.1.bb b/packages/python/python-simplejson_1.7.1.bb
index e41d9085af..129f4fb9eb 100644
--- a/packages/python/python-simplejson_1.7.1.bb
+++ b/packages/python/python-simplejson_1.7.1.bb
@@ -8,17 +8,9 @@ DEPENDS = "python-setuptools"
# python-zlib is needed to unpack egg created by setuptools
RDEPENDS = "python-core python-re python-io python-netserver python-zlib"
SRCNAME = "simplejson"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://cheeseshop.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz"
S = "${WORKDIR}/${SRCNAME}-${PV}"
inherit distutils
-
-do_install_prepend() {
- install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
-}
-
-# Deal with .pth file error
-export PYTHONPATH="${D}/${libdir}/python2.4/site-packages"
-