summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-23 11:53:53 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-23 11:53:53 +0000
commitd9b583873f4ee669a8576c2fbd3eb8ed70df6189 (patch)
treebb391191353bae03ff00211caa5925da49ca418b /packages/python
parentf1d0d79f48ab191a1ed0b5065e39046e1d95fef4 (diff)
parentf4c65cbaa1fe07d8e9d833a74afcd6812e246ba7 (diff)
merge of '630d91b636d9eb5ff3634efb7f7ed911fbd36602'
and 'e0613a176614c74d38f49dfbdb46b6f368ef64ca'
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-pygobject-native_2.12.2.bb3
-rw-r--r--packages/python/python-pygobject_2.12.2.bb23
2 files changed, 26 insertions, 0 deletions
diff --git a/packages/python/python-pygobject-native_2.12.2.bb b/packages/python/python-pygobject-native_2.12.2.bb
new file mode 100644
index 0000000000..c93950b31b
--- /dev/null
+++ b/packages/python/python-pygobject-native_2.12.2.bb
@@ -0,0 +1,3 @@
+require python-pygobject_${PV}.bb
+
+DEPENDS = "python-native"
diff --git a/packages/python/python-pygobject_2.12.2.bb b/packages/python/python-pygobject_2.12.2.bb
new file mode 100644
index 0000000000..1604b54715
--- /dev/null
+++ b/packages/python/python-pygobject_2.12.2.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Python GObject bindings"
+SECTION = "devel/python"
+LICENSE = "LGPL"
+DEPENDS = "python-pygobject-native"
+PR = "ml2"
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/pygobject/2.12/pygobject-${PV}.tar.bz2"
+S = "${WORKDIR}/pygobject-${PV}"
+
+inherit autotools distutils-base pkgconfig
+
+# otherwise the main package keeps snatching the .pc file away
+# and therefore depends on glib-2.0-dev (which only the -dev
+# package should).
+PACKAGES =+ "${PN}-dev"
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_LIBDIR}/../share/pygobject/
+ cp -dpfR docs/* ${STAGING_LIBDIR}/../share/pygobject/
+ install -d ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+ cp docs/style.css ${STAGING_LIBDIR}/../share/gtk-doc/html/pygobject/
+}