summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-02-28 15:52:21 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-02-28 15:52:21 +0000
commitcc1759e0dbf2f33f10ea6e620db4d543941f3e9c (patch)
treedf1219a9a932555c101ca34c25579cfd5c1bac47 /packages/python
parent344116414547c82ad8e16f53fc2ad5d7ace477e3 (diff)
python-m2crypto 0.18 update to 0.18.2 and bring back from nonworking
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-m2crypto/.mtn2git_empty0
-rw-r--r--packages/python/python-m2crypto/install.patch24
-rw-r--r--packages/python/python-m2crypto_0.18.2.bb18
3 files changed, 42 insertions, 0 deletions
diff --git a/packages/python/python-m2crypto/.mtn2git_empty b/packages/python/python-m2crypto/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/python/python-m2crypto/.mtn2git_empty
diff --git a/packages/python/python-m2crypto/install.patch b/packages/python/python-m2crypto/install.patch
new file mode 100644
index 0000000000..6c70ccf516
--- /dev/null
+++ b/packages/python/python-m2crypto/install.patch
@@ -0,0 +1,24 @@
+Index: m2crypto-0.18.2/setup.py
+===================================================================
+--- m2crypto-0.18.2.orig/setup.py
++++ m2crypto-0.18.2/setup.py
+@@ -38,7 +38,7 @@ class _M2CryptoBuildExt(build_ext.build_
+ self.openssl = 'c:\\pkg'
+ else:
+ self.libraries = ['ssl', 'crypto']
+- self.openssl = '/usr'
++ self.openssl = os.environ.get( "STAGING_DIR" )
+
+
+ def finalize_options(self):
+@@ -47,8 +47,8 @@ class _M2CryptoBuildExt(build_ext.build_
+
+ build_ext.build_ext.finalize_options(self)
+
+- opensslIncludeDir = os.path.join(self.openssl, 'include')
+- opensslLibraryDir = os.path.join(self.openssl, 'lib')
++ opensslIncludeDir = os.environ.get( "STAGING_INCDIR" )
++ opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" )
+
+ self.swig_opts = ['-I%s' % i for i in self.include_dirs + \
+ [opensslIncludeDir]]
diff --git a/packages/python/python-m2crypto_0.18.2.bb b/packages/python/python-m2crypto_0.18.2.bb
new file mode 100644
index 0000000000..c83a2ec076
--- /dev/null
+++ b/packages/python/python-m2crypto_0.18.2.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "A Python crypto and SSL toolkit"
+SECTION = "devel/python"
+PRIORITY = "optional"
+DEPENDS = "openssl swig-native"
+LICENSE = "BSD"
+SRCNAME = "M2Crypto"
+PR = "ml0"
+
+SRC_URI = "http://chandlerproject.org/pub/Projects/MeTooCrypto/m2crypto-${PV}.tar.gz \
+ file://install.patch;patch=1"
+S = "${WORKDIR}/m2crypto-0.18.2"
+
+inherit setuptools
+
+export STAGING_DIR := "${STAGING_DIR}"
+export STAGING_INCDIR := "${STAGING_INCDIR}"
+export STAGING_LIBDIR := "${STAGING_LIBDIR}"
+