summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2008-02-07 13:08:35 +0000
committerFlorian Boor <florian.boor@kernelconcepts.de>2008-02-07 13:08:35 +0000
commitbe3429189fb5eb2c12936f8d568bd8ba7d111ddc (patch)
tree3a96cda412e61a886aae321d88c6ed16bf994e51 /packages/python
parent6853e674e42ffa97b62d6354c38d15b075956ecd (diff)
parent28fee5ea2a5f032871b989acd23e6c4ac26287e4 (diff)
merge of '0f1b9dcedb4d611ce7ce7ca8935b934dbc44061c'
and '8dadec7d9f47d3e60f4729a152204227dce39c49'
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/python-2.5.1/sitecustomize.py6
-rw-r--r--packages/python/python_2.5.1.bb2
2 files changed, 4 insertions, 4 deletions
diff --git a/packages/python/python-2.5.1/sitecustomize.py b/packages/python/python-2.5.1/sitecustomize.py
index b5e78d3200..4c0ba3f0da 100644
--- a/packages/python/python-2.5.1/sitecustomize.py
+++ b/packages/python/python-2.5.1/sitecustomize.py
@@ -7,11 +7,11 @@
# * load command line history on startup
# * save command line history on exit
-HISTORY_FILENAME = "/tmp/python-history-file.txt"
+import os
def __exithandler():
try:
- readline.write_history_file( HISTORY_FILENAME )
+ readline.write_history_file( "%s/.python-history" % os.getenv( "HOME", "/tmp" ) )
except IOError:
pass
@@ -22,7 +22,7 @@ def __registerExitHandler():
def __enableReadlineSupport():
readline.parse_and_bind("tab: complete")
try:
- readline.read_history_file( "/tmp/python-history-file.txt" )
+ readline.read_history_file( "%s/.python-history" % os.getenv( "HOME", "/tmp" ) )
except IOError:
pass
diff --git a/packages/python/python_2.5.1.bb b/packages/python/python_2.5.1.bb
index b274b0d7f9..668c2a7833 100644
--- a/packages/python/python_2.5.1.bb
+++ b/packages/python/python_2.5.1.bb
@@ -7,7 +7,7 @@ DEPENDS = "python-native readline zlib gdbm openssl sqlite3 tcl tk"
DEPENDS_sharprom = "python-native readline zlib gdbm openssl"
# NOTE: Keep the digit in sync with BASEREV in contrib/generate-manifest-2.5.py
-PR = "ml7"
+PR = "ml8"
PYTHON_MAJMIN = "2.5"