summaryrefslogtreecommitdiff
path: root/packages/python
diff options
context:
space:
mode:
authorTom Rini <trini@embeddedalley.com>2009-02-06 00:52:22 -0500
committerTom Rini <trini@embeddedalley.com>2009-02-06 00:52:22 -0500
commit64a7ce5d1fbe1dc27ca66aeb1397fdb99a0bda0b (patch)
tree161b0282784671ed64c20913ae6ccca235d2b0ae /packages/python
parent76dd7c8587b23f31e530d6974dfd03d81cc5812e (diff)
parenta0522a8b0b5606d2c2601990d4212430ad459adb (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'packages/python')
-rw-r--r--packages/python/divmod.inc17
-rw-r--r--packages/python/python-coherence_svn.bb7
-rw-r--r--packages/python/python-divmodepsilon_0.5.11.bb7
-rw-r--r--packages/python/python-nevow_0.9.32.bb10
-rw-r--r--packages/python/python-twisted-native_8.2.0.bb7
5 files changed, 45 insertions, 3 deletions
diff --git a/packages/python/divmod.inc b/packages/python/divmod.inc
new file mode 100644
index 0000000000..20be1b2e38
--- /dev/null
+++ b/packages/python/divmod.inc
@@ -0,0 +1,17 @@
+SRC_URI = "http://divmod.org/trac/attachment/wiki/SoftwareReleases/${REALPN}-${PV}.tar.gz?format=raw"
+
+DEPENDS += "python-twisted-native"
+
+do_unpack2() {
+ cd ${WORKDIR}
+ tar zxvf ${REALPN}-${PV}.tar.gz?format=raw
+}
+
+addtask unpack2 after do_unpack before do_configure
+
+inherit distutils
+
+S = "${WORKDIR}/${REALPN}-${PV}"
+
+
+
diff --git a/packages/python/python-coherence_svn.bb b/packages/python/python-coherence_svn.bb
index c123bcfcbf..15c0b4f14f 100644
--- a/packages/python/python-coherence_svn.bb
+++ b/packages/python/python-coherence_svn.bb
@@ -3,9 +3,8 @@ SECTION = "python/devel"
LICENSE = "MIT"
HOMEPAGE = "http://coherence.beebits.net/wiki"
-PR = "r0"
+PR = "r3"
PV = "0.6.0+svnr${SRCREV}"
-DEFAULT_PREFERENCE = "-1"
inherit setuptools
@@ -13,6 +12,8 @@ SRC_URI = "svn://coherence.beebits.net/svn/trunk;module=Coherence;proto=https"
S = "${WORKDIR}/Coherence"
FILES_${PN} += "${datadir}"
-RDEPENDS_${PN} += "python-gst python-dbus python-configobj python-twisted python-twisted-core python-misc python-zopeinterface zope python-modules"
+RDEPENDS_${PN} += "python-twisted-pair python-divmodepsilon python-nevow python-gst python-dbus \
+ python-configobj python-twisted python-twisted-core python-misc python-zopeinterface \
+ zope python-modules"
diff --git a/packages/python/python-divmodepsilon_0.5.11.bb b/packages/python/python-divmodepsilon_0.5.11.bb
new file mode 100644
index 0000000000..5184b69252
--- /dev/null
+++ b/packages/python/python-divmodepsilon_0.5.11.bb
@@ -0,0 +1,7 @@
+DESCRIPTION = "A small utility package that depends on tools too recent for Twisted "
+LICENSE = "MIT"
+
+REALPN = "Epsilon"
+
+require divmod.inc
+
diff --git a/packages/python/python-nevow_0.9.32.bb b/packages/python/python-nevow_0.9.32.bb
new file mode 100644
index 0000000000..155157c517
--- /dev/null
+++ b/packages/python/python-nevow_0.9.32.bb
@@ -0,0 +1,10 @@
+DESCRIPTION = "Nevow is a web application construction kit written in Python"
+LICENSE = "MIT"
+
+REALPN = "Nevow"
+
+require divmod.inc
+
+FILES_${PN} += "${datadir}"
+DEPENDS += "python-twisted-native"
+
diff --git a/packages/python/python-twisted-native_8.2.0.bb b/packages/python/python-twisted-native_8.2.0.bb
new file mode 100644
index 0000000000..063f0fdb13
--- /dev/null
+++ b/packages/python/python-twisted-native_8.2.0.bb
@@ -0,0 +1,7 @@
+require python-twisted_${PV}.bb
+
+inherit native
+
+do_stage() {
+ distutils_stage_all
+}